summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/amazon-ecr-credential-helper/amazon-ecr-credential-helper-0.6.0.ebuild')
-rw-r--r--app-containers/amazon-ecr-credential-helper/amazon-ecr-credential-helper-0.6.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-containers/amazon-ecr-credential-helper/amazon-ecr-credential-helper-0.6.0.ebuild b/app-containers/amazon-ecr-credential-helper/amazon-ecr-credential-helper-0.6.0.ebuild
new file mode 100644
index 0000000..e3e8a14
--- /dev/null
+++ b/app-containers/amazon-ecr-credential-helper/amazon-ecr-credential-helper-0.6.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+EGO_PN=github.com/awslabs/${PN}
+
+inherit go-module
+
+EGO_VER="v${PV}"
+SRC_URI="https://github.com/awslabs/${PN}/archive/${EGO_VER}.tar.gz -> ${P}.tar.gz"
+
+DESCRIPTION="Automatically gets credentials for Amazon ECR on docker push/docker pull"
+HOMEPAGE="https://github.com/awslabs/amazon-ecr-credential-helper"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${P}/ecr-login"
+
+src_compile() {
+ ego build -v -work ${EGO_PN}/ecr-login/cli/docker-credential-ecr-login
+ echo "$@"
+ "$@" || die
+}
+
+src_install() {
+ dobin docker-credential-ecr-login
+}