summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChen, Chih-Chia <pigfoot@gmail.com>2016-11-01 17:29:00 +0800
committerChen, Chih-Chia <pigfoot@gmail.com>2016-11-01 17:29:00 +0800
commit7f3d43d400b53b943786e376bbcdef35a33c935a (patch)
tree4bfdd1045e9aa6e4861fa4febf977227287cdafe /sci-libs
parent[app-admin/google-compute-engine] Revert to boto (diff)
downloadpigfoot-7f3d43d400b53b943786e376bbcdef35a33c935a.tar.gz
pigfoot-7f3d43d400b53b943786e376bbcdef35a33c935a.tar.bz2
pigfoot-7f3d43d400b53b943786e376bbcdef35a33c935a.zip
Add sci-libs/xgboost
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/xgboost/metadata.xml9
-rw-r--r--sci-libs/xgboost/xgboost-0.60.ebuild25
-rw-r--r--sci-libs/xgboost/xgboost-9999.ebuild25
3 files changed, 59 insertions, 0 deletions
diff --git a/sci-libs/xgboost/metadata.xml b/sci-libs/xgboost/metadata.xml
new file mode 100644
index 0000000..bc5971a
--- /dev/null
+++ b/sci-libs/xgboost/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>pigfoot@gmail.com</email>
+ <name>Chen, Chih-Chia</name>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-libs/xgboost/xgboost-0.60.ebuild b/sci-libs/xgboost/xgboost-0.60.ebuild
new file mode 100644
index 0000000..a7c8cb1
--- /dev/null
+++ b/sci-libs/xgboost/xgboost-0.60.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Scalable, Portable and Distributed Gradient Boosting."
+HOMEPAGE="https://github.com/dmlc/xgboost"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/dmlc/xgboost.git"
+ inherit git-r3
+else
+ EGIT_COMMIT="4a8d63b6c8711fb839c71e26c659936252df1eb5"
+ EGIT_REPO_URI="git://github.com/dmlc/xgboost.git"
+ KEYWORDS="~amd64 ~x86"
+ inherit git-r3
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=sys-devel/gcc-4.6"
+RDEPEND="${DEPEND}"
diff --git a/sci-libs/xgboost/xgboost-9999.ebuild b/sci-libs/xgboost/xgboost-9999.ebuild
new file mode 100644
index 0000000..96c66e2
--- /dev/null
+++ b/sci-libs/xgboost/xgboost-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Scalable, Portable and Distributed Gradient Boosting."
+HOMEPAGE="https://github.com/dmlc/xgboost"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/dmlc/xgboost.git"
+ inherit git-r3
+else
+ EGIT_COMMIT=v${PV}
+ SRC_URI="https://github.com/dmlc/xgboost/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ inherit vcs-snapshot
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=sys-devel/gcc-4.6"
+RDEPEND="${DEPEND}"