summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPalmer Dabbelt <palmer@dabbelt.com>2016-02-14 12:45:36 -0800
committerPalmer Dabbelt <palmer@dabbelt.com>2016-02-14 12:50:14 -0800
commiteb50ff59553e8c2cb0703281fcd4025a5e8e2d5f (patch)
treeba1e9157b7481ea33f4e0d3076746c43a99c11f4 /sci-electronics
parentBump putil and drop circular dependency (diff)
downloadpalmer-eb50ff59553e8c2cb0703281fcd4025a5e8e2d5f.tar.gz
palmer-eb50ff59553e8c2cb0703281fcd4025a5e8e2d5f.tar.bz2
palmer-eb50ff59553e8c2cb0703281fcd4025a5e8e2d5f.zip
Add a Synopsys Installer ebuild
I can't run Custom Designer on my machine without some workarounds, so I'm going to go ahead and add packages for some Synopsys tools now. Since these don't actually fetch anything I think they're fine.
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/synopsys-installer/Manifest2
-rw-r--r--sci-electronics/synopsys-installer/synopsys-installer-3.2.ebuild22
2 files changed, 24 insertions, 0 deletions
diff --git a/sci-electronics/synopsys-installer/Manifest b/sci-electronics/synopsys-installer/Manifest
new file mode 100644
index 0000000..cbd3df2
--- /dev/null
+++ b/sci-electronics/synopsys-installer/Manifest
@@ -0,0 +1,2 @@
+DIST SynopsysInstaller_v3.2.run 12160218 SHA256 98de7a9f32d5a1deb3f0f2463e97f6c453540c6f6f9a6d8d4373754844e99037 SHA512 ce41e1259d25bc13d138b18848ed6418ad167944413ca1eae966eed65fe268aec2ffe418171045e5f27ac49a00ec69d9a83f3cafe8e55f74933490364b6a86df WHIRLPOOL c7d63c72239d7486184619c4e161a30ef181463aa723d3bc7f51597f3db318f56372f0ff480aecdc02fcf588a1ddca7f0189a15e8260187890e40a021f9dc126
+EBUILD synopsys-installer-3.2.ebuild 357 SHA256 eefdc2f23419fd1010d677251fca1370d23b12708b9d9330b8cc72738d314ad0 SHA512 e06299e6071161101c3869e539c4c250a6cd9f47baaef739145cdd7ec6b21fa90e0b92c2757ea359d2b1350646027d52456e4f49ef3394362aa0e9d608d0fab9 WHIRLPOOL d379948f4ca0632b0828e697903bb9d3d8645dc232aaba0925ad37404c1a0db1c39190913b79d1d393461744e3c1ef8ec06384432309b0f189b119375e0998c3
diff --git a/sci-electronics/synopsys-installer/synopsys-installer-3.2.ebuild b/sci-electronics/synopsys-installer/synopsys-installer-3.2.ebuild
new file mode 100644
index 0000000..b3fd7dc
--- /dev/null
+++ b/sci-electronics/synopsys-installer/synopsys-installer-3.2.ebuild
@@ -0,0 +1,22 @@
+EAPI=5
+
+DESCRIPTION="Synopsys's Software Installer"
+HOMEPAGE="http://www.synopsys.com/install"
+SRC_URI="SynopsysInstaller_v3.2.run"
+RESTRICT="fetch strip"
+
+LICENSE=""
+SLOT="${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ mkdir -p "${S}"
+}
+
+src_install() {
+ perl "${DISTDIR}/${A}" -dir ${ED}/opt/synopsys/installer/${PV}
+}