summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPalmer Dabbelt <palmer@dabbelt.com>2019-07-04 01:26:03 -0700
committerPalmer Dabbelt <palmer@dabbelt.com>2019-07-04 01:26:03 -0700
commit86d7848eb0ef559e866377617b9319579771a3e6 (patch)
tree1818721b90bc871562d3dc2d5b43f90e150475ac
parentAdd Segger's JLink tool (diff)
downloadpalmer-86d7848eb0ef559e866377617b9319579771a3e6.tar.gz
palmer-86d7848eb0ef559e866377617b9319579771a3e6.tar.bz2
palmer-86d7848eb0ef559e866377617b9319579771a3e6.zip
Add gsed wrapper
Signed-off-by: Palmer Dabbelt <palmer@dabbelt.com>
-rw-r--r--app-text/gsed/gsed-1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-text/gsed/gsed-1.ebuild b/app-text/gsed/gsed-1.ebuild
new file mode 100644
index 0000000..a7fdddf
--- /dev/null
+++ b/app-text/gsed/gsed-1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="GNU sed wrapper"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-apps/sed"
+BDEPEND=""
+
+src_unpack() {
+ mkdir -p ${S}
+}
+
+src_install() {
+ mkdir -p ${ED}/usr/bin
+ ln -s /bin/sed ${ED}/usr/bin/gsed
+}