summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNico Suhl <nico@overninethousand.de>2017-03-06 22:27:50 +0100
committerNico Suhl <nico@overninethousand.de>2017-03-06 22:27:50 +0100
commit87832ef3004f46d6492e29137be28a8eaf6af402 (patch)
tree715e6f0951513545b8bf23be9802ca3734236f67
parentfix naming error while updating telegraf (diff)
downloadnico-87832ef3004f46d6492e29137be28a8eaf6af402.tar.gz
nico-87832ef3004f46d6492e29137be28a8eaf6af402.tar.bz2
nico-87832ef3004f46d6492e29137be28a8eaf6af402.zip
add atom-bin
-rw-r--r--app-editors/atom-bin/Manifest1
-rw-r--r--app-editors/atom-bin/atom-bin-1.14.4.ebuild31
-rw-r--r--app-editors/atom-bin/metadata.xml12
3 files changed, 44 insertions, 0 deletions
diff --git a/app-editors/atom-bin/Manifest b/app-editors/atom-bin/Manifest
new file mode 100644
index 0000000..ed872e0
--- /dev/null
+++ b/app-editors/atom-bin/Manifest
@@ -0,0 +1 @@
+DIST atom-amd64.deb 86270902 SHA256 fbab0fc2d1fedc31b712ac2ad0a35c66e22b7267859a187f9c522f782f5c2d2c SHA512 94b55b124c799c394a318d1915dc9ddcb994887e90474373387bce43729378e02cc14b051fbc4b69746080c5753201b294e1571338481484cdd00a1fc16c113a WHIRLPOOL 3eeaf06947a7ef5463053c061b8ab0a679e2a52453c6db6f5e6c6de796f4ca92c455047f6bc0dad47c75b2c315d4f6ef646b075fb477f44886f745dd8d4018fe
diff --git a/app-editors/atom-bin/atom-bin-1.14.4.ebuild b/app-editors/atom-bin/atom-bin-1.14.4.ebuild
new file mode 100644
index 0000000..5d7d17b
--- /dev/null
+++ b/app-editors/atom-bin/atom-bin-1.14.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit unpacker
+
+MY_PN="atom"
+DESCRIPTION="A hackable text editor for the 21st Century"
+HOMEPAGE="https://atom.io"
+SRC_URI="https://github.com/atom/atom/releases/download/v${PV}/${MY_PN}-amd64.deb"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RESTRICT="mirror"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ mkdir -p ${WORKDIR}/${P}
+ cd ${WORKDIR}/${P}
+ unpack_deb ${A}
+}
+
+src_install() {
+ cp -Rp * "${D}"
+}
diff --git a/app-editors/atom-bin/metadata.xml b/app-editors/atom-bin/metadata.xml
new file mode 100644
index 0000000..3be2fce
--- /dev/null
+++ b/app-editors/atom-bin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>nico@overninethousand.de</email>
+ </maintainer>
+ <longdescription lang="en">
+ Atom is a text editor that's modern, approachable, yet hackable to the
+ core—a tool you can customize to do anything but also use productively
+ without ever touching a config file.
+ </longdescription>
+</pkgmetadata>