summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNico Suhl <nico@overninethousand.de>2016-01-07 02:04:38 +0100
committerNico Suhl <nico@overninethousand.de>2016-01-07 02:04:38 +0100
commit10ad6241959bbb17c3e8eaae8a5d121bc31c6422 (patch)
treefbef7df34c5f3b57e1f82cdfb6cec22604f391c7
parentcleanup, thanks @sping for feedback! (diff)
downloadnico-10ad6241959bbb17c3e8eaae8a5d121bc31c6422.tar.gz
nico-10ad6241959bbb17c3e8eaae8a5d121bc31c6422.tar.bz2
nico-10ad6241959bbb17c3e8eaae8a5d121bc31c6422.zip
add REQUIRED_USE
-rw-r--r--dev-python/basiciw/basiciw-9999.ebuild1
-rw-r--r--dev-python/colour/colour-0.1.2.ebuild1
-rw-r--r--dev-python/dota2py/dota2py-9999.ebuild1
-rw-r--r--dev-python/pywapi/pywapi-0.3.8.ebuild1
-rw-r--r--x11-plugins/pipe2pidgin/pipe2pidgin-20130710.ebuild7
5 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/basiciw/basiciw-9999.ebuild b/dev-python/basiciw/basiciw-9999.ebuild
index e0453e0..5cb6b8c 100644
--- a/dev-python/basiciw/basiciw-9999.ebuild
+++ b/dev-python/basiciw/basiciw-9999.ebuild
@@ -15,6 +15,7 @@ LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="net-wireless/wireless-tools"
RDEPEND="${DEPEND}"
diff --git a/dev-python/colour/colour-0.1.2.ebuild b/dev-python/colour/colour-0.1.2.ebuild
index 9dca44c..827e378 100644
--- a/dev-python/colour/colour-0.1.2.ebuild
+++ b/dev-python/colour/colour-0.1.2.ebuild
@@ -16,6 +16,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
src_install() {
python_foreach_impl python_domodule ${PN}.py
diff --git a/dev-python/dota2py/dota2py-9999.ebuild b/dev-python/dota2py/dota2py-9999.ebuild
index b7db5e0..cdcb35b 100644
--- a/dev-python/dota2py/dota2py-9999.ebuild
+++ b/dev-python/dota2py/dota2py-9999.ebuild
@@ -14,6 +14,7 @@ EGIT_REPO_URI="https://github.com/andrewsnowden/dota2py.git"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="dev-python/requests[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
diff --git a/dev-python/pywapi/pywapi-0.3.8.ebuild b/dev-python/pywapi/pywapi-0.3.8.ebuild
index b3ae2b3..5b07d05 100644
--- a/dev-python/pywapi/pywapi-0.3.8.ebuild
+++ b/dev-python/pywapi/pywapi-0.3.8.ebuild
@@ -16,6 +16,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
python_install_all() {
use examples && local EXAMPLES=( examples/. )
diff --git a/x11-plugins/pipe2pidgin/pipe2pidgin-20130710.ebuild b/x11-plugins/pipe2pidgin/pipe2pidgin-20130710.ebuild
index 37e4794..05a95f7 100644
--- a/x11-plugins/pipe2pidgin/pipe2pidgin-20130710.ebuild
+++ b/x11-plugins/pipe2pidgin/pipe2pidgin-20130710.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Id$
EAPI=5
@@ -21,6 +21,5 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="net-im/pidgin[dbus]
- virtual/python-argparse"
+ virtual/python-argparse[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
-