summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2023-02-11 06:25:11 +0100
committerMartin Väth <martin@mvath.de>2023-02-11 06:25:11 +0100
commit7627afd3c99e401a953277350815d7e71448143d (patch)
tree63913572ae568dff7ccdeece4c90978f89e67a9f
parentapp-portage/portage-bashrc-mv: Version bump (diff)
downloadmv-7627afd3c99e401a953277350815d7e71448143d.tar.gz
mv-7627afd3c99e401a953277350815d7e71448143d.tar.bz2
mv-7627afd3c99e401a953277350815d7e71448143d.zip
sys-apps/less: Revision bump for security fix
Signed-off-by: Martin Väth <martin@mvath.de>
-rw-r--r--metadata/pkg_desc_index2
-rw-r--r--sys-apps/less/files/less-608-CVE-2022-46663.patch22
-rw-r--r--sys-apps/less/less-608-r2.ebuild (renamed from sys-apps/less/less-608-r1.ebuild)6
3 files changed, 27 insertions, 3 deletions
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 7e70eb1b..1ab1a412 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -95,7 +95,7 @@ net-print/foo2zjs 20200221: Support for printing to ZjStream-based printers
sci-geosciences/googleearth 7.1.8.3036-r3 7.3.0.3832-r3 7.3.4-r1: A 3D interface to the planet
sci-mathematics/reduce 20141130-r3 20190413: A general-purpose computer algebra system
sys-apps/cpi 3.2: A wrapper for cp -i -a, making use of diff
-sys-apps/less 608-r1: Excellent text file viewer, optionally with additional selection feature
+sys-apps/less 608-r2: Excellent text file viewer, optionally with additional selection feature
sys-apps/man 1.6g-r4: Standard commands to read man pages
sys-apps/openrc-wrapper 2.4: Use openrc init scripts with systemd or other init systems
sys-apps/paxopen 1.2: A wrapper script to set PAX kernel variables to an insecure/safe state
diff --git a/sys-apps/less/files/less-608-CVE-2022-46663.patch b/sys-apps/less/files/less-608-CVE-2022-46663.patch
new file mode 100644
index 00000000..a358dd6f
--- /dev/null
+++ b/sys-apps/less/files/less-608-CVE-2022-46663.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/893530
+https://github.com/gwsw/less/commit/a78e1351113cef564d790a730d657a321624d79c
+
+From a78e1351113cef564d790a730d657a321624d79c Mon Sep 17 00:00:00 2001
+From: Mark Nudelman <markn@greenwoodsoftware.com>
+Date: Fri, 7 Oct 2022 19:25:46 -0700
+Subject: [PATCH] End OSC8 hyperlink on invalid embedded escape sequence.
+
+--- a/line.c
++++ b/line.c
+@@ -633,8 +633,8 @@ ansi_step(pansi, ch)
+ /* Hyperlink ends with \7 or ESC-backslash. */
+ if (ch == '\7')
+ return ANSI_END;
+- if (pansi->prev_esc && ch == '\\')
+- return ANSI_END;
++ if (pansi->prev_esc)
++ return (ch == '\\') ? ANSI_END : ANSI_ERR;
+ pansi->prev_esc = (ch == ESC);
+ return ANSI_MID;
+ }
+
diff --git a/sys-apps/less/less-608-r1.ebuild b/sys-apps/less/less-608-r2.ebuild
index fc033f1d..6fb89abc 100644
--- a/sys-apps/less/less-608-r1.ebuild
+++ b/sys-apps/less/less-608-r2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors and Martin V\"ath
+# Copyright 1999-2023 Gentoo Authors and Martin V\"ath
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+
WANT_AUTOMAKE=none
WANT_LIBTOOL=none
-
inherit autotools
DESCRIPTION="Excellent text file viewer, optionally with additional selection feature"
@@ -47,7 +47,9 @@ src_prepare() {
fi
local PATCHES=(
"${FILESDIR}/less-608-procfs.patch"
+ "${FILESDIR}/less-608-CVE-2022-46663.patch"
)
+
default
# Upstream uses unpatched autoconf-2.69, which breaks with clang-16.
# https://bugs.gentoo.org/870412