aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2015-03-17 12:56:27 +0000
committerPaul Healy <lmiphay@gmail.com>2015-03-17 12:56:27 +0000
commitedaf455f8553259cb7ed12d7a7ae784476f98047 (patch)
treeaa8b5c808107834d93b05cb023a3824c2b25a82b /x11-misc/xphoon
parentadd trouble shooting hints (diff)
downloadlmiphay-edaf455f8553259cb7ed12d7a7ae784476f98047.tar.gz
lmiphay-edaf455f8553259cb7ed12d7a7ae784476f98047.tar.bz2
lmiphay-edaf455f8553259cb7ed12d7a7ae784476f98047.zip
updated ebuild based on the old one in the xmw overlay
Diffstat (limited to 'x11-misc/xphoon')
-rw-r--r--x11-misc/xphoon/Manifest2
-rw-r--r--x11-misc/xphoon/xphoon-20140814.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/x11-misc/xphoon/Manifest b/x11-misc/xphoon/Manifest
new file mode 100644
index 0000000..8e72fd8
--- /dev/null
+++ b/x11-misc/xphoon/Manifest
@@ -0,0 +1,2 @@
+DIST xphoon_14Aug2014.tar.gz 103903 SHA256 64da210d4b2614b5ce442c8271d4b384fbe10026e813776c878b09a2c10fa1ba SHA512 6f0cf53b305cbf15d3b28fdfbcf49ff78689d49fb7b95815b590f3d42f43bda31df1bfd515eefa849579f9055f004cc7bf901741d98e2a10ac4841cc4ed95a00 WHIRLPOOL 6d4500aa1a951df31dc1ce5af859f47f4f0515617854a95443b65b52acedbfc0162d47fc76a01f0a90f3e6652d8bad0e75890e80e5e041af539ff2aea4e30214
+EBUILD xphoon-20140814.ebuild 768 SHA256 03ed6fcd52bdc799168f997027aba71314a16522813d8134645751a12bac3cad SHA512 6db066f13e80d053f5100990f2071d308c2db927e447b36ae8a0c13c655dcdd7f4d7384e7fbaca4ff281fa9ee18f0e280b9355ae1e21c7fa6d68c65e59c0adf1 WHIRLPOOL ba9d353ebd288ca832185c016ba8e8f9d686e87c9916745c2e4801f2cc97bf0957c4b784d0e4cf711929093c16e0a2e4a7d3f8812b1f02493fa01e99eba26420
diff --git a/x11-misc/xphoon/xphoon-20140814.ebuild b/x11-misc/xphoon/xphoon-20140814.ebuild
new file mode 100644
index 0000000..fc40f63
--- /dev/null
+++ b/x11-misc/xphoon/xphoon-20140814.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="sets X the root window to a picture of the moon in its current phase"
+HOMEPAGE="http://acme.com/software/xphoon/"
+
+MY_PV="14Aug2014"
+SRC_URI="http://acme.com/software/${PN}/${PN}_${MY_PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-misc/xbitmaps
+"
+DEPEND="${RDEPEND}
+ x11-misc/imake"
+
+S="${WORKDIR}/${PN}"
+
+src_configure() {
+ xmkmf || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CCOPTIONS="${CFLAGS}" EXTRA_LDOPTIONS="${LDFLAGS}" || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ newman ${PN}.man ${PN}.1 || die
+ dodoc README || die
+}