summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-08-23 14:43:06 +0200
committerMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-08-23 14:43:06 +0200
commit8a0e1481bfb7ee1bc52ff87cd0c1cfea7acd3641 (patch)
tree3a31075a52d9d282e4af7f893348574b6fdca440 /x11-libs
parentupdate gnome2-live eclass (diff)
downloadkeruspe-8a0e1481bfb7ee1bc52ff87cd0c1cfea7acd3641.tar.gz
keruspe-8a0e1481bfb7ee1bc52ff87cd0c1cfea7acd3641.tar.bz2
keruspe-8a0e1481bfb7ee1bc52ff87cd0c1cfea7acd3641.zip
add gitg scm
Signed-off-by: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtksourceview/Manifest2
-rw-r--r--x11-libs/gtksourceview/files/2.0/gentoo.lang111
-rw-r--r--x11-libs/gtksourceview/gtksourceview-9999-r1.ebuild65
3 files changed, 178 insertions, 0 deletions
diff --git a/x11-libs/gtksourceview/Manifest b/x11-libs/gtksourceview/Manifest
new file mode 100644
index 00000000..897f7e54
--- /dev/null
+++ b/x11-libs/gtksourceview/Manifest
@@ -0,0 +1,2 @@
+AUX 2.0/gentoo.lang 3910 RMD160 43b51212ec2787b9d95e9d4f512342b920d6c355 SHA1 22ce79797f654f1f7b6894de8cb12bbdcdf70bee SHA256 fcb5133892038174826d9ee1a720ec7204f3842c7bd3e9aabf0532b408e663d1
+EBUILD gtksourceview-9999-r1.ebuild 1696 RMD160 d41549f36f8fcf5cde2bb03e836caf91a3bc68e6 SHA1 92d4534804183130cd26ca74e6633caf5faf27cd SHA256 a14d1db82d70068e923a6e65b8d7a239009cb0277a66e22e792fb5dfd032f5a2
diff --git a/x11-libs/gtksourceview/files/2.0/gentoo.lang b/x11-libs/gtksourceview/files/2.0/gentoo.lang
new file mode 100644
index 00000000..f1e0660c
--- /dev/null
+++ b/x11-libs/gtksourceview/files/2.0/gentoo.lang
@@ -0,0 +1,111 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!--
+ GtkSourceView syntax highlight for Gentoo-specific files
+
+ Originally written for gtksourceview-1.x by:
+ Leonardo Ferreira Fontenelle <leo.fontenelle@gmail.com>, 2006.
+ Rewritten for gtksourceview-2 by:
+ Rene 'Necoro' Neumann <necoro@necoro.net>, 2007
+
+ Distributed under the same license(s) as gtksourceview.
+
+ TODO:
+ - do not highlight "enable" in the configure options
+ - perhaps highlight portage variables and portage functions different
+
+-->
+
+<language name="gentoo" id="gentoo" version="2.0" _section="Scripts">
+ <metadata>
+ <property name="globs">*.ebuild;*.eclass</property>
+ <property name="line-comment-start">#</property>
+ </metadata>
+
+ <styles>
+ <style id="variable" _name="Portage variables" map-to="def:builtin" />
+ <style id="command" _name="Portage command" map-to="def:type" />
+ <style id="function" _name="Portage function" map-to="def:function" />
+ <style id="string" _name="String" map-to="def:string" />
+ </styles>
+
+ <definitions>
+
+ <!-- rewrite shell string to show highlighted variables -->
+ <context id="string" style-ref="def:string">
+ <start>"</start>
+ <end>"</end>
+ <include>
+ <context ref="def:escape"/>
+ <context ref="def:line-continue"/>
+ <context ref="sh:variable"/>
+ </include>
+ </context>
+
+ <context id="string-2" style-ref="def:string">
+ <start>'</start>
+ <end>'</end>
+ <include>
+ <context ref="def:escape"/>
+ <context ref="def:line-continue"/>
+ <context ref="sh:variable"/>
+ </include>
+ </context>
+
+ <!-- subprograms:
+ - $(..) is not supported currently in the normal sh.lang
+ - `...` is interpreted as string - I think the subshell behavior is more acurate -->
+ <context id="subprogram">
+ <start>\$\(</start>
+ <end>\)</end>
+ <include>
+ <context sub-pattern="0" where="start" style-ref="sh:keyword"/>
+ <context sub-pattern="0" where="end" style-ref="sh:keyword"/>
+ <context ref="gentoo"/>
+ </include>
+ </context>
+
+ <context id="subprogram-2">
+ <start>`</start>
+ <end>`</end>
+ <include>
+ <context sub-pattern="0" where="start" style-ref="sh:keyword"/>
+ <context sub-pattern="0" where="end" style-ref="sh:keyword"/>
+ <context ref="gentoo"/>
+ </include>
+ </context>
+
+ <!-- portage variables - currently unused -->
+ <context id="portvars" style-ref="variable">
+ <match>\b((ARCH|HOMEPAGE|DESCRIPTION|IUSE|SRC_URI|LICENSE|SLOT|KEYWORDS|FILESDIR|WORKDIR|(P|R)?DEPEND|PROVIDE|DISTDIR|RESTRICT|USERLAND)|(S|D|T|PV|PF|P|PN|A)|C(XX)?FLAGS|LDFLAGS|C(HOST|TARGET|BUILD))\b</match>
+ </context>
+
+ <!-- portage functions - currently unused -->
+ <context id="portfuncs" style-ref="function">
+ <match>^(src_(unpack|compile|install|test)|pkg_(config|nofetch|setup|(pre|post)(inst|rm)))</match>
+ </context>
+
+ <!-- extra portage commands -->
+ <context id="portcmds" style-ref="command">
+ <match>\b(e(begin|end|conf|install|make|warn|infon?|error|patch)|die|use(_(with|enable))?|inherit|has|(has|best)_version|unpack|(do|new)(ins|s?bin|doc|lib(|\.so|\.a)|man|info|exe|initd|confd|envd|pam|menu|icon)|do(python|sed|dir|hard|sym|html|jar|mo)|keepdir|prepall(|docs|info|man|strip)|prep(info|lib|lib\.(so|a)|man|strip)|(|doc|ins|exe)into|f(owners|perms)|(exe|ins|dir)opts)\b</match>
+ </context>
+
+ <context id="built-in-command">
+ <include> <!-- do not include "sh:built-in-command" as it is replaced down there - which would lead to an endless loop -->
+ <context ref="sh:built-in-command-1" />
+ <context ref="sh:built-in-command-2" />
+ <context ref="portcmds" />
+ </include>
+ </context>
+
+ <!-- gentoo is just a shell with the replacements -->
+ <replace id="sh:built-in-command" ref="built-in-command" />
+ <replace id="sh:backtick-subshell" ref="subprogram-2" />
+ <context id="gentoo">
+ <include>
+ <context ref="subprogram"/>
+ <context ref="sh:sh"/>
+ </include>
+ </context>
+ </definitions>
+</language>
diff --git a/x11-libs/gtksourceview/gtksourceview-9999-r1.ebuild b/x11-libs/gtksourceview/gtksourceview-9999-r1.ebuild
new file mode 100644
index 00000000..93e59b46
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-9999-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/gtksourceview-3.0.4.ebuild,v 1.1 2011/06/20 11:45:03 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 virtualx
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="http://projects.gnome.org/gtksourceview/"
+
+LICENSE="GPL-2"
+SLOT="3.0"
+IUSE="doc glade +introspection"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+fi
+
+# Note: has native OSX support, prefix teams, attack!
+RDEPEND=">=x11-libs/gtk+-3.0:3[introspection?]
+ >=dev-libs/libxml2-2.6:2
+ >=dev-libs/glib-2.28:2
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.17
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1.11 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README"
+ G2CONF="${G2CONF}
+ --disable-deprecations
+ --enable-providers
+ $(use_enable glade glade-catalog)
+ $(use_enable introspection)"
+}
+
+src_prepare() {
+ # Skip broken test until upstream bug #621383 is solved
+ sed -e "/guess-language/d" \
+ -e "/get-language/d" \
+ -i tests/test-languagemanager.c || die
+
+ gnome2_src_prepare
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-3.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+}