summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-04-13 20:32:33 +0200
committerMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-04-13 20:32:33 +0200
commit7a0ddb840c699ff89e4a050021f3855a65ff703c (patch)
treefc33807b8c7ddb655254aa872f129a198b73ea6c /net-voip/telepathy-gabble
parentclean net-misc (diff)
downloadkeruspe-7a0ddb840c699ff89e4a050021f3855a65ff703c.tar.gz
keruspe-7a0ddb840c699ff89e4a050021f3855a65ff703c.tar.bz2
keruspe-7a0ddb840c699ff89e4a050021f3855a65ff703c.zip
clean net-voip
Signed-off-by: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
Diffstat (limited to 'net-voip/telepathy-gabble')
-rw-r--r--net-voip/telepathy-gabble/Manifest2
-rw-r--r--net-voip/telepathy-gabble/telepathy-gabble-0.11.10.ebuild17
2 files changed, 14 insertions, 5 deletions
diff --git a/net-voip/telepathy-gabble/Manifest b/net-voip/telepathy-gabble/Manifest
index a13b498d..24403bc0 100644
--- a/net-voip/telepathy-gabble/Manifest
+++ b/net-voip/telepathy-gabble/Manifest
@@ -1,2 +1,2 @@
-EBUILD telepathy-gabble-0.11.10.ebuild 1373 RMD160 b15555d4f29d0d136068dec3f14798a537f2527c SHA1 7d998418368dcfa51aaa0adb9c189fba14b20368 SHA256 d7e0f7de0db20c52b7b256eedbea875160435b9e198b9dbad800c63f59d0a9ae
+EBUILD telepathy-gabble-0.11.10.ebuild 1388 RMD160 cf28e63a480c3bc789475af780d817b5d9d1a60c SHA1 b2f86660003e7243560a22b013477414887f66f7 SHA256 1192db9300beda2fa9ba7055a6e8acdee678ed111e98d1873f4acd6d15e27cf9
DIST telepathy-gabble-0.11.10.tar.gz 3443486 RMD160 b4906a01b8cc6e6630e1707e97250bcdefeac9c4 SHA1 26ca4e8a98b01b78007f88caea56b08ae5070fdd SHA256 2167cac2cdea6df5f6d796c8ca4d23115598c93cd3c009c5c8cc643be5762a6e
diff --git a/net-voip/telepathy-gabble/telepathy-gabble-0.11.10.ebuild b/net-voip/telepathy-gabble/telepathy-gabble-0.11.10.ebuild
index e9ba0d4e..b7ece084 100644
--- a/net-voip/telepathy-gabble/telepathy-gabble-0.11.10.ebuild
+++ b/net-voip/telepathy-gabble/telepathy-gabble-0.11.10.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI="3"
PYTHON_DEPEND="2:2.5"
+
inherit eutils python
DESCRIPTION="A Jabber/XMPP connection manager, this handles single and multi user chats and voice calls."
@@ -12,28 +13,36 @@ SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="debug test"
RDEPEND=">=dev-libs/glib-2.24
>=sys-apps/dbus-1.1.0
>=dev-libs/dbus-glib-0.82
>=net-libs/telepathy-glib-0.14.3
- || ( >=net-libs/libsoup-2.33:2.4 <net-libs/libsoup-2.33:2.4[ssl] )
>=net-libs/libnice-0.0.11
>=net-libs/gnutls-2.10.2
+
dev-db/sqlite:3
dev-libs/libxml2
+
+ || ( net-libs/libsoup:2.4[ssl]
+ >=net-libs/libsoup-2.33.1 )
+
!<net-im/telepathy-mission-control-5.5.0"
DEPEND="${RDEPEND}
dev-libs/libxslt
- >=dev-lang/python-2.5
test? ( >=dev-python/twisted-0.8.2
>=dev-python/twisted-words-0.8.2
>=dev-python/dbus-python-0.83 )"
pkg_setup() {
python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
}
src_configure() {