aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/gdbm/gdbm-1.10-r1.ebuild')
-rw-r--r--sys-libs/gdbm/gdbm-1.10-r1.ebuild78
1 files changed, 0 insertions, 78 deletions
diff --git a/sys-libs/gdbm/gdbm-1.10-r1.ebuild b/sys-libs/gdbm/gdbm-1.10-r1.ebuild
deleted file mode 100644
index bbe5875..0000000
--- a/sys-libs/gdbm/gdbm-1.10-r1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="4"
-
-inherit flag-o-matic autotools-multilib
-
-EX_P="${PN}-1.8.3"
-DESCRIPTION="Standard GNU database libraries"
-HOMEPAGE="http://www.gnu.org/software/gdbm/"
-SRC_URI="mirror://gnu/gdbm/${P}.tar.gz
- exporter? ( mirror://gnu/gdbm/${EX_P}.tar.gz )"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+berkdb exporter static-libs"
-RDEPEND="abi_x86_32? (
- !<=app-emulation/emul-linux-x86-baselibs-20130224-r9
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
- )"
-DEPEND="${RDEPEND}"
-EX_S="${WORKDIR}"/${EX_P}
-
-src_configure() {
- # gdbm doesn't appear to use either of these libraries
- export ac_cv_lib_dbm_main=no ac_cv_lib_ndbm_main=no
-
- ehook autotools-multilib-per-abi-pre_src_configure \
- gdbm_pre_src_configure
-
- autotools-multilib_src_configure \
- --includedir="${EPREFIX}"/usr/include/gdbm \
- $(use_enable berkdb libgdbm-compat) \
- $(use_enable exporter gdbm-export) \
- $(use_enable static-libs static)
-}
-
-gdbm_pre_src_configure() {
- if use exporter ; then
- append-lfs-flags
- econf --disable-shared
- fi
- myeconfargs+=(
- --with-gdbm183-libdir="${BUILD_DIR}"/.libs
- --with-gdbm183-includedir="${BUILD_DIR}"
- )
- return 0
-}
-
-src_compile() {
- ehook autotools-multilib-per-abi-pre_src_compile \
- gdbm_pre_src_compile
- autotools-multilib_src_compile
-}
-
-gdbm_pre_src_compile() {
- cd "${BUILD_DIR}"
- if use exporter ; then
- autotools-utils_src_compile -C "${BUILD_DIR}" libgdbm.la
- fi
- return 0
-}
-
-src_install() {
- use static-libs || AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
- autotools-multilib_src_install
- mv "${ED}"/usr/include/gdbm/gdbm.h "${ED}"/usr/include/ || die
-}
-
-pkg_preinst() {
- preserve_old_lib libgdbm{,_compat}.so.{2,3} #32510
-}
-
-pkg_postinst() {
- preserve_old_lib_notify libgdbm{,_compat}.so.{2,3} #32510
-}