aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregory M. Tuner <gmt@be-evil.net>2013-11-26 14:27:37 -0800
committerGregory M. Tuner <gmt@be-evil.net>2013-11-26 14:27:37 -0800
commitf8ab0b12cbf460da9a2660a144a0009b75b291d9 (patch)
tree27bc4fa57c55d4e1ae70f7c606bbddfc5a74882b /sys-libs
parentnew ebuild: sys-apps/talloc (diff)
downloadgmt-f8ab0b12cbf460da9a2660a144a0009b75b291d9.tar.gz
gmt-f8ab0b12cbf460da9a2660a144a0009b75b291d9.tar.bz2
gmt-f8ab0b12cbf460da9a2660a144a0009b75b291d9.zip
waf-utils-multilib.eclass: inject libpath
To make waf-utils do the right thing with libpython, we must prevent it from pulling the libdirs from native python. To do so, I've injected them right at the front of LDFLAGS. For the record, this is an ugly hack that could potentially become problematic down the line. However, it does seem to work. With this in place, we no longer need emul-linux-x86-baselibs to provide libpytalloc-utils.so. Signed-off-by: Gregory M. Tuner <gmt@be-evil.net>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/talloc/Manifest2
-rw-r--r--sys-libs/talloc/talloc-2.1.0-r1.ebuild14
2 files changed, 1 insertions, 15 deletions
diff --git a/sys-libs/talloc/Manifest b/sys-libs/talloc/Manifest
index 444cbf3..78079eb 100644
--- a/sys-libs/talloc/Manifest
+++ b/sys-libs/talloc/Manifest
@@ -1,4 +1,4 @@
DIST talloc-2.1.0.tar.gz 416097 SHA256 0701393882647f823503e3aa075bc67d75c194b376822377dae2d20f9130f08f SHA512 7bdc448c91211299edf16502d263362ac660d5123d8ea7bb2ed58af2231537e4f29da5384b8d5be10254a02b193520890e95a73d697c40eba09728a9b6d56d57 WHIRLPOOL d8593cba27f5d971acb39acacdbea70df5b80ed31288cf440a2ebeaca266e070deeea8322f4ba5682580f66044128f18dd6d76b735aa0670aed46f13f5a4e857
-EBUILD talloc-2.1.0-r1.ebuild 3202 SHA256 a1deb5c4a53a20c64db8712d8b2db115be078948643e139db2042178cc335b66 SHA512 9c5d817ace6780744a37940c04cb81080e2d8da95d4430bf3325557f739172db90c7357523e6b535463354be224d21f6034a553be649af16482ba5b125780a43 WHIRLPOOL 95cf69a2989a5c2299df5474d6656e5613d7e3a898b43f0f008978333f7ed6b5a81d129956aeff202238ef5906d0de8d1f78288c263566006debf2584113a863
+EBUILD talloc-2.1.0-r1.ebuild 2042 SHA256 7e2b765e6e96a9d52e1ea501420153c4ba45f1692c85089aa5bf5053fca389a1 SHA512 5298c105de2075f9ffe427ea05f8cb24bfa4be54393407c20a05eb4870cf6f0f8ef01c9f816e49106dc366fc37fdfad3c19d8ff913f1c4bff2c8947f31a92e2c WHIRLPOOL e4efa5bff86b48e26e678d97170db8a87eb86386f8314eed25ce8786df23e428794653c81f2db43bbd80ada6fa5cfd5cdb412b5f163275ad2b473c06737129fd
MISC ChangeLog 8102 SHA256 08fd0460a7031fe60fd926e5b0c7e21ee0162f4957f8fa1eb4bf7df052043e42 SHA512 3780fe3bc7cd310579981672ff5e5604088d2672bd357159ba3d7df0a094e80016f2ac6038f99ac8f049869543feff6fdef324bef51594ccc6c024f772b0ff10 WHIRLPOOL d53f1eadd59c86a30536f22268b8b8659ae1fdb447fffef95a898eac0e4cb75e3691d7645ee1bdd4492c7c75c22d8f852e61fc6363c30f890de702cbdfae7385
MISC metadata.xml 341 SHA256 f12826bad0472c46c8bd1ee18e7ab0acdc4cf26dd8b1322b1a93ff7c95b14a7e SHA512 dd141022832b17bc47f40cc940c2165c849b5ad786df5cbba7685da4543a8969ed992fb9dda3a136d045418f6de731c83909f3d02fd3ad2dee4d0ab4689b0c44 WHIRLPOOL 1fff0d00542a6e5b3f64edb985e53fe978a9d91dde0b0118cf790dc113a1a3e3fd01632f2f19517af9b47fef51902de579e43c30eaedf3fa298230848cb125a3
diff --git a/sys-libs/talloc/talloc-2.1.0-r1.ebuild b/sys-libs/talloc/talloc-2.1.0-r1.ebuild
index f02db22..5f0009e 100644
--- a/sys-libs/talloc/talloc-2.1.0-r1.ebuild
+++ b/sys-libs/talloc/talloc-2.1.0-r1.ebuild
@@ -32,20 +32,6 @@ DEPEND="${RDEPEND}
WAF_BINARY_REL="buildtools/bin/waf"
-# sigh, apparently waf will only install pytalloc.h if system talloc is used, which can vary per-abi.
-# However, it seems that the same hard-coded header is used regardless -- which means that all we are
-# doing here is appeasing the framework. Some option to ignore header conflicts should really be introduced.
-MULTILIB_WRAPPED_HEADERS=( /usr/include/pytalloc.h )
-
-# Note that since native python is used for cross-abi building, waf only generates libtalloc.so but not
-# libpytalloc-util.so. For this reason, in app-emulation/emul-linux-x86-baselibs still provides those
-# files. However much sense this makes for building, it doesn't make a ton of sense of packaging.
-# The file is supposed to be provided by this ebuild. In the case of ABI_X86="32 64", for example,
-# the generated libpytalloc-util.so library links against libpython.so, which is provided...
-# This suggests that to fully solve the problem, we'll either need to have a full 32-bit python binary
-# around (again, in the ABI_X86="32 64" case -- but similar cases presumably have the same result), or,
-# hack on the build scripts to enable cross-abi building somehow. Bleh, this sucks.
-
src_configure() {
local extra_opts=""