summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Narváez <david.narvaez@computer.org>2013-01-01 22:57:33 -0500
committerDavid Narváez <david.narvaez@computer.org>2013-01-01 22:57:33 -0500
commit047558114876711b5e237311c585d508747fd2f8 (patch)
treed4898737148e9a47fb95eb2b5b5c5c0e0fe2dc32
parentAdding melt ebuilds (diff)
downloaddMaggot-047558114876711b5e237311c585d508747fd2f8.tar.gz
dMaggot-047558114876711b5e237311c585d508747fd2f8.tar.bz2
dMaggot-047558114876711b5e237311c585d508747fd2f8.zip
Deleting old ebuild
-rw-r--r--dev-util/gcc-python-plugin/gcc-python-plugin-0.9.ebuild102
1 files changed, 0 insertions, 102 deletions
diff --git a/dev-util/gcc-python-plugin/gcc-python-plugin-0.9.ebuild b/dev-util/gcc-python-plugin/gcc-python-plugin-0.9.ebuild
deleted file mode 100644
index 811e911..0000000
--- a/dev-util/gcc-python-plugin/gcc-python-plugin-0.9.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_DEPEND="*"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-
-inherit python eutils
-
-DESCRIPTION="GCC Python plugin for static analysis"
-HOMEPAGE="https://fedorahosted.org/gcc-python-plugin"
-SRC_URI="https://fedorahosted.org/releases/g/c/gcc-python-plugin/${P}.tar.gz"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc"
-
-DEPEND="${DEPEND}
->=sys-devel/gcc-4.6
-dev-python/six
-dev-python/pygments
-media-gfx/graphviz
-doc? (
- dev-python/sphinx
- dev-python/pycairo
-)
-"
-
-RDEPEND="${DEPEND}"
-
-DEPEND="${DEPEND}
-doc? (
- dev-python/sphinx
- dev-python/pycairo
-)
-"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-python3-docs.diff"
- epatch "${FILESDIR}/${PN}-man-target.diff"
-
- python_src_prepare
-}
-
-src_configure() {
- return
-}
-
-src_compile() {
- rename_items() {
- PLUGIN_NAME="python$(python_get_version --major)"
- GCC_WITH_PYTHON_SCRIPT_NAME="gcc-with-${PLUGIN_NAME}"
-
- cp python.so "${PLUGIN_NAME}.so"
- cp gcc-with-python "${GCC_WITH_PYTHON_SCRIPT_NAME}"
- sed -i -e"s|-fplugin=[^ ]*|-fplugin=${PLUGIN_NAME}|" "${GCC_WITH_PYTHON_SCRIPT_NAME}"
- sed -i -e"s|-fplugin-arg-python-script|-fplugin-arg-${PLUGIN_NAME}-script|" "${GCC_WITH_PYTHON_SCRIPT_NAME}"
- }
-
- python_execute_function -d -s plugin
- python_execute_function -s rename_items
-
- cd "${WORKDIR}/${P}-$(python_get_version -f)"
-
- emake man
-
- if use doc; then
- emake html
- fi
-}
-
-src_test() {
- emake testcpybuilder test-suite testcpychecker
-}
-
-src_install() {
- GCC_PLUGIN_DIR="$(gcc --print-file-name=plugin)"
-
- install_plugin_files() {
- dobin "gcc-with-python$(python_get_version --major)"
- insinto "${GCC_PLUGIN_DIR}"
- doins "python$(python_get_version --major).so"
- insinto "$(python_get_sitedir)"
- doins gccutils.py
- doins -r libcpychecker
- }
-
- python_execute_function -s install_plugin_files
- dobin "${FILESDIR}/gcc-with-python"
-
- cd "${WORKDIR}/${P}-$(python_get_version -f)"
-
- doman docs/_build/man/*
-
- if use doc; then
- dodoc -r examples
- dodoc -r docs/_build/html
- fi
-}