summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/bibletime/bibletime-2.10.1.ebuild')
-rw-r--r--app-text/bibletime/bibletime-2.10.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/bibletime/bibletime-2.10.1.ebuild b/app-text/bibletime/bibletime-2.10.1.ebuild
new file mode 100644
index 0000000..2473ade
--- /dev/null
+++ b/app-text/bibletime/bibletime-2.10.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Copyright 2010-2013 The BibleTime team
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="Qt4 Bible study application using the SWORD library."
+HOMEPAGE="http://www.bibletime.info/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="debug"
+
+RDEPEND="
+ >=app-text/sword-1.7[curl]
+ >=dev-cpp/clucene-0.9.16a
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtwebkit:4"
+DEPEND="${RDEPEND}
+ dev-qt/qttest:4"
+
+DOCS="ChangeLog README"
+
+pkg_setup() {
+ einfo "Please file bugs for this ebuild to http://bugs.bibletime.info/"
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs} -DUSE_QT_WEBKIT=ON"
+ cmake-utils_src_configure
+}