summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-roguelike/moria')
-rw-r--r--games-roguelike/moria/Manifest7
-rw-r--r--games-roguelike/moria/files/5.6-fbsd.patch264
-rw-r--r--games-roguelike/moria/files/5.6-gentoo-paths.patch58
-rw-r--r--games-roguelike/moria/files/5.6-hours.patch30
-rw-r--r--games-roguelike/moria/metadata.xml26
-rw-r--r--games-roguelike/moria/moria-5.6.ebuild65
6 files changed, 0 insertions, 450 deletions
diff --git a/games-roguelike/moria/Manifest b/games-roguelike/moria/Manifest
deleted file mode 100644
index fb07f50..0000000
--- a/games-roguelike/moria/Manifest
+++ /dev/null
@@ -1,7 +0,0 @@
-AUX 5.6-fbsd.patch 7242 RMD160 90177ef6f656dc80cceedbf8e344362cabcdc1b8 SHA1 0886cb9f060bdefaee0751122294c6283bea48dd SHA256 79b103441adc5424c23a7ae190eb2d8718a3f7d8feb3ac8141c06ea7e43825d8
-AUX 5.6-gentoo-paths.patch 2859 RMD160 9af71f1a9cf9456c2564c23928a01e85bd8ba89f SHA1 297018e15d8f61862575696808e9b1bf586bd52f SHA256 4f9537b8edfc154862f38016a442609304b201dabe57e2cca835b05e97f466e9
-AUX 5.6-hours.patch 1375 RMD160 1e5a375e8f780c1db201f22838d1c700af139303 SHA1 b864edfd3b49eb165ef5de6565530cece37c6b78 SHA256 8a3e3919a152a5ea812c698b3444718133142705b5b78d3f30d0cbe9684f10c2
-DIST moria-extras.tar.bz2 57324 RMD160 1224849eeade7a2b7d1858abc6da816607e1bed1 SHA1 3216dace81698d2c4c0c79a878af2e85a1f220c5 SHA256 60f2a7d7bf8615a090cacafd17cf6fae8f9f0af78700439022e25014384b5076
-DIST moria_5.6.orig.tar.gz 663240 RMD160 8a716be9ba4ca2dcad40456bde94fbb04acda6fa SHA1 5188bac8f453aa8c17ca3bcb170430dd043324f3 SHA256 b9f3856221026445585e41e084894ec1dd880993f07cebc99e43d06c8f2d54ea
-EBUILD moria-5.6.ebuild 2025 RMD160 c32d59636eba163bdb14735938d7b95fde1ea552 SHA1 1639c7ce784b4bc6b4bcb928f26facbc8bd84c3f SHA256 d91ddefecfc1cf2f25a5aaeb3c8c55f171688276ce525684d718f31224fb04a0
-MISC metadata.xml 1164 RMD160 2ec0683c552fb3937c5c73ad96a64c1b8c7c4a7d SHA1 6692a37f29ffebfd5fb578862bb6a8952ec0e395 SHA256 566da244e91d0fc93e05934a3e883d86c2c0dea3289682e71e326093c11be42a
diff --git a/games-roguelike/moria/files/5.6-fbsd.patch b/games-roguelike/moria/files/5.6-fbsd.patch
deleted file mode 100644
index 3d8f88f..0000000
--- a/games-roguelike/moria/files/5.6-fbsd.patch
+++ /dev/null
@@ -1,264 +0,0 @@
-diff -Npur moria-5.6.orig/source/death.c moria-5.6/source/death.c
---- moria-5.6.orig/source/death.c 2011-11-05 12:21:31.824290449 +0100
-+++ moria-5.6/source/death.c 2011-11-05 12:25:21.776290432 +0100
-@@ -111,6 +111,7 @@ off_t lseek();
- #endif
- #endif
-
-+#ifndef __FreeBSD__
- #ifndef VMS
- #ifndef MAC
- #if defined(ultrix) || defined(USG)
-@@ -118,6 +119,7 @@ void exit ();
- #endif
- #endif
- #endif
-+#endif
-
- #if defined(LINT_ARGS)
- static void date(char *);
-@@ -143,13 +145,13 @@ static void date(day)
- char *day;
- {
- register char *tmp;
--#ifdef MAC
-+#if defined(MAC) || defined(__FreeBSD__)
- time_t clockvar;
- #else
- long clockvar;
- #endif
-
--#ifdef MAC
-+#if defined(MAC) || defined(__FreeBSD__)
- clockvar = time((time_t *) 0);
- #else
- clockvar = time((long *) 0);
-diff -Npur moria-5.6.orig/source/io.c moria-5.6/source/io.c
---- moria-5.6.orig/source/io.c 2011-11-05 12:21:31.823290449 +0100
-+++ moria-5.6/source/io.c 2011-11-05 12:28:50.526290419 +0100
-@@ -22,6 +22,11 @@
-
- #include "config.h"
-
-+#ifdef __FreeBSD__
-+#include <sys/ioctl_compat.h>
-+#include <time.h>
-+#endif
-+
- #ifdef HPUX
- #include <sys/bsdtty.h>
- #endif
-@@ -259,7 +264,9 @@ int suspend()
- struct ltchars lcbuf;
- struct tchars cbuf;
- int lbuf;
-+#ifndef __FreeBSD__
- long time();
-+#endif
-
- py.misc.male |= 2;
- (void) ioctl(0, TIOCGETP, (char *)&tbuf);
-@@ -327,7 +334,7 @@ void init_curses()
- #endif
-
- /* PC curses returns ERR */
--#if defined(USG) && !defined(PC_CURSES) && !defined(AMIGA)
-+#if (defined(USG) && !defined(PC_CURSES) && !defined(AMIGA)) || defined(__FreeBSD__)
- if (initscr() == NULL)
- #else
- if (initscr() == ERR)
-@@ -345,7 +352,7 @@ void init_curses()
- #if defined(atarist) && defined(__GNUC__)
- (void) signal (SIGTSTP, (__Sigfunc)suspend);
- #else
--#ifdef __386BSD__
-+#if defined(__386BSD__) || defined(__FreeBSD__)
- (void) signal (SIGTSTP, (sig_t)suspend);
- #else
- #ifdef DEBIAN_LINUX
-@@ -777,7 +784,7 @@ void shell_out()
- msg_print("Fork failed. Try again.");
- return;
- }
--#if defined(USG) || defined(__386BSD__)
-+#if defined(USG) || defined(__386BSD__) || defined(__FreeBSD__)
- (void) wait((int *) 0);
- #else
- (void) wait((union wait *) 0);
-diff -Npur moria-5.6.orig/source/main.c moria-5.6/source/main.c
---- moria-5.6.orig/source/main.c 2011-11-05 12:21:31.825290449 +0100
-+++ moria-5.6/source/main.c 2011-11-05 12:23:19.611290441 +0100
-@@ -96,6 +96,7 @@
- #include <time.h>
- #endif
-
-+#ifndef __FreeBSD__
- #ifndef VMS
- #ifndef MAC
- #ifndef GEMDOS
-@@ -106,6 +107,9 @@ long time();
- char *getenv();
- #endif
- #endif
-+#else
-+#include <stdlib.h>
-+#endif
-
- #ifndef MAC
- #ifndef AMIGA
-@@ -368,7 +372,7 @@ char *argv[];
- else
- { /* Create character */
- create_character();
--#ifdef MAC
-+#if defined(MAC) || defined(__FreeBSD__)
- birth_date = time ((time_t *)0);
- #else
- birth_date = time ((long *)0);
-diff -Npur moria-5.6.orig/source/misc1.c moria-5.6/source/misc1.c
---- moria-5.6.orig/source/misc1.c 2011-11-05 12:21:31.825290449 +0100
-+++ moria-5.6/source/misc1.c 2011-11-05 12:31:23.686290407 +0100
-@@ -38,7 +38,7 @@
- #endif
- #endif
-
--#if !defined(ATARIST_MWC) && !defined(MAC) && !defined(VMS) && !defined(AMIGA)
-+#if !defined(ATARIST_MWC) && !defined(MAC) && !defined(VMS) && !defined(AMIGA) && !defined(__FreeBSD__)
- long time();
- #endif
- struct tm *localtime();
-@@ -55,7 +55,7 @@ int32u seed;
- register int32u clock_var;
-
- if (seed == 0)
--#ifdef MAC
-+#if defined(MAC) || defined(__FreeBSD__)
- clock_var = time((time_t *)0);
- #else
- clock_var = time((long *)0);
-@@ -99,10 +99,14 @@ void reset_seed()
- int check_time()
- {
- #ifdef MORIA_HOU
-+#if defined(MAC) || defined(__FreeBSD__)
-+ time_t clock_var;
-+#else
- long clock_var;
-+#endif
- register struct tm *tp;
-
--#ifdef MAC
-+#if defined(MAC) || defined(__FreeBSD__)
- clock_var = time((time_t *)0);
- #else
- clock_var = time((long *)0);
-diff -Npur moria-5.6.orig/source/save.c moria-5.6/source/save.c
---- moria-5.6.orig/source/save.c 2011-11-05 12:21:31.823290449 +0100
-+++ moria-5.6/source/save.c 2011-11-05 12:34:57.052290391 +0100
-@@ -110,7 +110,7 @@ static void rd_monster();
- #endif
-
- #if !defined(ATARIST_MWC)
--#ifdef MAC
-+#if defined(MAC) || defined(__FreeBSD__)
- #include <time.h>
- #else
- long time();
-@@ -339,7 +339,7 @@ static int sv_write()
- }
-
- /* save the current time in the savefile */
--#ifdef MAC
-+#if defined(MAC) || defined(__FreeBSD__)
- l = time((time_t *)0);
- #else
- l = time((long *)0);
-@@ -1037,7 +1037,7 @@ int *generate;
- || (version_min == 2 && patch_level >= 2))
- rd_long ((int32u *)&birth_date);
- else
--#ifdef MAC
-+#if defined(MAC) || defined(__FreeBSD__)
- birth_date = time((time_t *)0);
- #else
- birth_date = time((long *)0);
-@@ -1261,7 +1261,7 @@ scoreboard; it will not be scored again.
- /* rotate store inventory, depending on how old the save file */
- /* is foreach day old (rounded up), call store_maint */
- /* calculate age in seconds */
--#ifdef MAC
-+#if defined(MAC) || defined(__FreeBSD__)
- start_time = time((time_t *)0);
- #else
- start_time = time((long *)0);
-diff -Npur moria-5.6.orig/source/signals.c moria-5.6/source/signals.c
---- moria-5.6.orig/source/signals.c 2011-11-05 12:21:31.825290449 +0100
-+++ moria-5.6/source/signals.c 2011-11-05 12:37:30.794290382 +0100
-@@ -111,7 +111,7 @@ static int signal_count = 0;
-
- /*ARGSUSED*/
- #ifndef USG
--#ifdef __386BSD__
-+#if defined(__386BSD__) || defined(__FreeBSD__)
- static void signal_handler(sig, code, scp)
- #else
- static int signal_handler(sig, code, scp)
-@@ -239,7 +239,7 @@ void signals()
- #if defined(atarist) && defined(__GNUC__)
- (void) MSIGNAL(SIGTSTP, (__Sigfunc)suspend);
- #else
--#ifdef __386BSD__
-+#if defined(__386BSD__) || defined(__FreeBSD__)
- (void) MSIGNAL(SIGTSTP, (sig_t)suspend);
- #else
- (void) MSIGNAL(SIGTSTP, suspend);
-diff -Npur moria-5.6.orig/source/types.h moria-5.6/source/types.h
---- moria-5.6.orig/source/types.h 2011-11-05 12:21:31.824290449 +0100
-+++ moria-5.6/source/types.h 2011-11-05 12:38:52.062290376 +0100
-@@ -33,6 +33,14 @@ typedef long int32;
- typedef unsigned long int32u;
- #endif
- #else
-+#ifdef __FreeBSD__
-+#include <sys/types.h>
-+typedef u_int32_t int32u;
-+typedef int32_t int32;
-+typedef u_int16_t int16u;
-+typedef int16_t int16;
-+typedef u_int8_t int8u;
-+#else
- #include<stdint.h>
- typedef uint_least8_t int8u;
- typedef int_least16_t int16;
-@@ -40,6 +48,7 @@ typedef uint_least16_t int16u;
- typedef int_least32_t int32;
- typedef uint_least32_t int32u;
- #endif
-+#endif
-
- /* some machines will not accept 'signed char' as a type, and some accept it
- but still treat it like an unsigned character, let's just avoid it,
-diff -Npur moria-5.6.orig/unix/unix.c moria-5.6/unix/unix.c
---- moria-5.6.orig/unix/unix.c 2011-11-05 12:21:31.822290449 +0100
-+++ moria-5.6/unix/unix.c 2011-11-05 12:39:58.586290375 +0100
-@@ -25,6 +25,10 @@
- /* defines TRUE and FALSE */
- #include <ncurses.h>
-
-+#ifdef __FreeBSD__
-+#include <unistd.h>
-+#endif
-+
- #include "config.h"
- #include "constant.h"
- #include "types.h"
-@@ -289,7 +293,9 @@ int getuid();
- void user_name(buf)
- char *buf;
- {
-+#ifndef __FreeBSD__
- extern char *getlogin();
-+#endif
- struct passwd *pwline;
- register char *p;
-
diff --git a/games-roguelike/moria/files/5.6-gentoo-paths.patch b/games-roguelike/moria/files/5.6-gentoo-paths.patch
deleted file mode 100644
index d2b8c8d..0000000
--- a/games-roguelike/moria/files/5.6-gentoo-paths.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-diff -Npur moria-5.6.orig/source/config.h moria-5.6/source/config.h
---- moria-5.6.orig/source/config.h 2011-11-05 14:53:49.313289807 +0100
-+++ moria-5.6/source/config.h 2011-11-05 14:53:56.419289806 +0100
-@@ -240,17 +240,17 @@ some of the system defines set up here.
-
- /* Generic UNIX */
- /* This must be unix; change file names as appropriate. */
--#define MORIA_SAV "moria-save"
--#define MORIA_HOU "/home/dgrabiner/moria-5.6/files/hours"
--#define MORIA_MOR "/home/dgrabiner/moria-5.6/files/news"
--#define MORIA_GPL "/home/dgrabiner/moria-5.6/files/COPYING"
--#define MORIA_TOP "/home/dgrabiner/moria-5.6/files/scores"
--#define MORIA_HELP "/home/dgrabiner/moria-5.6/files/roglcmds.hlp"
--#define MORIA_ORIG_HELP "/home/dgrabiner/moria-5.6/files/origcmds.hlp"
--#define MORIA_WIZ_HELP "/home/dgrabiner/moria-5.6/files/rwizcmds.hlp"
--#define MORIA_OWIZ_HELP "/home/dgrabiner/moria-5.6/files/owizcmds.hlp"
--#define MORIA_WELCOME "/home/dgrabiner/moria-5.6/files/welcome.hlp"
--#define MORIA_VER "/home/dgrabiner/moria-5.6/files/version.hlp"
-+#define MORIA_SAV ".moria-save"
-+#define MORIA_HOU "GENTOO_SYSCONFDIR/hours"
-+#define MORIA_MOR "GENTOO_DATADIR/news"
-+#define MORIA_GPL "GENTOO_DATADIR/COPYING"
-+#define MORIA_TOP "GENTOO_STATEDIR/scores"
-+#define MORIA_HELP "GENTOO_DATADIR/roglcmds.hlp"
-+#define MORIA_ORIG_HELP "GENTOO_DATADIR/origcmds.hlp"
-+#define MORIA_WIZ_HELP "GENTOO_DATADIR/rwizcmds.hlp"
-+#define MORIA_OWIZ_HELP "GENTOO_DATADIR/owizcmds.hlp"
-+#define MORIA_WELCOME "GENTOO_DATADIR/welcome.hlp"
-+#define MORIA_VER "GENTOO_DATADIR/version.hlp"
-
- #endif
- #endif
-diff -Npur moria-5.6.orig/unix/Makefile moria-5.6/unix/Makefile
---- moria-5.6.orig/unix/Makefile 2011-11-05 14:53:49.310289807 +0100
-+++ moria-5.6/unix/Makefile 2011-11-05 14:54:22.482289805 +0100
-@@ -7,7 +7,7 @@ DESTDIR =
-
-
- # BINDIR is the directory where the moria binary while be put
--# LIBDIR is where the other files (score, news, hours) will be put
-+# LIBDIR is where the other files (score) will be put
- # LIBDIR must be the same directory defined in config.h
- # Edited for Debian GNU/Linux: Next 4 lines are for the FHS
- # Edited for Debian GNU/Linux: LIBDIR is retired
-@@ -89,10 +89,10 @@ install:
- # No longer chmod 755 $(LIBVARDIR)
- (cd files; cp $(LIBSTATICFILES) $(LIBSTATICDIR))
- (cd $(LIBSTATICDIR); chmod 444 $(LIBSTATICFILES))
-- # No longer (cd $(LIBVARDIR); touch scores; chmod 664 scores)
-+ (cd $(LIBVARDIR); touch scores; chmod 664 scores)
- # No longer (cd $(LIBVARDIR); chown $(OWNER) . scores; chgrp $(GROUP) . scores)
-- (cd files; cp hours $(ETCDIR)/moria-hours)
-- chmod 644 $(ETCDIR)/moria-hours
-+ (cd files; cp hours $(ETCDIR)/hours)
-+ chmod 644 $(ETCDIR)/hours
- (cd $(LIBSTATICDIR); chown $(OWNER) $(LIBSTATICFILES))
- (cd $(LIBSTATICDIR); chgrp $(GROUP) $(LIBSTATICFILES))
- # If you are short on disk space, or aren't interested in debugging moria.
diff --git a/games-roguelike/moria/files/5.6-hours.patch b/games-roguelike/moria/files/5.6-hours.patch
deleted file mode 100644
index fd98932..0000000
--- a/games-roguelike/moria/files/5.6-hours.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -Npur moria-5.6.orig/source/files.c moria-5.6/source/files.c
---- moria-5.6.orig/source/files.c 2011-11-05 12:21:31.823290449 +0100
-+++ moria-5.6/source/files.c 2011-11-05 12:44:34.703290350 +0100
-@@ -126,19 +126,19 @@ void read_times()
- if (strlen(in_line) > 3)
- {
- if (!strncmp(in_line, "SUN:", 4))
-- (void) strcpy(days[0], in_line);
-+ (void) snprintf(days[0], sizeof(days[0]), "%s", in_line);
- else if (!strncmp(in_line, "MON:", 4))
-- (void) strcpy(days[1], in_line);
-+ (void) snprintf(days[1], sizeof(days[0]), "%s", in_line);
- else if (!strncmp(in_line, "TUE:", 4))
-- (void) strcpy(days[2], in_line);
-+ (void) snprintf(days[2], sizeof(days[0]), "%s", in_line);
- else if (!strncmp(in_line, "WED:", 4))
-- (void) strcpy(days[3], in_line);
-+ (void) snprintf(days[3], sizeof(days[0]), "%s", in_line);
- else if (!strncmp(in_line, "THU:", 4))
-- (void) strcpy(days[4], in_line);
-+ (void) snprintf(days[4], sizeof(days[0]), "%s", in_line);
- else if (!strncmp(in_line, "FRI:", 4))
-- (void) strcpy(days[5], in_line);
-+ (void) snprintf(days[5], sizeof(days[0]), "%s", in_line);
- else if (!strncmp(in_line, "SAT:", 4))
-- (void) strcpy(days[6], in_line);
-+ (void) snprintf(days[6], sizeof(days[0]), "%s", in_line);
- }
- (void) fclose(file1);
- }
diff --git a/games-roguelike/moria/metadata.xml b/games-roguelike/moria/metadata.xml
deleted file mode 100644
index 274a651..0000000
--- a/games-roguelike/moria/metadata.xml
+++ /dev/null
@@ -1,26 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>games</herd>
- <maintainer>
- <email>anthoine.bourgeois@gmail.com</email>
- <name>Anthoine Bourgeois</name>
- <description>aluco's overlay maintainer</description>
- </maintainer>
- <longdescription>
- A single player roguelike game with a regenerating dungeon, moria is the
- predecessor of angband with a full-screen, text-based, turn-based
- interface. It features scrolling maps, and an infinite (constantly
- regenerated) dungeon.
-
- Moria's dungeons are populated by monsters, some of which are inspired
- by J.R.R. Tolkien's books. The goal of the game is to find and kill the
- Balrog, whereupon the player is crowned King. Your player can be created
- from a combination of 8 races (human, half-elf, elf, halfling, gnome,
- dwarf, half-orc, half-troll) and 6 classes (warrior, mage, priest,
- rogue, ranger, paladin), and is measured by 6 attributes (strength,
- dexterity, intelligence, wisdom, constitution, and charisma).
-
- Despite the package name, this is actually Umoria (Unix moria).
- </longdescription>
-</pkgmetadata>
diff --git a/games-roguelike/moria/moria-5.6.ebuild b/games-roguelike/moria/moria-5.6.ebuild
deleted file mode 100644
index 6cf34fb..0000000
--- a/games-roguelike/moria/moria-5.6.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/moria/moria-5.5.2.ebuild,v 1.12 2010/05/05 20:28:21 mr_bones_ Exp $
-
-EAPI=2
-inherit eutils toolchain-funcs games
-
-DESCRIPTION="Rogue-like D&D curses game similar to nethack (BUT BETTER)"
-HOMEPAGE="http://remarque.org/~grabiner/moria.html"
-SRC_URI="http://ftp.debian.org/debian/pool/main/m/moria/moria_5.6.orig.tar.gz
- ftp://kane.evendata.net/pub/${PN}-extras.tar.bz2"
-
-LICENSE="Moria"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=">=sys-libs/ncurses-5"
-RDEPEND="${DEPENDS}"
-
-src_prepare() {
- local f
-
- epatch \
- "${FILESDIR}"/${PV}-gentoo-paths.patch \
- "${FILESDIR}"/${PV}-fbsd.patch \
- "${FILESDIR}"/${PV}-hours.patch
-
- for f in source/* unix/* ; do
- ln -s ${f} $(basename ${f})
- done
-
- sed -i \
- -e "s:David Grabiner <grabiner@alumni.princeton.edu>:root:" \
- -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
- -e "s:GENTOO_STATEDIR:${GAMES_STATEDIR}/${PN}:" \
- -e "s:GENTOO_SYSCONFDIR:${GAMES_SYSCONFDIR}/${PN}:" \
- config.h \
- || die "sed failed"
- echo "#include <stdlib.h>" >> config.h
- echo "#include <stdio.h>" >> config.h
- sed -i \
- -e "/^LIBSTATICDIR =/s:=.*:=\$(DESTDIR)${GAMES_DATADIR}/${PN}:" \
- -e "/^BINDIR = /s:=.*:=\$(DESTDIR)${GAMES_BINDIR}:" \
- -e "/^ETCDIR = /s:=.*:=\$(DESTDIR)${GAMES_SYSCONFDIR}/${PN}:" \
- -e "/^LIBVARDIR = /s:=.*:=\$(DESTDIR)${GAMES_STATEDIR}/${PN}:" \
- -e "/^CFLAGS = /s:=.*:=${CFLAGS}:" \
- -e "/^OWNER = /s:=.*:=${GAMES_USER}:" \
- -e "/^GROUP = /s:=.*:=${GAMES_GROUP}:" \
- -e "/^CC = /s:=.*:=$(tc-getCC):" \
- -e '/^LFLAGS = /s:=.*:= $(LDFLAGS):' \
- Makefile \
- || die "sed failed"
- mv doc/moria.6 "${S}" || die "mv failed"
-}
-
-src_install() {
- dodir "${GAMES_BINDIR}" "${GAMES_DATADIR}/${PN}" "${GAMES_STATEDIR}/${PN}" "${GAMES_SYSCONFDIR}/${PN}"
- emake DESTDIR="${D}" install || die "emake install failed"
-
- doman moria.6
- dodoc README doc/* "${WORKDIR}"/${PN}-extras/*
-
- prepgamesdirs
-}