summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/ropemacs')
-rw-r--r--app-emacs/ropemacs/Manifest3
-rw-r--r--app-emacs/ropemacs/metadata.xml10
-rw-r--r--app-emacs/ropemacs/ropemacs-0.6.ebuild39
3 files changed, 52 insertions, 0 deletions
diff --git a/app-emacs/ropemacs/Manifest b/app-emacs/ropemacs/Manifest
new file mode 100644
index 0000000..4045416
--- /dev/null
+++ b/app-emacs/ropemacs/Manifest
@@ -0,0 +1,3 @@
+DIST ropemacs-0.6.tar.gz 29162 RMD160 5e9c10a251ea438a786522a175502c3aab40e9ee SHA1 907bc99bdf179edd6fd077ea005bfab3c38176af SHA256 44831ce6a9d2e7634b036ae0c5c6e931a0d0dd0c7d228f3a9fd81d2bebf2d8a9
+EBUILD ropemacs-0.6.ebuild 680 RMD160 23c611409105321fdf429d403abecfb8d9f400f1 SHA1 716e715ea51d24fc0f54a9dfa673119ae8c99606 SHA256 a66b7429aaea08a4c7b85d8ebc24d30be13bd3d87b67a027dec490ac18bdbe69
+MISC metadata.xml 260 RMD160 eecb7161102f7359031d32ef4d0a853ad68c128a SHA1 85e42541dbe13b49285fc9156bca90d2f0e38899 SHA256 a4370bc15e78a3eecd51884dc4ceecee58d4a2ff916c81d494418f4214aefa07
diff --git a/app-emacs/ropemacs/metadata.xml b/app-emacs/ropemacs/metadata.xml
new file mode 100644
index 0000000..2a13ce0
--- /dev/null
+++ b/app-emacs/ropemacs/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>alex.cepoi@gmail.com</email>
+ <name>Alexandru Cepoi</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/app-emacs/ropemacs/ropemacs-0.6.ebuild b/app-emacs/ropemacs/ropemacs-0.6.ebuild
new file mode 100644
index 0000000..2e4d8b9
--- /dev/null
+++ b/app-emacs/ropemacs/ropemacs-0.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=""
+
+inherit distutils eutils elisp-common
+
+DESCRIPTION="Emacs interface for rope"
+HOMEPAGE="http://rope.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rope/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="nomirror"
+
+DEPEND=">=dev-python/rope-0.7
+ >=app-emacs/pymacs-0.22-r1"
+RDEPEND="${DEPEND}"
+SITEFILE=55${PN}-gentoo.el
+
+src_install() {
+ distutils_src_install
+
+ dodir docs
+ dodoc docs/*.txt
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}