summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandru Cepoi <alex.cepoi@gmail.com>2010-05-29 05:36:18 +0300
committerAlexandru Cepoi <alex.cepoi@gmail.com>2010-05-29 05:36:18 +0300
commitfb27da896c609a92cf38727dae3f380442e937e2 (patch)
tree3b802a7af5fc20336b26832713846fd3f726f57f /app-emacs/ropemacs/ropemacs-0.6.ebuild
parentfix monodevelop dependencies (diff)
downloadalexcepoi-fb27da896c609a92cf38727dae3f380442e937e2.tar.gz
alexcepoi-fb27da896c609a92cf38727dae3f380442e937e2.tar.bz2
alexcepoi-fb27da896c609a92cf38727dae3f380442e937e2.zip
add webkit-sharp-0.3
Diffstat (limited to 'app-emacs/ropemacs/ropemacs-0.6.ebuild')
-rw-r--r--app-emacs/ropemacs/ropemacs-0.6.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/ropemacs/ropemacs-0.6.ebuild b/app-emacs/ropemacs/ropemacs-0.6.ebuild
new file mode 100644
index 0000000..2e4d8b9
--- /dev/null
+++ b/app-emacs/ropemacs/ropemacs-0.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=""
+
+inherit distutils eutils elisp-common
+
+DESCRIPTION="Emacs interface for rope"
+HOMEPAGE="http://rope.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rope/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="nomirror"
+
+DEPEND=">=dev-python/rope-0.7
+ >=app-emacs/pymacs-0.22-r1"
+RDEPEND="${DEPEND}"
+SITEFILE=55${PN}-gentoo.el
+
+src_install() {
+ distutils_src_install
+
+ dodir docs
+ dodoc docs/*.txt
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}