summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/curseofwar/curseofwar-9999.ebuild')
-rw-r--r--games-strategy/curseofwar/curseofwar-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-strategy/curseofwar/curseofwar-9999.ebuild b/games-strategy/curseofwar/curseofwar-9999.ebuild
new file mode 100644
index 0000000..f6c0468
--- /dev/null
+++ b/games-strategy/curseofwar/curseofwar-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit games git-2
+
+DESCRIPTION="Real Time Strategy Game for Linux"
+HOMEPAGE="https://github.com/a-nikolaev/curseofwar"
+EGIT_REPO_URI="https://github.com/a-nikolaev/${PN}.git"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-shells/bash
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ sys-devel/gcc"
+
+src_configure() {
+ sed -i -e 's/CFLAGS\ \ =/CFLAGS\ \ \+=/' Makefile || \
+ die "couldn't patch Makefil CFLAGS"
+ sed -i -e 's/LDFLAGS\ =/LDFLAGS\ \+=/' Makefile || \
+ die "couldn't patch Makefil LDFLAGS"
+}