summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2019-07-08 07:18:07 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2019-07-08 07:18:07 +0000
commitdc7a2310971b6a6a35073c7a4452149ab9630c1f (patch)
tree297417f5c5b3a6a86677e05d3fa6baafb57ca595 /raw.txt
parent2019-07-08T06:20:01Z (diff)
downloadrepos-dc7a2310971b6a6a35073c7a4452149ab9630c1f.tar.gz
repos-dc7a2310971b6a6a35073c7a4452149ab9630c1f.tar.bz2
repos-dc7a2310971b6a6a35073c7a4452149ab9630c1f.zip
2019-07-08T07:11:29Z
Diffstat (limited to 'raw.txt')
-rw-r--r--raw.txt55
1 files changed, 47 insertions, 8 deletions
diff --git a/raw.txt b/raw.txt
index 308fae436adb..e1743370f01a 100644
--- a/raw.txt
+++ b/raw.txt
@@ -10,24 +10,63 @@
'uri': 'https://github.com/mahatma-kaganovich/raw.git'}],
'status': 'unofficial'}
$ pmaint sync raw
-WARNING:pkgcore:'beatussum-overlay' repo at '/var/lib/repo-mirror-ci/sync/beatussum-overlay' has unsupported profile format: profile-default-eapi
+WARNING:pkgcore:EAPI '7' isn't fully supported
WARNING:pkgcore:'genthree' repo at '/var/lib/repo-mirror-ci/sync/genthree' has unsupported profile format: profile-bashrcs
WARNING:pkgcore:'xelnor' repo at '/var/lib/repo-mirror-ci/sync/xelnor' has unsupported profile format: build-id
-WARNING:pkgcore:'xelnor' repo at '/var/lib/repo-mirror-ci/sync/xelnor' has unsupported profile format: build-id
-WARNING:pkgcore:'genthree' repo at '/var/lib/repo-mirror-ci/sync/genthree' has unsupported profile format: profile-bashrcs
WARNING:pkgcore:'beatussum-overlay' repo at '/var/lib/repo-mirror-ci/sync/beatussum-overlay' has unsupported profile format: profile-default-eapi
-*** syncing raw
Already up to date.
+*** syncing raw
*** synced raw
* Sync succeeded
$ git log --format=%ci -1
$ git show -q --pretty=format:%G? HEAD
$ pmaint regen --use-local-desc --pkg-desc-index -t 1 raw
-WARNING:pkgcore:'beatussum-overlay' repo at '/var/lib/repo-mirror-ci/repos/beatussum-overlay' has unsupported profile format: profile-default-eapi
+WARNING:pkgcore:EAPI '7' isn't fully supported
WARNING:pkgcore:'genthree' repo at '/var/lib/repo-mirror-ci/repos/genthree' has unsupported profile format: profile-bashrcs
WARNING:pkgcore:'xelnor' repo at '/var/lib/repo-mirror-ci/repos/xelnor' has unsupported profile format: build-id
-WARNING:pkgcore:'xelnor' repo at '/var/lib/repo-mirror-ci/repos/xelnor' has unsupported profile format: build-id
+WARNING:pkgcore:'beatussum-overlay' repo at '/var/lib/repo-mirror-ci/repos/beatussum-overlay' has unsupported profile format: profile-default-eapi
WARNING:pkgcore:'genthree' repo at '/var/lib/repo-mirror-ci/repos/genthree' has unsupported profile format: profile-bashrcs
+WARNING:pkgcore:'xelnor' repo at '/var/lib/repo-mirror-ci/repos/xelnor' has unsupported profile format: build-id
WARNING:pkgcore:'beatussum-overlay' repo at '/var/lib/repo-mirror-ci/repos/beatussum-overlay' has unsupported profile format: profile-default-eapi
-WARNING:pkgcore:EAPI 7 isn't fully supported
- * Cache regenerated successfully
+Traceback (most recent call last):
+ File "/usr/lib/python-exec/python3.6/pmaint", line 4, in <module>
+ scripts.run(basename(__file__))
+ File "/usr/lib64/python3.6/site-packages/pkgcore/scripts/__init__.py", line 32, in run
+ sys.exit(tool())
+ File "/usr/lib64/python3.6/site-packages/snakeoil/cli/tool.py", line 83, in __call__
+ ret = self.main()
+ File "/usr/lib64/python3.6/site-packages/snakeoil/cli/tool.py", line 179, in main
+ self.handle_exec_exception(e)
+ File "/usr/lib64/python3.6/site-packages/snakeoil/cli/tool.py", line 164, in main
+ exitstatus = func(self.options, self.out, self.err)
+ File "/usr/lib64/python3.6/site-packages/pkgcore/scripts/pmaint.py", line 305, in regen_main
+ eclass_caching=(not options.disable_eclass_caching))
+ File "/usr/lib64/python3.6/site-packages/pkgcore/operations/repo.py", line 291, in _proxy_op
+ return getattr(self.raw_operations, op_name)(*args, **kwargs)
+ File "/usr/lib64/python3.6/site-packages/pkgcore/operations/repo.py", line 291, in _proxy_op
+ return getattr(self.raw_operations, op_name)(*args, **kwargs)
+ File "/usr/lib64/python3.6/site-packages/pkgcore/operations/__init__.py", line 73, in _recast_exception_decorator
+ return functor(*args, **kwds)
+ File "/usr/lib64/python3.6/site-packages/pkgcore/operations/repo.py", line 245, in _cmd_api_regen_cache
+ self._cmd_implementation_clean_cache()
+ File "/usr/lib64/python3.6/site-packages/pkgcore/operations/repo.py", line 227, in _cmd_implementation_clean_cache
+ pkgs = frozenset(x.cpvstr for x in self.repo)
+ File "/usr/lib64/python3.6/site-packages/pkgcore/operations/repo.py", line 227, in <genexpr>
+ pkgs = frozenset(x.cpvstr for x in self.repo)
+ File "/usr/lib64/python3.6/site-packages/pkgcore/repository/prototype.py", line 282, in _internal_match
+ for pkg in self._internal_gen_candidates(candidates, **kwargs):
+ File "/usr/lib64/python3.6/site-packages/pkgcore/repository/prototype.py", line 278, in _internal_gen_candidates
+ yield from sorter(pkg_filter(pkgs))
+ File "/usr/lib64/python3.6/site-packages/pkgcore/ebuild/repository.py", line 536, in _pkg_filter
+ if not pkg.is_supported:
+ File "/usr/lib64/python3.6/site-packages/snakeoil/klass.py", line 368, in __call__
+ return self.getter(obj)
+ File "/usr/lib64/python3.6/site-packages/pkgcore/package/base.py", line 89, in dynamic_getattr_dict
+ val = functor(self)
+ File "/usr/lib64/python3.6/site-packages/pkgcore/ebuild/ebuild_src.py", line 183, in get_parsed_eapi
+ i = fileutils.readlines_utf8(ebuild.path)
+ File "/usr/lib64/python3.6/site-packages/snakeoil/_fileutils.py", line 81, in native_readlines
+ handle = open(mypath, mode, encoding=encoding)
+FileNotFoundError: [Errno 2] No such file or directory: '/var/lib/repo-mirror-ci/repos/raw/net-dialup/pptpd/pptpd-1.3.3-r85.ebuild'
+ * caught exception [Errno 2] No such file or directory: '/var/lib/repo-mirror-ci/repos/raw/net-dialup/pptpd/pptpd-1.3.3-r85.ebuild' while processing ebuild src: net-dialup/pptpd-1.3.3-r085
+ * Cache regen failed with 1