aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorodniceanu Andrei <a.horodniceanu@proton.me>2023-12-01 00:09:44 +0200
committerHorodniceanu Andrei <a.horodniceanu@proton.me>2023-12-17 16:26:48 +0200
commitf93527655c8f3c3a21a322082d74bb817eba45be (patch)
treecb02fb0cabb824b3cb0550b95fd36b0ad55d0e00 /x11-terms
parentdev-libs/gtkd: install pkg-config files (diff)
downloaddlang-f93527655c8f3c3a21a322082d74bb817eba45be.tar.gz
dlang-f93527655c8f3c3a21a322082d74bb817eba45be.tar.bz2
dlang-f93527655c8f3c3a21a322082d74bb817eba45be.zip
x11-terms/tilix: add 1.9.6
Signed-off-by: Horodniceanu Andrei <a.horodniceanu@proton.me>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/tilix/Manifest1
-rw-r--r--x11-terms/tilix/tilix-1.9.6.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/x11-terms/tilix/Manifest b/x11-terms/tilix/Manifest
index 4ad9639..5bf3865 100644
--- a/x11-terms/tilix/Manifest
+++ b/x11-terms/tilix/Manifest
@@ -1 +1,2 @@
DIST tilix-1.9.3.tar.gz 837010 BLAKE2B b132ec95a51a09d4fba5b4358961919c581b2ffec2c1d05c2b5e11a5f49f6404cbdd5d553bf2735c1630e917b66c5b8e80d6186f6bf97c0c1f6eae983d575ba5 SHA512 59165d24404c3fb9beb40070005131c6262abe98626c164552c0d90d0d74b3fc1d0532430b56027497674934a7fbfd2fdf4195b01915cb6d03a284f468c7adca
+DIST tilix-1.9.6.tar.gz 1047476 BLAKE2B a08ea0c4060772af798f44119461764c74f5db330b9dbcb6381a94713c69f213c07affb024f06efc51ad58725117a515869cb74644f7240422496bd8ce8be7aa SHA512 2d51e8c0203863573e52c7bf68a66ba4ec58f929ecebf90bb68bae3f15d9f745f956fc524b7dd23d1804d5130dd0bf39ff834d262042375448e53714021338f6
diff --git a/x11-terms/tilix/tilix-1.9.6.ebuild b/x11-terms/tilix/tilix-1.9.6.ebuild
new file mode 100644
index 0000000..08c0bed
--- /dev/null
+++ b/x11-terms/tilix/tilix-1.9.6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A tiling terminal emulator for Linux using GTK+ 3"
+HOMEPAGE="https://gnunn1.github.io/tilix-web/"
+LICENSE="MPL-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DLANG_VERSION_RANGE="2.099-2.105"
+DLANG_PACKAGE_TYPE="single"
+# Using dmd and gdc results in linking errors currently.
+# Upstream only tests with ldc2 as well.
+DLANG_COMPILER_DISABLED_BACKENDS=(dmd gdc)
+
+inherit gnome2-utils meson optfeature dlang
+
+GITHUB_URI="https://codeload.github.com/gnunn1"
+SRC_URI="${GITHUB_URI}/${PN}/tar.gz/${PV} -> ${PN}-${PV}.tar.gz"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=sys-devel/gettext-0.19.8.1
+ >=dev-libs/gtkd-3.10.0-r1:3[vte,${DLANG_COMPILER_USE}]
+ sys-libs/libunwind
+ gnome-base/gsettings-desktop-schemas
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ app-text/po4a
+ dev-libs/appstream
+ test? ( dev-util/desktop-file-utils )
+"
+
+d_src_configure() {
+ DFLAGS="${DCFLAGS}" meson_src_configure
+}
+
+d_src_compile() {
+ meson_src_compile
+}
+
+d_src_test() {
+ meson_src_test
+}
+
+d_src_install() {
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ gnome2_schemas_update
+
+ optfeature "Nautilus integration" "dev-python/nautilus-python"
+ optfeature "Password support" "app-crypt/libsecret gnome-base/gnome-keyring"
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}