aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2019-05-21 10:34:31 +0200
committerMarco Leise <marco.leise@gmx.de>2019-05-21 10:34:31 +0200
commit8450ca14e3bf7a681d3cbc2cda885dbcac0ddc45 (patch)
tree95a9d67c7c94ea6120b6941f4c7af8051f45f296 /x11-terms
parentstabilization sweep (diff)
downloaddlang-8450ca14e3bf7a681d3cbc2cda885dbcac0ddc45.tar.gz
dlang-8450ca14e3bf7a681d3cbc2cda885dbcac0ddc45.tar.bz2
dlang-8450ca14e3bf7a681d3cbc2cda885dbcac0ddc45.zip
tilix-1.9.3
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/tilix/Manifest1
-rw-r--r--x11-terms/tilix/tilix-1.9.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/x11-terms/tilix/Manifest b/x11-terms/tilix/Manifest
index faca387..f0cf719 100644
--- a/x11-terms/tilix/Manifest
+++ b/x11-terms/tilix/Manifest
@@ -1,2 +1,3 @@
DIST tilix-1.8.9.tar.gz 823457 BLAKE2B 883fdf0c19bc1d7c2167850d26210671c9405592cb54aff66f0533fdda452d38fb04ec497e41e0fc6b78442031847a905806bc82f995b064ad55c7b6327b4f99 SHA512 ce04763f091c31086ea351ed383b4166b9407d297a2e6721c44daa060ecce043604fa0fab84c12031abac736f0ebd2d937c74efa71799112efcf2aaf4892422d
DIST tilix-1.9.0.tar.gz 836113 BLAKE2B 2985c79008fe985da87d9e76a75748de44ba255e75ce00ce2eb8783f3a333f1d3724cd338b47d1d4436b3e2a6d9a2325e4197f76954edf86db33a19276f685b2 SHA512 f1f2f0a85cd42ab779d9b6a70dc91a4a69bbb2d6fa4fdce6b04f482ae98ca0c1da3813931c6fae1aa38ae73a9ac8272cace224529e0af777e669c6211afc99af
+DIST tilix-1.9.3.tar.gz 837010 BLAKE2B b132ec95a51a09d4fba5b4358961919c581b2ffec2c1d05c2b5e11a5f49f6404cbdd5d553bf2735c1630e917b66c5b8e80d6186f6bf97c0c1f6eae983d575ba5 SHA512 59165d24404c3fb9beb40070005131c6262abe98626c164552c0d90d0d74b3fc1d0532430b56027497674934a7fbfd2fdf4195b01915cb6d03a284f468c7adca
diff --git a/x11-terms/tilix/tilix-1.9.3.ebuild b/x11-terms/tilix/tilix-1.9.3.ebuild
new file mode 100644
index 0000000..c30553c
--- /dev/null
+++ b/x11-terms/tilix/tilix-1.9.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A tiling terminal emulator for Linux using GTK+ 3"
+HOMEPAGE="https://gnunn1.github.io/tilix-web/"
+LICENSE="MPL-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+crypt"
+
+DLANG_VERSION_RANGE="2.075-"
+DLANG_PACKAGE_TYPE="single"
+
+inherit gnome2 dlang
+
+GITHUB_URI="https://codeload.github.com/gnunn1"
+SRC_URI="${GITHUB_URI}/${PN}/tar.gz/${PV} -> ${PN}-${PV}.tar.gz"
+
+RDEPEND="
+ >=sys-devel/gettext-0.19.8.1
+ >=dev-libs/gtkd-3.8.5:3[vte,${DLANG_COMPILER_USE}]
+ x11-libs/vte:2.91[crypt?]"
+DEPEND="
+ sys-devel/automake:1.15
+ >=sys-devel/autoconf-2.69
+ app-text/po4a
+ ${RDEPEND}"
+
+src_prepare() {
+ eapply_user
+ ./autogen.sh
+}
+
+d_src_configure() {
+ export GTKD_CFLAGS="-I/usr/include/dlang/gtkd-3"
+ export GTKD_LIBS="-L-ldl -L-lvted-3 -L-lgtkd-3"
+ DC="${DMD}" default_src_configure
+}
+
+d_src_install() {
+ default_src_install
+ # Silence "Please fix the ebuild not to install compressed files" QA warnings
+ gzip -d "${D}"/usr/share/man/man1/tilix.1.gz "${D}"/usr/share/man/*/man1/tilix.1.gz
+}