aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2020-05-30 17:34:00 +0200
committerMarco Leise <marco.leise@gmx.de>2020-05-30 17:34:00 +0200
commit92068078c5e1e34f23e696077b887fe85aae9daa (patch)
treeeaf7e0ef54a8e43f63bb38aacdba12cc8ed42298 /net-misc
parentstabilization sweep (diff)
downloaddlang-92068078c5e1e34f23e696077b887fe85aae9daa.tar.gz
dlang-92068078c5e1e34f23e696077b887fe85aae9daa.tar.bz2
dlang-92068078c5e1e34f23e696077b887fe85aae9daa.zip
onedrive-2.4.2
Signed-off-by: Marco Leise <marco.leise@gmx.de>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/onedrive/Manifest1
-rw-r--r--net-misc/onedrive/onedrive-2.4.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-misc/onedrive/Manifest b/net-misc/onedrive/Manifest
index 63e9065..b1154af 100644
--- a/net-misc/onedrive/Manifest
+++ b/net-misc/onedrive/Manifest
@@ -1,2 +1,3 @@
DIST onedrive-2.4.0.tar.gz 670382 BLAKE2B 1b6adfe6c1eecb3a32461a2a12c1bcae4db534b6fa73bddda2787317dd9285c17081fdeb783c1362e055eaed4ebbe2f2aec5f5bdc80640e9d90e4fd73fa525c8 SHA512 57c57c716b95ab2d517f73a849938dfa49a167d548050eefd4729a5c2ff128072dcc5ca0633eb6eb7722d45533e767dd03b5c7ea529652d36b087d4ab57a542c
DIST onedrive-2.4.1.tar.gz 681397 BLAKE2B 41ceec5c6f8e1d2cdb49d74514b7ae68f3dad1795f4d0c95e0e1fd2bacb24dfc4de5709bb831bc7412e626013ed6764f289b57cd96c60c7be2709ece52682e6c SHA512 0844efcacffba5d0473867e803e96869d350c3d1f3b75f374a17899be3469f96ea83e51f69eb1a9a73b8735320b9131a3e2fa782e249980de7639dba9dc2fa0a
+DIST onedrive-2.4.2.tar.gz 685026 BLAKE2B 0eb5e16670d65ae6743f8aa8e6d754bceb6d3f45ac3036e5a03e036b882b58145f3836ab55d5a80bca5bd4e8a4f9dfe590e48771c28f2c90b4d6fa68a6477438 SHA512 08c1a04dfefd0017f1ded8ee17653d91d8ac6ce1e8a942171de37c28deed6fb463e9a85474bea68a6e309dcdf188bdb8a8aed24c723bb01285186135dc43b901
diff --git a/net-misc/onedrive/onedrive-2.4.2.ebuild b/net-misc/onedrive/onedrive-2.4.2.ebuild
new file mode 100644
index 0000000..c87fd4d
--- /dev/null
+++ b/net-misc/onedrive/onedrive-2.4.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Free Client for OneDrive on Linux"
+HOMEPAGE="https://github.com/abraunegg/onedrive"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="
+ >=dev-db/sqlite-3.7.15:3
+ net-misc/curl
+ libnotify? ( x11-libs/libnotify )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+SRC_URI="https://codeload.github.com/abraunegg/onedrive/tar.gz/v${PV} -> ${P}.tar.gz"
+DLANG_VERSION_RANGE="2.082-"
+DLANG_PACKAGE_TYPE="single"
+IUSE="debug libnotify"
+
+inherit dlang systemd bash-completion-r1
+
+d_src_configure() {
+ # LDC is supported without wrapper
+ if [[ "${DLANG_VENDOR}" == "LDC" ]]; then
+ export DC=${DC}
+ export DCFLAGS=${DCFLAGS}
+ else
+ export DC=${DMD}
+ export DCFLAGS=${DMDFLAGS}
+ fi
+ econf --disable-version-check --enable-completions $(use_enable debug) $(use_enable libnotify notifications) \
+ --with-zsh-completion-dir=/usr/share/zsh/site-functions --with-bash-completion-dir="$(get_bashcompdir)" \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install
+ # log directory
+ keepdir /var/log/onedrive
+ fperms 775 /var/log/onedrive
+ fowners root:users /var/log/onedrive
+ # init script
+ dobin contrib/init.d/onedrive_service.sh
+ newinitd contrib/init.d/onedrive.init onedrive
+}
+
+pkg_postinst() {
+ elog "OneDrive Free Client needs to be authorized to access your data before the"
+ elog "first use. To do so, run onedrive in a terminal for the user in question and"
+ elog "follow the steps on screen."
+ elog
+ ewarn "When upgrading from 2.3 you are required you to reauthorise your client."
+ ewarn "This is due to changing the client identifier to assist with resolving"
+ ewarn "the correct handling of 429 error responses (activityLimitReached)"
+}