aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiko Böckerman <niko.bockerman@protonmail.com>2022-03-17 17:32:15 +0200
committerNiko Böckerman <niko.bockerman@protonmail.com>2022-03-23 21:48:38 +0200
commit601527242dcc1c78c6ba3fd133cb61ab38c972ba (patch)
treebb2b582f0b76f396c5e7c60c1c7caebf1e3ea312 /net-misc
parentRemove ldc2-1.24.0 source tarball from Manifest (diff)
downloaddlang-601527242dcc1c78c6ba3fd133cb61ab38c972ba.tar.gz
dlang-601527242dcc1c78c6ba3fd133cb61ab38c972ba.tar.bz2
dlang-601527242dcc1c78c6ba3fd133cb61ab38c972ba.zip
onedrive-2.4.16
Signed-off-by: Niko Böckerman <niko.bockerman@protonmail.com>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/onedrive/Manifest1
-rw-r--r--net-misc/onedrive/onedrive-2.4.16.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-misc/onedrive/Manifest b/net-misc/onedrive/Manifest
index 869711c..85abf8b 100644
--- a/net-misc/onedrive/Manifest
+++ b/net-misc/onedrive/Manifest
@@ -1,2 +1,3 @@
DIST onedrive-2.4.12.tar.gz 1034187 BLAKE2B 5c9bf0a4c9fbf966762bee68f83af62021910d26052c258d8c805c9628f76d91181a56b2eb32bb1d8ad2d5c449d1bfb848a2b33e73c9b6ab92d0216abea89ff9 SHA512 e870b85716a1d86c4b589daeb790006e8b15fe83064337be73eb985f821a476f172fef4e7372b6f953190243a117fe71c959afae0039ee81b0ad2151317d93d2
DIST onedrive-2.4.13.tar.gz 1036028 BLAKE2B f11d750c3e9b452a997c0aaa260f072b1614fadf6eb50d8b0524752fd8340698fd4fa6b9678a92a95f9237454d40bbfc97f7de04665ceb40ce5e85bbd0aa5047 SHA512 6861c01d996ede667f0cb622038ad714a060cd2bc1c78f650cb6bcc9a671879f0ef675519db83a46668ce41bf7b71ef36157e2a1c7786e7b97d0e9153abf704c
+DIST onedrive-2.4.16.tar.gz 1139304 BLAKE2B 403d978d3830ea690faaa59df93d489636f0d4c085169755a50ecb2ec2e84d78d28a8a3eb2fb6fde1a2464726a45cc2bc4b0aa37ef5fab2aa0ac6eca04dd4bd9 SHA512 49100664d57e30c778923dea30afb7842cc978b5407114a39403624f9a4e1fc8b631a3da45f32dea77b4146e1f36e3b48ba72f055a8fb8b3656a455144555fa7
diff --git a/net-misc/onedrive/onedrive-2.4.16.ebuild b/net-misc/onedrive/onedrive-2.4.16.ebuild
new file mode 100644
index 0000000..b3fdc55
--- /dev/null
+++ b/net-misc/onedrive/onedrive-2.4.16.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Free Client for OneDrive on Linux"
+HOMEPAGE="https://abraunegg.github.io/"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="
+ >=dev-db/sqlite-3.7.15:3
+ net-misc/curl
+ libnotify? ( x11-libs/libnotify )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+SRC_URI="https://codeload.github.com/abraunegg/onedrive/tar.gz/v${PV} -> ${P}.tar.gz"
+DLANG_VERSION_RANGE="2.087-"
+DLANG_PACKAGE_TYPE="single"
+IUSE="debug libnotify"
+
+inherit dlang systemd bash-completion-r1
+
+d_src_configure() {
+ # LDC is supported without wrapper
+ if [[ "${DLANG_VENDOR}" == "LDC" ]]; then
+ export DC=${DC}
+ export DCFLAGS=${DCFLAGS}
+ else
+ export DC=${DMD}
+ export DCFLAGS=${DMDFLAGS}
+ fi
+ econf --disable-version-check --enable-completions $(use_enable debug) $(use_enable libnotify notifications) \
+ --with-zsh-completion-dir=/usr/share/zsh/site-functions \
+ --with-bash-completion-dir="$(get_bashcompdir)" \
+ --with-fish-completion-dir=/usr/share/fish/completions \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install
+ # log directory
+ keepdir /var/log/onedrive
+ fperms 775 /var/log/onedrive
+ fowners root:users /var/log/onedrive
+ # init script
+ dobin contrib/init.d/onedrive_service.sh
+ newinitd contrib/init.d/onedrive.init onedrive
+}
+
+pkg_postinst() {
+ elog "OneDrive Free Client needs to be authorized to access your data before the"
+ elog "first use. To do so, run onedrive in a terminal for the user in question and"
+ elog "follow the steps on screen."
+ elog
+ ewarn "When upgrading from 2.3 you are required you to reauthorise your client."
+ ewarn "This is due to changing the client identifier to assist with resolving"
+ ewarn "the correct handling of 429 error responses (activityLimitReached)"
+}