aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrei Horodniceanu <a.horodniceanu@proton.me>2024-03-13 23:27:24 +0200
committerAndrei Horodniceanu <a.horodniceanu@proton.me>2024-03-13 23:27:24 +0200
commite7f724bb736cf0df737b39fa41a8a11600876592 (patch)
treee07bda76e25d630ead144d8bb43889576c7a4f9c /dev-lang
parentdev-lang/ldc2: drop 1.33.0 (diff)
downloaddlang-e7f724bb736cf0df737b39fa41a8a11600876592.tar.gz
dlang-e7f724bb736cf0df737b39fa41a8a11600876592.tar.bz2
dlang-e7f724bb736cf0df737b39fa41a8a11600876592.zip
dev-lang/ldc2: drop 1.34.0
Signed-off-by: Andrei Horodniceanu <a.horodniceanu@proton.me>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ldc2/ldc2-1.34.0.ebuild79
1 files changed, 0 insertions, 79 deletions
diff --git a/dev-lang/ldc2/ldc2-1.34.0.ebuild b/dev-lang/ldc2/ldc2-1.34.0.ebuild
deleted file mode 100644
index f055ccb..0000000
--- a/dev-lang/ldc2/ldc2-1.34.0.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib-build cmake llvm
-
-MY_PV="${PV//_/-}"
-MY_P="ldc-${MY_PV}-src"
-SRC_URI="https://github.com/ldc-developers/ldc/releases/download/v${MY_PV}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="LLVM D Compiler"
-HOMEPAGE="https://github.com/ldc-developers/ldc"
-KEYWORDS="amd64 ~arm64 x86"
-LICENSE="BSD"
-SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
-
-IUSE="static-libs"
-
-# Upstream supports LLVM 11.0 through 16.
-RDEPEND="
- || (
- sys-devel/llvm:16
- sys-devel/llvm:15
- sys-devel/llvm:14
- )
- <sys-devel/llvm-17:=
- >=app-eselect/eselect-dlang-20140709"
-DEPEND="${RDEPEND}"
-LLVM_MAX_SLOT=16
-PATCHES="${FILESDIR}/ldc2-1.15.0-link-defaultlib-shared.patch"
-
-# For now, we support amd64 multilib. Anyone is free to add more support here.
-MULTILIB_COMPAT=( abi_x86_{32,64} )
-
-# Upstream supports "2.079-"
-DLANG_VERSION_RANGE="2.075-2.080 2.082-2.106"
-DLANG_PACKAGE_TYPE="single"
-
-inherit dlang
-
-src_prepare() {
- cmake_src_prepare
-}
-
-d_src_configure() {
- # Make sure libphobos2 is installed into ldc2's directory.
- export LIBDIR_${ABI}="${LIBDIR_HOST}"
- local mycmakeargs=(
- -DD_VERSION=2
- -DCMAKE_INSTALL_PREFIX=/usr/lib/ldc2/$(ver_cut 1-2)
- -DD_COMPILER="${DMD} $(dlang_dmdw_dcflags)"
- -DLDC_WITH_LLD=OFF
- )
- use static-libs && mycmakeargs+=( -DBUILD_SHARED_LIBS=BOTH ) || mycmakeargs+=( -DBUILD_SHARED_LIBS=ON )
- use abi_x86_32 && use abi_x86_64 && mycmakeargs+=( -DMULTILIB=ON )
- cmake_src_configure
-}
-
-d_src_compile()
-{
- cmake_src_compile
-}
-
-d_src_install() {
- cmake_src_install
-
- rm -rf "${ED}"/usr/share/bash-completion
-}
-
-pkg_postinst() {
- # Update active ldc2
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}
-
-pkg_postrm() {
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}