aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorodniceanu Andrei <a.horodniceanu@protonmail.com>2022-07-23 14:38:47 +0300
committerHorodniceanu Andrei <a.horodniceanu@protonmail.com>2022-07-23 15:49:20 +0300
commit67933f488e18b8a672e975d103cfcbd14c1ed06e (patch)
treec9c22f8fa6d6ad504be5dd95c1aaeee96cb7abd9 /dev-lang
parentMerge branch 'add-gdc-11.3.0' (diff)
downloaddlang-67933f488e18b8a672e975d103cfcbd14c1ed06e.tar.gz
dlang-67933f488e18b8a672e975d103cfcbd14c1ed06e.tar.bz2
dlang-67933f488e18b8a672e975d103cfcbd14c1ed06e.zip
Remove llvm-12 dependency
Signed-off-by: Horodniceanu Andrei <a.horodniceanu@protonmail.com>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ldc2/Manifest4
-rw-r--r--dev-lang/ldc2/ldc2-1.25.1-r1.ebuild81
-rw-r--r--dev-lang/ldc2/ldc2-1.26.0-r1.ebuild81
-rw-r--r--dev-lang/ldc2/ldc2-1.27.1.ebuild81
-rw-r--r--dev-lang/ldc2/ldc2-1.28.1.ebuild81
-rw-r--r--dev-lang/ldc2/ldc2-1.29.0-r1.ebuild (renamed from dev-lang/ldc2/ldc2-1.29.0.ebuild)1
6 files changed, 0 insertions, 329 deletions
diff --git a/dev-lang/ldc2/Manifest b/dev-lang/ldc2/Manifest
index bd2a3ec..8298964 100644
--- a/dev-lang/ldc2/Manifest
+++ b/dev-lang/ldc2/Manifest
@@ -1,5 +1 @@
-DIST ldc-1.25.1-src.tar.gz 7625687 BLAKE2B 02eacb06c334608d4b649d8fdffdef03cd1645a2d237063c888728c840a8c939df1c1ff9aefe3efab395358a7757dd287d1efa7a704b37f0b2661c8c1b5faaca SHA512 a087f48ec8f559eea17f88f9c00893c84db17bfcb10590011f43d6d1573a30286067207133ad6d249897fe51cb22829c2ddf00bf23210f01aa059b1f87790fae
-DIST ldc-1.26.0-src.tar.gz 7650063 BLAKE2B d132dc842e27a93fc76810e17db1d67f856530ca7e6948c795ec5f943e4be32513b4a956aa9217df4acd45806bc81ff855ebab757aa3f6a1943fa7c394b3e3ce SHA512 7bb2aa464f5ba834c07f67743f4af01db6588d56611d6c9e250a6908ebe93a0dcd9d3a79f8f252fc92eeb4826bfa62de6c51c4db03ff80e60a8d993e4451f573
-DIST ldc-1.27.1-src.tar.gz 7742031 BLAKE2B d459d70e6745930aca1293cf17ec186526393ce3ff3888c0aad3781f215ed53d6a44a08e3a1bc69e91ba0b039c443e277a0b526e7054e18445e074be1de12e87 SHA512 d10118c9c52a26510f3f9d8d93b38f89144aca7b861ef663e807df0bcf1bb3bc12d1410e6617891e58a3f2cfe160e31bb8478bb1f39f79d026c97ce7e72a9f65
-DIST ldc-1.28.1-src.tar.gz 7937120 BLAKE2B fae97676064506989883c03f628685bc8ddd3bb3cd1f41afef9a34bba83c9d803a6cff186145a26e8605479b18b7a7661bb14a950f5891ab27b195f045a219a9 SHA512 3ec4c754873db4c00fb2e45ec42a3641f46ed6a7d882c0a00edb9ee8a5686fad7c43e45068b7a216b2df89395860ccfc700a7f3efea38c2d3d0ac3b90dd5d3a1
DIST ldc-1.29.0-src.tar.gz 8080420 BLAKE2B 37890b283f8097e6d845d6d849b9c04e64bdca5654f483bd83e0d387f0bc4d1cacdef023ccab67dd140a57615e0e7ba9f92acffb18f49211ca130a503f8307e8 SHA512 f8a1e23150b84ef31d3616b9be8ca4c1a64df2b3f26fbedb1119a7d2d3dacad10cd86b6b9bf79728c8c725213f8f7ae88acdeb7a0d9e2f3f5068857f97c39a7e
diff --git a/dev-lang/ldc2/ldc2-1.25.1-r1.ebuild b/dev-lang/ldc2/ldc2-1.25.1-r1.ebuild
deleted file mode 100644
index 9e27b2c..0000000
--- a/dev-lang/ldc2/ldc2-1.25.1-r1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib-build cmake llvm
-
-MY_PV="${PV//_/-}"
-MY_P="ldc-${MY_PV}-src"
-SRC_URI="https://github.com/ldc-developers/ldc/releases/download/v${MY_PV}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="LLVM D Compiler"
-HOMEPAGE="https://github.com/ldc-developers/ldc"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-LICENSE="BSD"
-SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
-
-IUSE="static-libs"
-
-# We support LLVM 6.0 through 12.
-RDEPEND="dev-util/ninja
- || (
- sys-devel/llvm:12
- )
- <sys-devel/llvm-13:=
- >=app-eselect/eselect-dlang-20140709"
-DEPEND="${RDEPEND}"
-LLVM_MAX_SLOT=12
-PATCHES="${FILESDIR}/ldc2-1.15.0-link-defaultlib-shared.patch"
-
-# For now, we support amd64 multilib. Anyone is free to add more support here.
-MULTILIB_COMPAT=( abi_x86_{32,64} )
-
-DLANG_VERSION_RANGE="2.075-"
-DLANG_PACKAGE_TYPE="single"
-
-inherit dlang
-
-detect_hardened() {
- gcc --version | grep -o Hardened
-}
-
-src_prepare() {
- cmake_src_prepare
-}
-
-d_src_configure() {
- # Make sure libphobos2 is installed into ldc2's directory.
- export LIBDIR_${ABI}="${LIBDIR_HOST}"
- local mycmakeargs=(
- -DD_VERSION=2
- -DCMAKE_INSTALL_PREFIX=/usr/lib/ldc2/$(ver_cut 1-2)
- -DD_COMPILER="${DMD}"
- -DLDC_WITH_LLD=OFF
- )
- use static-libs && mycmakeargs+=( -DBUILD_SHARED_LIBS=BOTH ) || mycmakeargs+=( -DBUILD_SHARED_LIBS=ON )
- use abi_x86_32 && use abi_x86_64 && mycmakeargs+=( -DMULTILIB=ON )
- detect_hardened && mycmakeargs+=( -DADDITIONAL_DEFAULT_LDC_SWITCHES=' "-relocation-model=pic",' )
- cmake_src_configure
-}
-
-d_src_compile()
-{
- cmake_src_compile
-}
-
-d_src_install() {
- cmake_src_install
-
- rm -rf "${ED}"/usr/share/bash-completion
-}
-
-pkg_postinst() {
- # Update active ldc2
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}
-
-pkg_postrm() {
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}
diff --git a/dev-lang/ldc2/ldc2-1.26.0-r1.ebuild b/dev-lang/ldc2/ldc2-1.26.0-r1.ebuild
deleted file mode 100644
index 9e27b2c..0000000
--- a/dev-lang/ldc2/ldc2-1.26.0-r1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib-build cmake llvm
-
-MY_PV="${PV//_/-}"
-MY_P="ldc-${MY_PV}-src"
-SRC_URI="https://github.com/ldc-developers/ldc/releases/download/v${MY_PV}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="LLVM D Compiler"
-HOMEPAGE="https://github.com/ldc-developers/ldc"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-LICENSE="BSD"
-SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
-
-IUSE="static-libs"
-
-# We support LLVM 6.0 through 12.
-RDEPEND="dev-util/ninja
- || (
- sys-devel/llvm:12
- )
- <sys-devel/llvm-13:=
- >=app-eselect/eselect-dlang-20140709"
-DEPEND="${RDEPEND}"
-LLVM_MAX_SLOT=12
-PATCHES="${FILESDIR}/ldc2-1.15.0-link-defaultlib-shared.patch"
-
-# For now, we support amd64 multilib. Anyone is free to add more support here.
-MULTILIB_COMPAT=( abi_x86_{32,64} )
-
-DLANG_VERSION_RANGE="2.075-"
-DLANG_PACKAGE_TYPE="single"
-
-inherit dlang
-
-detect_hardened() {
- gcc --version | grep -o Hardened
-}
-
-src_prepare() {
- cmake_src_prepare
-}
-
-d_src_configure() {
- # Make sure libphobos2 is installed into ldc2's directory.
- export LIBDIR_${ABI}="${LIBDIR_HOST}"
- local mycmakeargs=(
- -DD_VERSION=2
- -DCMAKE_INSTALL_PREFIX=/usr/lib/ldc2/$(ver_cut 1-2)
- -DD_COMPILER="${DMD}"
- -DLDC_WITH_LLD=OFF
- )
- use static-libs && mycmakeargs+=( -DBUILD_SHARED_LIBS=BOTH ) || mycmakeargs+=( -DBUILD_SHARED_LIBS=ON )
- use abi_x86_32 && use abi_x86_64 && mycmakeargs+=( -DMULTILIB=ON )
- detect_hardened && mycmakeargs+=( -DADDITIONAL_DEFAULT_LDC_SWITCHES=' "-relocation-model=pic",' )
- cmake_src_configure
-}
-
-d_src_compile()
-{
- cmake_src_compile
-}
-
-d_src_install() {
- cmake_src_install
-
- rm -rf "${ED}"/usr/share/bash-completion
-}
-
-pkg_postinst() {
- # Update active ldc2
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}
-
-pkg_postrm() {
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}
diff --git a/dev-lang/ldc2/ldc2-1.27.1.ebuild b/dev-lang/ldc2/ldc2-1.27.1.ebuild
deleted file mode 100644
index 9e27b2c..0000000
--- a/dev-lang/ldc2/ldc2-1.27.1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib-build cmake llvm
-
-MY_PV="${PV//_/-}"
-MY_P="ldc-${MY_PV}-src"
-SRC_URI="https://github.com/ldc-developers/ldc/releases/download/v${MY_PV}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="LLVM D Compiler"
-HOMEPAGE="https://github.com/ldc-developers/ldc"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-LICENSE="BSD"
-SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
-
-IUSE="static-libs"
-
-# We support LLVM 6.0 through 12.
-RDEPEND="dev-util/ninja
- || (
- sys-devel/llvm:12
- )
- <sys-devel/llvm-13:=
- >=app-eselect/eselect-dlang-20140709"
-DEPEND="${RDEPEND}"
-LLVM_MAX_SLOT=12
-PATCHES="${FILESDIR}/ldc2-1.15.0-link-defaultlib-shared.patch"
-
-# For now, we support amd64 multilib. Anyone is free to add more support here.
-MULTILIB_COMPAT=( abi_x86_{32,64} )
-
-DLANG_VERSION_RANGE="2.075-"
-DLANG_PACKAGE_TYPE="single"
-
-inherit dlang
-
-detect_hardened() {
- gcc --version | grep -o Hardened
-}
-
-src_prepare() {
- cmake_src_prepare
-}
-
-d_src_configure() {
- # Make sure libphobos2 is installed into ldc2's directory.
- export LIBDIR_${ABI}="${LIBDIR_HOST}"
- local mycmakeargs=(
- -DD_VERSION=2
- -DCMAKE_INSTALL_PREFIX=/usr/lib/ldc2/$(ver_cut 1-2)
- -DD_COMPILER="${DMD}"
- -DLDC_WITH_LLD=OFF
- )
- use static-libs && mycmakeargs+=( -DBUILD_SHARED_LIBS=BOTH ) || mycmakeargs+=( -DBUILD_SHARED_LIBS=ON )
- use abi_x86_32 && use abi_x86_64 && mycmakeargs+=( -DMULTILIB=ON )
- detect_hardened && mycmakeargs+=( -DADDITIONAL_DEFAULT_LDC_SWITCHES=' "-relocation-model=pic",' )
- cmake_src_configure
-}
-
-d_src_compile()
-{
- cmake_src_compile
-}
-
-d_src_install() {
- cmake_src_install
-
- rm -rf "${ED}"/usr/share/bash-completion
-}
-
-pkg_postinst() {
- # Update active ldc2
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}
-
-pkg_postrm() {
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}
diff --git a/dev-lang/ldc2/ldc2-1.28.1.ebuild b/dev-lang/ldc2/ldc2-1.28.1.ebuild
deleted file mode 100644
index 34437cb..0000000
--- a/dev-lang/ldc2/ldc2-1.28.1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib-build cmake llvm
-
-MY_PV="${PV//_/-}"
-MY_P="ldc-${MY_PV}-src"
-SRC_URI="https://github.com/ldc-developers/ldc/releases/download/v${MY_PV}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="LLVM D Compiler"
-HOMEPAGE="https://github.com/ldc-developers/ldc"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-LICENSE="BSD"
-SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
-
-IUSE="static-libs"
-
-# We support LLVM 6.0 through 10.
-RDEPEND="dev-util/ninja
- || (
- sys-devel/llvm:12
- )
- <sys-devel/llvm-13:=
- >=app-eselect/eselect-dlang-20140709"
-DEPEND="${RDEPEND}"
-LLVM_MAX_SLOT=12
-PATCHES="${FILESDIR}/ldc2-1.15.0-link-defaultlib-shared.patch"
-
-# For now, we support amd64 multilib. Anyone is free to add more support here.
-MULTILIB_COMPAT=( abi_x86_{32,64} )
-
-DLANG_VERSION_RANGE="2.075-"
-DLANG_PACKAGE_TYPE="single"
-
-inherit dlang
-
-detect_hardened() {
- gcc --version | grep -o Hardened
-}
-
-src_prepare() {
- cmake_src_prepare
-}
-
-d_src_configure() {
- # Make sure libphobos2 is installed into ldc2's directory.
- export LIBDIR_${ABI}="${LIBDIR_HOST}"
- local mycmakeargs=(
- -DD_VERSION=2
- -DCMAKE_INSTALL_PREFIX=/usr/lib/ldc2/$(ver_cut 1-2)
- -DD_COMPILER="${DMD}"
- -DLDC_WITH_LLD=OFF
- )
- use static-libs && mycmakeargs+=( -DBUILD_SHARED_LIBS=BOTH ) || mycmakeargs+=( -DBUILD_SHARED_LIBS=ON )
- use abi_x86_32 && use abi_x86_64 && mycmakeargs+=( -DMULTILIB=ON )
- detect_hardened && mycmakeargs+=( -DADDITIONAL_DEFAULT_LDC_SWITCHES=' "-relocation-model=pic",' )
- cmake_src_configure
-}
-
-d_src_compile()
-{
- cmake_src_compile
-}
-
-d_src_install() {
- cmake_src_install
-
- rm -rf "${ED}"/usr/share/bash-completion
-}
-
-pkg_postinst() {
- # Update active ldc2
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}
-
-pkg_postrm() {
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}
diff --git a/dev-lang/ldc2/ldc2-1.29.0.ebuild b/dev-lang/ldc2/ldc2-1.29.0-r1.ebuild
index d5fa6fc..1880f4d 100644
--- a/dev-lang/ldc2/ldc2-1.29.0.ebuild
+++ b/dev-lang/ldc2/ldc2-1.29.0-r1.ebuild
@@ -21,7 +21,6 @@ IUSE="static-libs"
# We support LLVM 6.0 through 14.
RDEPEND="dev-util/ninja
|| (
- sys-devel/llvm:12
sys-devel/llvm:13
sys-devel/llvm:14
)