aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrei Horodniceanu <a.horodniceanu@proton.me>2024-02-04 17:56:58 +0200
committerAndrei Horodniceanu <a.horodniceanu@proton.me>2024-02-04 20:59:49 +0200
commit176d27d5d8eb0cd4c06f6a41f679acaa7589ba91 (patch)
treed30af14ab0318e3583487a808938f8fe89b432b4 /dev-lang
parentapp-eselect/eselect-dlang: drop 20190608 (diff)
downloaddlang-176d27d5d8eb0cd4c06f6a41f679acaa7589ba91.tar.gz
dlang-176d27d5d8eb0cd4c06f6a41f679acaa7589ba91.tar.bz2
dlang-176d27d5d8eb0cd4c06f6a41f679acaa7589ba91.zip
*/*: set an upper bound on DLANG_VERSION_RANGE
A package should explicitly list the D compiler versions it supports and not rely on "any version higher than X". This is especially relevant for stable packages. These changes don't actually have any effect right now, they will only make themselves seen when a new compiler version is added to the tree. Signed-off-by: Andrei Horodniceanu <a.horodniceanu@proton.me>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ldc2/ldc2-1.32.2-r1.ebuild2
-rw-r--r--dev-lang/ldc2/ldc2-1.32.2.ebuild2
-rw-r--r--dev-lang/ldc2/ldc2-1.33.0-r1.ebuild2
-rw-r--r--dev-lang/ldc2/ldc2-1.33.0.ebuild2
-rw-r--r--dev-lang/ldc2/ldc2-1.34.0-r1.ebuild2
-rw-r--r--dev-lang/ldc2/ldc2-1.34.0.ebuild2
-rw-r--r--dev-lang/ldc2/ldc2-1.35.0.ebuild4
7 files changed, 8 insertions, 8 deletions
diff --git a/dev-lang/ldc2/ldc2-1.32.2-r1.ebuild b/dev-lang/ldc2/ldc2-1.32.2-r1.ebuild
index f1d5ad7..4d52b34 100644
--- a/dev-lang/ldc2/ldc2-1.32.2-r1.ebuild
+++ b/dev-lang/ldc2/ldc2-1.32.2-r1.ebuild
@@ -33,7 +33,7 @@ PATCHES="${FILESDIR}/ldc2-1.15.0-link-defaultlib-shared.patch"
MULTILIB_COMPAT=( abi_x86_{32,64} )
# Upstream supports "2.079-"
-DLANG_VERSION_RANGE="2.075-2.080 2.082-"
+DLANG_VERSION_RANGE="2.075-2.080 2.082-2.106"
DLANG_PACKAGE_TYPE="single"
inherit dlang
diff --git a/dev-lang/ldc2/ldc2-1.32.2.ebuild b/dev-lang/ldc2/ldc2-1.32.2.ebuild
index c64522d..37cc843 100644
--- a/dev-lang/ldc2/ldc2-1.32.2.ebuild
+++ b/dev-lang/ldc2/ldc2-1.32.2.ebuild
@@ -34,7 +34,7 @@ PATCHES="${FILESDIR}/ldc2-1.15.0-link-defaultlib-shared.patch"
MULTILIB_COMPAT=( abi_x86_{32,64} )
# Upstream supports "2.079-"
-DLANG_VERSION_RANGE="2.075-2.080 2.082-"
+DLANG_VERSION_RANGE="2.075-2.080 2.082-2.106"
DLANG_PACKAGE_TYPE="single"
inherit dlang
diff --git a/dev-lang/ldc2/ldc2-1.33.0-r1.ebuild b/dev-lang/ldc2/ldc2-1.33.0-r1.ebuild
index f1d5ad7..4d52b34 100644
--- a/dev-lang/ldc2/ldc2-1.33.0-r1.ebuild
+++ b/dev-lang/ldc2/ldc2-1.33.0-r1.ebuild
@@ -33,7 +33,7 @@ PATCHES="${FILESDIR}/ldc2-1.15.0-link-defaultlib-shared.patch"
MULTILIB_COMPAT=( abi_x86_{32,64} )
# Upstream supports "2.079-"
-DLANG_VERSION_RANGE="2.075-2.080 2.082-"
+DLANG_VERSION_RANGE="2.075-2.080 2.082-2.106"
DLANG_PACKAGE_TYPE="single"
inherit dlang
diff --git a/dev-lang/ldc2/ldc2-1.33.0.ebuild b/dev-lang/ldc2/ldc2-1.33.0.ebuild
index c64522d..37cc843 100644
--- a/dev-lang/ldc2/ldc2-1.33.0.ebuild
+++ b/dev-lang/ldc2/ldc2-1.33.0.ebuild
@@ -34,7 +34,7 @@ PATCHES="${FILESDIR}/ldc2-1.15.0-link-defaultlib-shared.patch"
MULTILIB_COMPAT=( abi_x86_{32,64} )
# Upstream supports "2.079-"
-DLANG_VERSION_RANGE="2.075-2.080 2.082-"
+DLANG_VERSION_RANGE="2.075-2.080 2.082-2.106"
DLANG_PACKAGE_TYPE="single"
inherit dlang
diff --git a/dev-lang/ldc2/ldc2-1.34.0-r1.ebuild b/dev-lang/ldc2/ldc2-1.34.0-r1.ebuild
index 9cf71ba..975b209 100644
--- a/dev-lang/ldc2/ldc2-1.34.0-r1.ebuild
+++ b/dev-lang/ldc2/ldc2-1.34.0-r1.ebuild
@@ -34,7 +34,7 @@ PATCHES="${FILESDIR}/ldc2-1.15.0-link-defaultlib-shared.patch"
MULTILIB_COMPAT=( abi_x86_{32,64} )
# Upstream supports "2.079-"
-DLANG_VERSION_RANGE="2.075-2.080 2.082-"
+DLANG_VERSION_RANGE="2.075-2.080 2.082-2.106"
DLANG_PACKAGE_TYPE="single"
inherit dlang
diff --git a/dev-lang/ldc2/ldc2-1.34.0.ebuild b/dev-lang/ldc2/ldc2-1.34.0.ebuild
index 8a23db2..f055ccb 100644
--- a/dev-lang/ldc2/ldc2-1.34.0.ebuild
+++ b/dev-lang/ldc2/ldc2-1.34.0.ebuild
@@ -35,7 +35,7 @@ PATCHES="${FILESDIR}/ldc2-1.15.0-link-defaultlib-shared.patch"
MULTILIB_COMPAT=( abi_x86_{32,64} )
# Upstream supports "2.079-"
-DLANG_VERSION_RANGE="2.075-2.080 2.082-"
+DLANG_VERSION_RANGE="2.075-2.080 2.082-2.106"
DLANG_PACKAGE_TYPE="single"
inherit dlang
diff --git a/dev-lang/ldc2/ldc2-1.35.0.ebuild b/dev-lang/ldc2/ldc2-1.35.0.ebuild
index 5ead0f9..cd6d066 100644
--- a/dev-lang/ldc2/ldc2-1.35.0.ebuild
+++ b/dev-lang/ldc2/ldc2-1.35.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -38,7 +38,7 @@ PATCHES="${FILESDIR}/ldc2-1.15.0-link-defaultlib-shared.patch"
MULTILIB_COMPAT=( abi_x86_{32,64} )
# Upstream supports "2.079-"
-DLANG_VERSION_RANGE="2.075-2.080 2.082-"
+DLANG_VERSION_RANGE="2.075-2.080 2.082-2.106"
DLANG_PACKAGE_TYPE="single"
inherit dlang