aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/btrfs-progs/files')
-rw-r--r--sys-fs/btrfs-progs/files/btrfs-progs-4.15.1-e2fsprogs-1.44.0.patch34
-rw-r--r--sys-fs/btrfs-progs/files/btrfs-progs-4.16-static-linkage.patch27
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-fs/btrfs-progs/files/btrfs-progs-4.15.1-e2fsprogs-1.44.0.patch b/sys-fs/btrfs-progs/files/btrfs-progs-4.15.1-e2fsprogs-1.44.0.patch
new file mode 100644
index 0000000..8aa05a5
--- /dev/null
+++ b/sys-fs/btrfs-progs/files/btrfs-progs-4.15.1-e2fsprogs-1.44.0.patch
@@ -0,0 +1,34 @@
+From 33e9f2bd47a17bd0798a664718b6bfcfc4d044a1 Mon Sep 17 00:00:00 2001
+From: Qu Wenruo <wqu@suse.com>
+Date: Wed, 14 Mar 2018 08:56:57 +0800
+Subject: [PATCH] btrfs-progs: convert/ext2: Remove check for
+ ext2_ext_attr_entry->e_value_block
+
+In latest e2fsprogs (1.44.0) definition of ext2_ext_attr_entry has
+removed member e_value_block, as currently ext* doesn't support it set
+anyway.
+
+So remove such check so that we can pass compile.
+
+Issue: #110
+Bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=199071
+Signed-off-by: Qu Wenruo <wqu@suse.com>
+Signed-off-by: David Sterba <dsterba@suse.com>
+---
+ convert/source-ext2.c | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/convert/source-ext2.c b/convert/source-ext2.c
+index b1492c786..070126ec3 100644
+--- a/convert/source-ext2.c
++++ b/convert/source-ext2.c
+@@ -422,8 +422,7 @@ static int ext2_xattr_check_entry(struct ext2_ext_attr_entry *entry,
+ {
+ size_t value_size = entry->e_value_size;
+
+- if (entry->e_value_block != 0 || value_size > size ||
+- entry->e_value_offs + value_size > size)
++ if (value_size > size || entry->e_value_offs + value_size > size)
+ return -EIO;
+ return 0;
+ }
diff --git a/sys-fs/btrfs-progs/files/btrfs-progs-4.16-static-linkage.patch b/sys-fs/btrfs-progs/files/btrfs-progs-4.16-static-linkage.patch
new file mode 100644
index 0000000..b8a7d8b
--- /dev/null
+++ b/sys-fs/btrfs-progs/files/btrfs-progs-4.16-static-linkage.patch
@@ -0,0 +1,27 @@
+https://www.spinics.net/lists/linux-btrfs/msg76763.html
+Reported-by: Attila Tóth
+Bug: https://bugs.gentoo.org/652966
+diff --git a/Makefile b/Makefile
+index 5ba76d2..dc3a31a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -264,6 +264,7 @@ static_libbtrfs_objects = $(patsubst %.o, %.static.o, $(libbtrfs_objects))
+ static_convert_objects = $(patsubst %.o, %.static.o, $(convert_objects))
+ static_mkfs_objects = $(patsubst %.o, %.static.o, $(mkfs_objects))
+ static_image_objects = $(patsubst %.o, %.static.o, $(image_objects))
++static_libbtrfsutil_objects = $(patsubst %.o, %.static.o, $(libbtrfsutil_objects))
+
+ libs_shared = libbtrfs.so.0.1 libbtrfsutil.so.$(libbtrfsutil_version)
+ libs_static = libbtrfs.a libbtrfsutil.a
+@@ -453,7 +454,7 @@ btrfs: btrfs.o $(objects) $(cmds_objects) $(libs_static)
+ @echo " [LD] $@"
+ $(Q)$(CC) -o $@ $^ $(LDFLAGS) $(LIBS) $(LIBS_COMP)
+
+-btrfs.static: btrfs.static.o $(static_objects) $(static_cmds_objects) $(static_libbtrfs_objects)
++btrfs.static: btrfs.static.o $(static_objects) $(static_cmds_objects) $(static_libbtrfs_objects) $(static_libbtrfsutil_objects)
+ @echo " [LD] $@"
+ $(Q)$(CC) -o $@ $^ $(STATIC_LDFLAGS) $(STATIC_LIBS) $(STATIC_LIBS_COMP)
+
+--
+2.17.0
+