summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/octave/octave-4.2.1.ebuild')
-rw-r--r--sci-mathematics/octave/octave-4.2.1.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/sci-mathematics/octave/octave-4.2.1.ebuild b/sci-mathematics/octave/octave-4.2.1.ebuild
index 00a2d44ce48e..e7ecf516cc42 100644
--- a/sci-mathematics/octave/octave-4.2.1.ebuild
+++ b/sci-mathematics/octave/octave-4.2.1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit autotools flag-o-matic fortran-2 java-pkg-opt-2 pax-utils toolchain-funcs
+inherit autotools flag-o-matic fortran-2 java-pkg-opt-2 pax-utils toolchain-funcs xdg-utils
DESCRIPTION="High-level interactive language for numerical computations"
LICENSE="GPL-3"
@@ -175,3 +175,13 @@ src_install() {
echo "LDPATH=${EPREFIX}/usr/$(get_libdir)/${PN}/${PV}" > 99octave || die
doenvd 99octave
}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}