summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild20
-rw-r--r--net-libs/nfqueue-bindings/nfqueue-bindings-0.6.ebuild20
2 files changed, 26 insertions, 14 deletions
diff --git a/net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild b/net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild
index 9b53a58b9d8d..864546a6d190 100644
--- a/net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild
+++ b/net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild
@@ -47,13 +47,19 @@ pkg_setup() {
}
src_prepare() {
- # Fix Perl destination directory
- perl_set_version
- sed -i "s|\${LIB_INSTALL_DIR}/perl\${PERL_VERSION}/|${VENDOR_ARCH}|" perl/CMakeLists.txt || die
- sed -i "s|\${LIB_INSTALL_DIR}/python\${PYTHON_VERSION}/dist-packages/|$(python_get_sitedir)|" python/CMakeLists.txt || die
- # Disable Perl/Python from USE flags
- use perl || sed -i 's|ADD_SUBDIRECTORY(perl)||' CMakeLists.txt || die
- use python || sed -i 's|ADD_SUBDIRECTORY(python)||' CMakeLists.txt || die
+ if use perl; then
+ # Fix Perl destination directory
+ perl_set_version
+ sed -i "s|\${LIB_INSTALL_DIR}/perl\${PERL_VERSION}/|${VENDOR_ARCH}|" perl/CMakeLists.txt || die
+ else
+ sed -i 's|ADD_SUBDIRECTORY(perl)||' CMakeLists.txt || die
+ fi
+
+ if use python; then
+ sed -i "s|\${LIB_INSTALL_DIR}/python\${PYTHON_VERSION}/dist-packages/|$(python_get_sitedir)|" python/CMakeLists.txt || die
+ else
+ sed -i 's|ADD_SUBDIRECTORY(python)||' CMakeLists.txt || die
+ fi
}
src_install() {
diff --git a/net-libs/nfqueue-bindings/nfqueue-bindings-0.6.ebuild b/net-libs/nfqueue-bindings/nfqueue-bindings-0.6.ebuild
index 2282bae84962..6c7f4afc4a1c 100644
--- a/net-libs/nfqueue-bindings/nfqueue-bindings-0.6.ebuild
+++ b/net-libs/nfqueue-bindings/nfqueue-bindings-0.6.ebuild
@@ -45,13 +45,19 @@ pkg_setup() {
}
src_prepare() {
- # Fix Perl destination directory
- perl_set_version
- sed -i "s|\${LIB_INSTALL_DIR}/perl\${PERL_VERSION}/|${VENDOR_ARCH}|" perl/CMakeLists.txt || die
- sed -i "s|\${LIB_INSTALL_DIR}/python\${PYTHON_VERSION}/dist-packages/|$(python_get_sitedir)|" python/CMakeLists.txt || die
- # Disable Perl/Python from USE flags
- use perl || sed -i 's|ADD_SUBDIRECTORY(perl)||' CMakeLists.txt || die
- use python || sed -i 's|ADD_SUBDIRECTORY(python)||' CMakeLists.txt || die
+ if use perl; then
+ # Fix Perl destination directory
+ perl_set_version
+ sed -i "s|\${LIB_INSTALL_DIR}/perl\${PERL_VERSION}/|${VENDOR_ARCH}|" perl/CMakeLists.txt || die
+ else
+ sed -i 's|ADD_SUBDIRECTORY(perl)||' CMakeLists.txt || die
+ fi
+
+ if use python; then
+ sed -i "s|\${LIB_INSTALL_DIR}/python\${PYTHON_VERSION}/dist-packages/|$(python_get_sitedir)|" python/CMakeLists.txt || die
+ else
+ sed -i 's|ADD_SUBDIRECTORY(python)||' CMakeLists.txt || die
+ fi
}
src_install() {