summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rqt_graph')
-rw-r--r--dev-ros/rqt_graph/Manifest1
-rw-r--r--dev-ros/rqt_graph/rqt_graph-0.4.10.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/rqt_graph/Manifest b/dev-ros/rqt_graph/Manifest
index fe265db9dff1..3cba949e37b0 100644
--- a/dev-ros/rqt_graph/Manifest
+++ b/dev-ros/rqt_graph/Manifest
@@ -1 +1,2 @@
+DIST rqt_graph-0.4.10.tar.gz 18455 BLAKE2B 930f2c7bc5d1797eae06e9d37e9f1268a503ddda3bf28adda47779b5879d578353e77e773e7c4417e670870effa6c6a39b5844f19bb101ba6f3733604514e704 SHA512 a37483ed15dc1f1d1492e53d26252a3db6771a1ecf47469a33314c9d17aef88d2e68a5acdca24e412e1d2409c31311ea2f2983aa54b6a5e3b5de5c11b6ab1191
DIST rqt_graph-0.4.9.tar.gz 15857 BLAKE2B 52201faed0ec636dc15a7a7067d19d29f72dca4e98412614a24d6e5f38d916f6cf194fa2b11f84ed0d9476a53f0ad3fdcff807b851286f192c5ee1332033d997 SHA512 21d1395f272f38bb27f7549c865a9e2b4ac5d9267c50dbbaf02016b509b6fab08526c35a87f500788bad094e605d89f925baf939742e78f37d615fedcb04776e
diff --git a/dev-ros/rqt_graph/rqt_graph-0.4.10.ebuild b/dev-ros/rqt_graph/rqt_graph-0.4.10.ebuild
new file mode 100644
index 000000000000..a40a5c1b0a81
--- /dev/null
+++ b/dev-ros/rqt_graph/rqt_graph-0.4.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_graph"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS computation graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosservice[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"