summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-sha/Manifest1
-rw-r--r--dev-ml/ocaml-sha/ocaml-sha-1.15.2.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/ocaml-sha/Manifest b/dev-ml/ocaml-sha/Manifest
index d5f04d4492b9..07c86dccea07 100644
--- a/dev-ml/ocaml-sha/Manifest
+++ b/dev-ml/ocaml-sha/Manifest
@@ -1 +1,2 @@
DIST ocaml-sha-1.15.1.tar.gz 15972 BLAKE2B c80fe4ba9a216fb88b0ca4cdf4f467450ad7225c9aa8fbb7389c85b8372de0a965683dc4a674c82ae4c2801b9f6a83777fbd3bfe5deb68af3d5e9193c058c9d9 SHA512 25af4f3fff6d5126e5e3b5f4dff4d6cc48396ffea48da186450236825bbb79110c7918a2bfa1c77dfaee9570965f9052d87c513d9f9da01208d95962b12cfd1c
+DIST ocaml-sha-1.15.2.tar.gz 15700 BLAKE2B 7504d4302d54d94f6b8143efce6487dbc95c4f909baef515a85a7a6f7adcc5cff94225ae9231770193025312a82384b738e47001f1b6975cd39f4d21b8f6a162 SHA512 7ea47377747ef4c36791c4ed9ff88fe138ee14d012cc3f7b41fcc28776e57ea54c5ee5cc033adc6288177ed834afb73c44e60cfff01f1be28492a992f97a1d06
diff --git a/dev-ml/ocaml-sha/ocaml-sha-1.15.2.ebuild b/dev-ml/ocaml-sha/ocaml-sha-1.15.2.ebuild
new file mode 100644
index 000000000000..dca25b58d530
--- /dev/null
+++ b/dev-ml/ocaml-sha/ocaml-sha-1.15.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DUNE_PKG_NAME=sha
+
+inherit dune
+
+DESCRIPTION="Binding to the SHA cryptographic functions"
+HOMEPAGE="https://github.com/djs55/ocaml-sha/"
+SRC_URI="https://github.com/djs55/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-ml/stdlib-shims:="
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-ml/ounit2 )"