summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/irrlicht-headers/irrlicht-headers-1.8.4.ebuild')
-rw-r--r--dev-games/irrlicht-headers/irrlicht-headers-1.8.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-games/irrlicht-headers/irrlicht-headers-1.8.4.ebuild b/dev-games/irrlicht-headers/irrlicht-headers-1.8.4.ebuild
new file mode 100644
index 000000000000..c954409b0df4
--- /dev/null
+++ b/dev-games/irrlicht-headers/irrlicht-headers-1.8.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+MY_PN="irrlicht"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Irrlicht 3D engine headers"
+HOMEPAGE="http://irrlicht.sourceforge.net/"
+SRC_URI="mirror://sourceforge/irrlicht/${MY_P}.zip
+ https://dev.gentoo.org/~mgorny/dist/${MY_P}-patchset.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="!<dev-games/irrlicht-1.8.4-r1"
+BDEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}/source/${MY_PN^}
+
+PATCHES=(
+ "${WORKDIR}"/${MY_P}-patchset/${MY_P}-config.patch
+)
+
+src_prepare() {
+ cd "${WORKDIR}"/${MY_P} || die
+ edos2unix include/IrrCompileConfig.h
+ default
+}
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ cd "${WORKDIR}"/${MY_P} || die
+
+ insinto /usr/include/${MY_PN}
+ doins include/*
+}