summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/sqlite-3.20.1-r1.ebuild12
1 files changed, 12 insertions, 0 deletions
diff --git a/dev-db/sqlite/sqlite-3.20.1-r1.ebuild b/dev-db/sqlite/sqlite-3.20.1-r1.ebuild
index 137b7b0eeb21..6b547ffb208d 100644
--- a/dev-db/sqlite/sqlite-3.20.1-r1.ebuild
+++ b/dev-db/sqlite/sqlite-3.20.1-r1.ebuild
@@ -74,6 +74,18 @@ src_prepare() {
eautoreconf
multilib_copy_sources
+
+ preparation() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+
+ if [[ "${ABI}" == "x86" ]]; then
+ # Disable tests broken on x86.
+ sed -e "/^for {set i 0} {\$i<1000} {incr i} {$/,/^}$/d" -i test/date.test || die "sed failed"
+ fi
+
+ popd > /dev/null || die
+ }
+ multilib_foreach_abi preparation
}
multilib_src_configure() {