summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/vim-clang-format/vim-clang-format-0_pre20200506.ebuild')
-rw-r--r--app-vim/vim-clang-format/vim-clang-format-0_pre20200506.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/vim-clang-format/vim-clang-format-0_pre20200506.ebuild b/app-vim/vim-clang-format/vim-clang-format-0_pre20200506.ebuild
new file mode 100644
index 000000000000..3a12f0b17060
--- /dev/null
+++ b/app-vim/vim-clang-format/vim-clang-format-0_pre20200506.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+#VIM_PLUGIN_VIM_VERSION="7.0"
+inherit vim-plugin
+
+COMMIT_HASH="95593b67723f23979cd7344ecfd049f2f917830f"
+DESCRIPTION="Vim plugin for clang-format"
+HOMEPAGE="https://github.com/rhysd/vim-clang-format"
+SRC_URI="https://github.com/rhysd/${PN}/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT_HASH}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-devel/clang"
+
+src_prepare() {
+ default
+
+ # tests are written in ruby, prefer to avoid that
+ rm -r .travis.yml test || die
+}