summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/yelp-tools/yelp-tools-40.0.ebuild')
-rw-r--r--app-text/yelp-tools/yelp-tools-40.0.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/app-text/yelp-tools/yelp-tools-40.0.ebuild b/app-text/yelp-tools/yelp-tools-40.0.ebuild
index 9a95c578eaca..146acdd72141 100644
--- a/app-text/yelp-tools/yelp-tools-40.0.ebuild
+++ b/app-text/yelp-tools/yelp-tools-40.0.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-
-inherit gnome2 meson
+PYTHON_COMPAT=( python3_{7..9} )
+inherit gnome2 meson python-single-r1
DESCRIPTION="Collection of tools for building and converting documentation"
HOMEPAGE="https://wiki.gnome.org/Apps/Yelp/Tools"
@@ -11,8 +11,10 @@ HOMEPAGE="https://wiki.gnome.org/Apps/Yelp/Tools"
LICENSE="|| ( GPL-2+ freedist ) GPL-2+" # yelp.m4 is GPL2 || freely distributable
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
+ ${PYTHON_DEPS}
>=dev-libs/libxml2-2.6.12
>=dev-libs/libxslt-1.1.8
dev-util/itstool
@@ -22,3 +24,12 @@ DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${ED}"/usr/bin/yelp-{build,check,new}
+}