summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/ibus-table/ibus-table-1.5.0-r1.ebuild')
-rw-r--r--app-i18n/ibus-table/ibus-table-1.5.0-r1.ebuild35
1 files changed, 18 insertions, 17 deletions
diff --git a/app-i18n/ibus-table/ibus-table-1.5.0-r1.ebuild b/app-i18n/ibus-table/ibus-table-1.5.0-r1.ebuild
index 117770e0b80a..6d8c14c9848c 100644
--- a/app-i18n/ibus-table/ibus-table-1.5.0-r1.ebuild
+++ b/app-i18n/ibus-table/ibus-table-1.5.0-r1.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI="6"
PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite"
-inherit eutils python-single-r1
+PYTHON_REQ_USE="sqlite(+)"
-DESCRIPTION="The Table Engine for IBus Framework"
+inherit python-single-r1
+
+DESCRIPTION="Tables engines for IBus"
HOMEPAGE="https://github.com/ibus/ibus/wiki"
SRC_URI="https://ibus.googlecode.com/files/${P}.tar.gz"
@@ -14,28 +15,28 @@ LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
- >=app-i18n/ibus-1.2[python,${PYTHON_USEDEP}]
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ virtual/libiconv
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
- nls? ( >=sys-devel/gettext-0.16.1 )
- virtual/pkgconfig"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
src_prepare() {
python_fix_shebang .
- sed -i -e "s/python/${EPYTHON}/" \
- engine/ibus-table-createdb.in engine/ibus-engine-table.in || die
+ sed -i \
+ "s/python/${EPYTHON}/" \
+ engine/ibus-table-createdb.in \
+ engine/ibus-engine-table.in
+
+ default
}
src_configure() {
econf $(use_enable nls)
}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc AUTHORS ChangeLog NEWS README
-}