summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lua/lutok/lutok-0.4-r10.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-lua/lutok/lutok-0.4-r10.ebuild b/dev-lua/lutok/lutok-0.4-r10.ebuild
index a88f7f0ef0ca..378ed963caf4 100644
--- a/dev-lua/lutok/lutok-0.4-r10.ebuild
+++ b/dev-lua/lutok/lutok-0.4-r10.ebuild
@@ -33,9 +33,13 @@ pkg_setup() {
src_configure() {
lua_setup
- lua_get_CFLAGS >/dev/null
- lua_get_LIBS >/dev/null
- econf --enable-shared --disable-static
+ local myconf=(
+ --enable-shared
+ --disable-static
+ LUA_CFLAGS="$(lua_get_CFLAGS)"
+ LUA_LIBS="$(lua_get_LIBS)"
+ )
+ econf "${myconf[@]}"
}
src_install() {