summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-physics/geant4_vmc/Manifest2
-rw-r--r--sci-physics/geant4_vmc/geant4_vmc-6.1_p3.ebuild80
-rw-r--r--sci-physics/geant4_vmc/geant4_vmc-6.2.ebuild79
-rw-r--r--sci-physics/geant4_vmc/geant4_vmc-9999.ebuild12
4 files changed, 167 insertions, 6 deletions
diff --git a/sci-physics/geant4_vmc/Manifest b/sci-physics/geant4_vmc/Manifest
index b0c2f3acdede..4678b54e61dd 100644
--- a/sci-physics/geant4_vmc/Manifest
+++ b/sci-physics/geant4_vmc/Manifest
@@ -2,3 +2,5 @@ DIST geant4_vmc-5.4.tar.gz 7363185 BLAKE2B 3f1738a6d99d7cad1df1249a086b5257ff1d9
DIST geant4_vmc-6.0.tar.gz 5649857 BLAKE2B 905ee76a579e25ee6259aafe978b0f202313ae6ce7f62e424c663e5a22f3c77e9a2eb3a4d807515267087c9e95aebb962927728da8110248136d69bcb8b1fc56 SHA512 ee21ec2d493d4ef227b294818ca0e6940c437e069197009f4bfab0fa1c282b4ad0dc5744157077ccb3b8953c4a167492571a56f68def2152730bcb79892f56fc
DIST geant4_vmc-6.1.tar.gz 5604048 BLAKE2B 74d8e7fd20f9abd0205ccb3913180380b8862fef604b563ffde036a27f387887e1bf9ddf1c33fcb530e328c0dc5db42c51eac16097d94861326ec1a4c4ad3eed SHA512 6a9fd1c2b74e57ca5552c2bdb02a568916568da662eba29947f746c27c07a779e69b24315afd9cb9e8eda83b14eb53d351f3494cbe6fefb951eaf85888b0b1be
DIST geant4_vmc-6.1_p2.tar.gz 5606450 BLAKE2B 943398e4cf9a8f4d6e44687f89eff6e6f09e4904b8a57684e202719162d861d5b370c1fc9bcf40de43aa607cfa89db1d1a740046a1ad9744ba2c538dbc8103f8 SHA512 97f825a32958d7da8d4086e87397c358b0331ac8f6630b83c1a8142f02be21093bed65c0841a24c0db5548adb611f52f2c5e05e92f39a67f13c70d76f901d47e
+DIST geant4_vmc-6.1_p3.tar.gz 5605174 BLAKE2B 80d7936534d4102b545a4285b8ddba4eb7c9ec31b1343194da922a6c79730c1f779cc9719b1d2e5b4bcf02a681c371157057d727c5fa86633e6c7497d64206e0 SHA512 ccb568c2ce004300c7c6ad908aa8d97319f3c0d4add0da3ace418231906cf91ef9f73b5c774fbadd6e4473dcc1b49071023d7fa159b5864f03b28dae407074c6
+DIST geant4_vmc-6.2.tar.gz 5743487 BLAKE2B 062fece07714f255eddd13c6bda660ea6737772fe7a43413df07c9ed221c0f80a872fe72614e5e4ad18396c72aae2c2000cdf6e3b1c2436f9419933ac32704bb SHA512 72651ab5261a398feb6f37271a41a5770334a20dc61be2046b19ca8ff4780cf7649136314e4a8597023d14782996d7ee0d047579b33a983c4dea9c21b32b4551
diff --git a/sci-physics/geant4_vmc/geant4_vmc-6.1_p3.ebuild b/sci-physics/geant4_vmc/geant4_vmc-6.1_p3.ebuild
new file mode 100644
index 000000000000..d345df0c65eb
--- /dev/null
+++ b/sci-physics/geant4_vmc/geant4_vmc-6.1_p3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake virtualx
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vmc-project/${PN}.git"
+else
+ MY_PV=$(ver_rs 1-2 -)
+ SRC_URI="https://github.com/vmc-project/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Virtual Monte Carlo Geant4 implementation"
+HOMEPAGE="https://github.com/vmc-project/geant4_vmc"
+
+LICENSE="GPL-3"
+SLOT="4"
+IUSE="doc examples geant3 +g4root vgm test"
+
+RDEPEND="
+ >=sci-physics/geant-4.11[c++17,opengl,geant3?]
+ sci-physics/root:=[c++17,-vmc(-)]
+ >=sci-physics/vmc-2.0:=[c++17]
+ vgm? ( <=sci-physics/vgm-5.0:= )"
+DEPEND="${RDEPEND}
+ test? ( >=sci-physics/geant-4.11[gdml] )"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
+RESTRICT="
+ !examples? ( test )
+ !geant3? ( test )
+ !g4root? ( test )
+ !test? ( test )
+ !vgm? ( test )"
+
+DOCS=(history README.md)
+
+src_configure() {
+ local mycmakeargs=(
+ -DGeant4VMC_USE_VGM="$(usex vgm)"
+ -DGeant4VMC_USE_GEANT4_G3TOG4="$(usex geant3)"
+ -DGeant4VMC_USE_G4Root="$(usex g4root)"
+ -DGeant4VMC_BUILD_EXAMPLES="$(usex test)"
+ -DGeant4VMC_INSTALL_EXAMPLES="$(usex examples)"
+ -DGeant4VMC_BUILD_G4Root_TEST="$(usex test)"
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc ; then
+ local dirs=(
+ source
+ $(usev g4root)
+ $(usev examples)
+ )
+ local d
+ for d in "${dirs[@]}"; do
+ doxygen "${d}"/Doxyfile || die
+ done
+ fi
+}
+
+src_test() {
+ export QT_DEBUG_PLUGINS=1
+ cd examples || die
+ virtx ./test_suite.sh --debug --g3=off --garfield=off --builddir="${BUILD_DIR}" || die
+ virtx ./test_suite_exe.sh --g3=off --garfield=off --garfield=off --builddir="${BUILD_DIR}" || die
+}
+
+src_install() {
+ cmake_src_install
+ use doc && local HTML_DOCS=(doc/.)
+ einstalldocs
+}
diff --git a/sci-physics/geant4_vmc/geant4_vmc-6.2.ebuild b/sci-physics/geant4_vmc/geant4_vmc-6.2.ebuild
new file mode 100644
index 000000000000..b379508aa225
--- /dev/null
+++ b/sci-physics/geant4_vmc/geant4_vmc-6.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake virtualx
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vmc-project/${PN}.git"
+else
+ MY_PV=$(ver_rs 1-2 -)
+ SRC_URI="https://github.com/vmc-project/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Virtual Monte Carlo Geant4 implementation"
+HOMEPAGE="https://github.com/vmc-project/geant4_vmc"
+
+LICENSE="GPL-3"
+SLOT="4"
+IUSE="doc examples geant3 +g4root vgm test"
+
+RDEPEND="
+ >=sci-physics/geant-4.11.1:=[c++17,opengl,geant3?]
+ sci-physics/root:=[c++17,-vmc(-)]
+ >=sci-physics/vmc-2.0:=[c++17]
+ vgm? ( >=sci-physics/vgm-5.1:= )"
+DEPEND="${RDEPEND}
+ test? ( >=sci-physics/geant-4.11.1:=[gdml] )"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
+RESTRICT="
+ !examples? ( test )
+ !geant3? ( test )
+ !g4root? ( test )
+ !test? ( test )
+ !vgm? ( test )"
+
+DOCS=(history README.md)
+
+src_configure() {
+ local mycmakeargs=(
+ -DGeant4VMC_USE_VGM="$(usex vgm)"
+ -DGeant4VMC_USE_GEANT4_G3TOG4="$(usex geant3)"
+ -DGeant4VMC_USE_G4Root="$(usex g4root)"
+ -DGeant4VMC_BUILD_EXAMPLES="$(usex test)"
+ -DGeant4VMC_INSTALL_EXAMPLES="$(usex examples)"
+ -DGeant4VMC_BUILD_G4Root_TEST="$(usex test)"
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc ; then
+ local dirs=(
+ source
+ $(usev g4root)
+ $(usev examples)
+ )
+ local d
+ for d in "${dirs[@]}"; do
+ doxygen "${d}"/Doxyfile || die
+ done
+ fi
+}
+
+src_test() {
+ cd examples || die
+ virtx ./test_suite.sh --debug --g3=off --garfield=off --builddir="${BUILD_DIR}" || die
+ virtx ./test_suite_exe.sh --g3=off --garfield=off --garfield=off --builddir="${BUILD_DIR}" || die
+}
+
+src_install() {
+ cmake_src_install
+ use doc && local HTML_DOCS=(doc/.)
+ einstalldocs
+}
diff --git a/sci-physics/geant4_vmc/geant4_vmc-9999.ebuild b/sci-physics/geant4_vmc/geant4_vmc-9999.ebuild
index 2bc5b7595a6d..988ae63d16b7 100644
--- a/sci-physics/geant4_vmc/geant4_vmc-9999.ebuild
+++ b/sci-physics/geant4_vmc/geant4_vmc-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake
+inherit cmake virtualx
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -23,12 +23,12 @@ SLOT="4"
IUSE="doc examples geant3 +g4root vgm test"
RDEPEND="
- sci-physics/geant[c++17,opengl,geant3?]
+ sci-physics/geant:=[c++17,opengl,geant3?]
sci-physics/root:=[c++17,-vmc(-)]
sci-physics/vmc:=[c++17]
vgm? ( sci-physics/vgm:= )"
DEPEND="${RDEPEND}
- test? ( >=sci-physics/geant-4.11[gdml] )"
+ test? ( sci-physics/geant:=[gdml] )"
BDEPEND="doc? ( app-doc/doxygen[dot] )"
RESTRICT="
!examples? ( test )
@@ -68,8 +68,8 @@ src_compile() {
src_test() {
cd examples || die
- ./test_suite.sh --debug --g3=off --garfield=off --builddir="${BUILD_DIR}" || die
- ./test_suite_exe.sh --g3=off --garfield=off --garfield=off --builddir="${BUILD_DIR}" || die
+ virtx ./test_suite.sh --debug --g3=off --garfield=off --builddir="${BUILD_DIR}" || die
+ virtx ./test_suite_exe.sh --g3=off --garfield=off --garfield=off --builddir="${BUILD_DIR}" || die
}
src_install() {