summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorThuna <thuna.cing@gmail.com>2022-11-13 01:30:21 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-11-25 14:37:55 +0200
commitc3677641f0c65243ad0076fb4e4b06dac5ac1733 (patch)
tree55719c3162b055bf6ed9281aa470a8652caffa7c /x11-wm
parentapp-crypt/heimdal: Stabilize 7.7.1 sparc, #881439 (diff)
downloadgentoo-c3677641f0c65243ad0076fb4e4b06dac5ac1733.tar.gz
gentoo-c3677641f0c65243ad0076fb4e4b06dac5ac1733.tar.bz2
gentoo-c3677641f0c65243ad0076fb4e4b06dac5ac1733.zip
x11-wm/stumpwm: Add version 22.05
Signed-off-by: Umut Tuna Akgül <thuna.cing@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/28249 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/stumpwm/Manifest1
-rw-r--r--x11-wm/stumpwm/stumpwm-22.05.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/x11-wm/stumpwm/Manifest b/x11-wm/stumpwm/Manifest
index 2daac8ab8df2..b126401aa65c 100644
--- a/x11-wm/stumpwm/Manifest
+++ b/x11-wm/stumpwm/Manifest
@@ -1 +1,2 @@
DIST stumpwm-18.05.tar.gz 199467 BLAKE2B d532a531b7ceec7a80be66563dc2f36a6f1957d1e0f014ccf61cac1edf23073370dbe7cf3d7004f6dab144a88a4b54360e82ce7b13bdbc40cba59adfcb8e8af1 SHA512 a28c0af3a82670c0f31a5839227301672cc0706c47fb353355f90f791944556fb6125f3fa4d8547e6fbcf4817cdac5b0fe47de2dbae3a304d631a895af6ddb35
+DIST stumpwm-740e945d742d85aef36e0ed9467de9bbbf5eafd2.tar.gz 273172 BLAKE2B 00756081aed915af18af4534414659e29856bc1a98df2cd35b48bb5bf4f06fe2dc76c4016cbc39e296ff19d51b3e959ef84dbc57972da0a634bc6cb3ca0b881e SHA512 313f430da8ecb7919940b37f2353969c8bf3a3be6a1d380e1655a7a6aebb83a3890cbd99a292a414f71f934adcae1350c24650fe5d5d35cf30788ff392feaac0
diff --git a/x11-wm/stumpwm/stumpwm-22.05.ebuild b/x11-wm/stumpwm/stumpwm-22.05.ebuild
new file mode 100644
index 000000000000..5efbf724926a
--- /dev/null
+++ b/x11-wm/stumpwm/stumpwm-22.05.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit common-lisp-3 autotools desktop elisp-common xdg-utils
+
+MY_COMMIT="740e945d742d85aef36e0ed9467de9bbbf5eafd2"
+
+DESCRIPTION="A Window Manager written entirely in Common Lisp"
+HOMEPAGE="https://stumpwm.github.io/"
+SRC_URI="https://github.com/stumpwm/stumpwm/archive/${MY_COMMIT}.tar.gz -> ${PN}-${MY_COMMIT}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="contrib doc emacs"
+
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+RESTRICT="strip"
+
+RDEPEND="dev-lisp/alexandria
+ dev-lisp/cl-ppcre
+ dev-lisp/clx
+ >=dev-lisp/sbcl-1.3.0
+ emacs? ( >=app-editors/emacs-23.1:* )"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/texinfo
+ doc? ( virtual/texi2dvi )"
+
+PDEPEND="contrib? ( x11-wm/stumpwm-contrib )"
+
+SITEFILE=70${PN}-gentoo.el
+CLPKGDIR="${CLSOURCEROOT}/${CLPACKAGE}"
+
+install_docs() {
+ local pdffile="${PN}.pdf"
+
+ texi2pdf -o "${pdffile}" "${PN}.texi.in" && dodoc "${pdffile}" || die
+ cp "${FILESDIR}/README.Gentoo" . && sed -i "s:@VERSION@:${PV}:" README.Gentoo || die
+ dodoc AUTHORS NEWS README.md README.Gentoo
+ doinfo "${PN}.info"
+ docinto examples
+ dodoc sample-stumpwmrc.lisp
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ xdg_environment_reset
+ econf --with-lisp=sbcl
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ dobin stumpwm
+ make_session_desktop StumpWM /usr/bin/stumpwm
+
+ common-lisp-install-sources *.lisp
+ common-lisp-install-asdf
+ # Fix ASDF dir
+ sed -i -e "/(:directory/c\ (:directory \"${CLPKGDIR}\")" \
+ "${D}${CLPKGDIR}/load-stumpwm.lisp" || die
+ use doc && install_docs
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}