summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-30 18:42:19 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-30 19:56:25 -0400
commitc4aa12630daea0bd953c234bb2ae49f51939e8b4 (patch)
tree8be2cb18a0f8e2a6d1328acfc55487406e1fd1e6 /x11-base
parentdev-perl/Mail-DKIM: keyworded 1.202.9.070 for ia64 (diff)
downloadgentoo-c4aa12630daea0bd953c234bb2ae49f51939e8b4.tar.gz
gentoo-c4aa12630daea0bd953c234bb2ae49f51939e8b4.tar.bz2
gentoo-c4aa12630daea0bd953c234bb2ae49f51939e8b4.zip
x11-base/xwayland: add 21.1.1.901 unkeyworded for testing
Release candidate that notably allows acceleration for NVIDIA cards. Also added openssl dep for sha1=libcrypto, and fix install on prefix. Acked-by: Matt Turner <mattst88@gentoo.org> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xwayland/Manifest1
-rw-r--r--x11-base/xwayland/xwayland-21.1.1.901.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/x11-base/xwayland/Manifest b/x11-base/xwayland/Manifest
index 2f2adffe714f..f6d26f7621e3 100644
--- a/x11-base/xwayland/Manifest
+++ b/x11-base/xwayland/Manifest
@@ -1 +1,2 @@
+DIST xwayland-21.1.1.901.tar.xz 1258684 BLAKE2B e689f9342bc1e3ccdd0807dc3e47d04e34b9d728698848c155cb489a02002ef8120cad1322db9d6fe955d275fc6c0835bbc76d61d4a2aa26118bb267c16e7717 SHA512 60dec3875e8ea60f8fc53eea0ebcb55c948cf5eeb40b30f6d5e13d8c7b48d0aabd035884ae108fce0b03ca5da592d1b0e395a9c5198c1204e8407ec119d9bbee
DIST xwayland-21.1.1.tar.xz 1257776 BLAKE2B 181aca3d3fad3759eb726c6f6141912d588a85bae214f9d395450b6945ee845d28c7a8580e6aaa5f3538d06083312391d24267e6b239bfc533526a1bd7a56f0a SHA512 0cb03d796af183f9fde14c30ef45d94ef466ac4ba3d85dda34e74f91dd94bb75d0c8a867ecb7bda7ea61d98c70a4f73bc98c5a205ea5f69a0e222cd780d263d8
diff --git a/x11-base/xwayland/xwayland-21.1.1.901.ebuild b/x11-base/xwayland/xwayland-21.1.1.901.ebuild
new file mode 100644
index 000000000000..2727dab21fa4
--- /dev/null
+++ b/x11-base/xwayland/xwayland-21.1.1.901.ebuild
@@ -0,0 +1,89 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Standalone X server running under Wayland"
+HOMEPAGE="https://wayland.freedesktop.org/xserver.html"
+SRC_URI="https://xorg.freedesktop.org/archive/individual/xserver/${P}.tar.xz"
+
+IUSE="rpc unwind ipv6 xcsecurity selinux video_cards_nvidia"
+
+LICENSE="MIT"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND="
+ >=x11-libs/pixman-0.27.2
+ dev-libs/libbsd
+ >=x11-libs/libXfont2-2.0.1
+ dev-libs/openssl:=
+ dev-libs/wayland
+ video_cards_nvidia? ( gui-libs/egl-wayland )
+ >=x11-libs/libXdmcp-1.0.2
+ >=x11-libs/libdrm-2.4.89
+ >=media-libs/libepoxy-1.5.4[X,egl(+)]
+ >=media-libs/mesa-18[X(+),egl,gbm]
+ >=x11-libs/libxshmfence-1.1
+ rpc? ( net-libs/libtirpc )
+ >=x11-libs/libXau-1.0.4
+ media-libs/libglvnd[X]
+ unwind? ( sys-libs/libunwind )
+ >=dev-libs/wayland-protocols-1.18
+ media-fonts/font-util
+ x11-libs/libxkbfile
+ >=x11-libs/xtrans-1.3.5
+ x11-base/xorg-proto
+"
+
+DEPEND="
+ ${CDEPEND}
+ !<=x11-base/xorg-server-1.20.11
+"
+
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-xserver )
+"
+BDEPEND="
+ sys-devel/flex
+ dev-util/wayland-scanner
+"
+
+PATCHES=(
+ "${FILESDIR}"/xwayland-drop-redundantly-installed-files.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use rpc secure-rpc)
+ $(meson_use unwind libunwind)
+ $(meson_use ipv6)
+ $(meson_use xcsecurity)
+ $(meson_use selinux xselinux)
+ $(meson_use video_cards_nvidia xwayland_eglstream)
+ -Dsha1=libcrypto
+ -Ddpms=true
+ -Ddri3=true
+ -Dglamor=true
+ -Dglx=true
+ -Dscreensaver=true
+ -Dxace=true
+ -Dxdmcp=true
+ -Dxinerama=true
+ -Dxv=true
+ -Dxvfb=true
+ -Dxwayland-path="${EPREFIX}"/usr/libexec
+ -Ddtrace=false
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ dosym ../libexec/Xwayland /usr/bin/Xwayland
+
+ meson_src_install
+}