summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2019-12-30 22:53:26 +0100
committerPiotr Karbowski <slashbeast@gentoo.org>2019-12-30 22:54:09 +0100
commit536f9fbfad303a2afd648c30ea5c43285795833b (patch)
tree9d4a134db16b54f4b30ddf8cbe7231a04cf00c9d /www-servers/gunicorn
parentdev-python/yarl-1.3.0: python 3.8 support added. (diff)
downloadgentoo-536f9fbfad303a2afd648c30ea5c43285795833b.tar.gz
gentoo-536f9fbfad303a2afd648c30ea5c43285795833b.tar.bz2
gentoo-536f9fbfad303a2afd648c30ea5c43285795833b.zip
www-servers/gunicorn-19.9.0: py38 support added; relaxed sphinx dep.
The sphinx dependency has been relaxed to not force sphinx to be installed with the same PYTHON_TARGETS as the gunicorn itself. No revbump as the end result with USE=doc is the same as it was before. Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'www-servers/gunicorn')
-rw-r--r--www-servers/gunicorn/gunicorn-19.9.0.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/www-servers/gunicorn/gunicorn-19.9.0.ebuild b/www-servers/gunicorn/gunicorn-19.9.0.ebuild
index c98e3a00bb6f..d79648682864 100644
--- a/www-servers/gunicorn/gunicorn-19.9.0.ebuild
+++ b/www-servers/gunicorn/gunicorn-19.9.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy )
inherit distutils-r1
@@ -13,13 +13,12 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT PSF-2 doc? ( BSD )"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="doc test"
+IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
@@ -29,22 +28,14 @@ DEPEND="
DOCS="README.rst"
-python_prepare_all() {
- sed -ie "s/..\/bin/\/usr\/bin\//" docs/Makefile || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
+distutils_enable_sphinx 'docs/source' --no-autodoc
python_test() {
py.test -v || die "Testing failed with ${EPYTHON}"
}
python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
+ use doc && local HTML_DOCS=( docs/source/_build/html/. )
distutils-r1_python_install_all
}