summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-04-08 21:49:12 -0400
committerMatt Turner <mattst88@gentoo.org>2023-04-08 22:10:20 -0400
commit1cba0e8028af3f310ce88fd5bb4fa8560431e1af (patch)
tree6e31539903d3423aab1d3849ef2e83a9dd12784a /www-plugins
parentx11-terms/aterm: Drop old versions (diff)
downloadgentoo-1cba0e8028af3f310ce88fd5bb4fa8560431e1af.tar.gz
gentoo-1cba0e8028af3f310ce88fd5bb4fa8560431e1af.tar.bz2
gentoo-1cba0e8028af3f310ce88fd5bb4fa8560431e1af.zip
www-plugins/browserpass: Version bump to 3.1.0
Also add Vivaldi support (bug #854312) Closes: https://bugs.gentoo.org/854312 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/browserpass/Manifest2
-rw-r--r--www-plugins/browserpass/browserpass-3.1.0.ebuild46
-rw-r--r--www-plugins/browserpass/metadata.xml3
3 files changed, 51 insertions, 0 deletions
diff --git a/www-plugins/browserpass/Manifest b/www-plugins/browserpass/Manifest
index 38c9c90bccd7..95ae7a054f40 100644
--- a/www-plugins/browserpass/Manifest
+++ b/www-plugins/browserpass/Manifest
@@ -1,2 +1,4 @@
DIST browserpass-3.0.10-deps.tar.xz 2508704 BLAKE2B 893aa8116bf6d021a9a8ca2b2fd7bcdc4686e8d3060a42255f702881b65c4cf20971e4c69b2f92520b9ad73439ffb92b73bc1013947a317840e4bdf090ea6439 SHA512 44e48d60e9656ef7b4ad74aebb9d2aa38ad42c77873143f857a1908daa81089544ef1b9cbc367e2566c910243e869a17203a8ecddd06650ff63c830defdf8244
DIST browserpass-3.0.10.tar.gz 19242 BLAKE2B 822fb82b30b3f0faab5aad40af534f94b12636b476c9f704d8e1bd874e4dde2b2f4645553a43fcc79741aa06e30eac48bd26af8d6f868db0901330ecfaee6d35 SHA512 c8be34d3b0bd53f0d14f620826a223df44847ec7a2d6ee9fd9af776e640157bac2064a5eb21116942701d97e385f1d0bbf2c705a043e03ca62448db872c97c38
+DIST browserpass-3.1.0-deps.tar.xz 2416968 BLAKE2B e591c9dac93efea35daeeac6935319b6e6e1e5145a5eaeea1cec1252b24c6c036f54f11e552400a146e883c6f7efcaa3b1dd2fca023a84b632be8facfc253644 SHA512 27cdac3d42009cad45f58b3501eeeaca0daa921c071a675c11048951a0843656225f35772e3101a9149275afafa6567989072df4de20a0c49e2c693b41554131
+DIST browserpass-3.1.0.tar.gz 21835 BLAKE2B a6551f25681a2895a26654e2cc54451b3a08c6ab4cc5376e01fe1273f0866ebe44dec04de5ac113a1902b153884b3b7693a2675c8188d31360e83e860966fadf SHA512 ca5b1c7b805e66e1ccea7c0a69b26ccceb307ae4707b7b284e79169d810e79c118ac174d893b589ca82051cddd08ae0e047dc339960c2faf261075cdaef25a3f
diff --git a/www-plugins/browserpass/browserpass-3.1.0.ebuild b/www-plugins/browserpass/browserpass-3.1.0.ebuild
new file mode 100644
index 000000000000..73f25aad2cbd
--- /dev/null
+++ b/www-plugins/browserpass/browserpass-3.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+MY_PN=browserpass-native
+
+DESCRIPTION="WebExtension host binary for app-admin/pass, a UNIX password manager"
+HOMEPAGE="https://github.com/browserpass/browserpass-native"
+
+SRC_URI="https://github.com/browserpass/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~mattst88/distfiles/${P}-deps.tar.xz"
+
+LICENSE="BSD ISC MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+RDEPEND="app-crypt/gnupg"
+
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+src_compile() {
+ ego build || die
+
+ sed -e "s|%%replace%%|${EPREFIX}/usr/libexec/browserpass-native|" \
+ -i browser-files/firefox-host.json browser-files/chromium-host.json || die
+}
+
+src_install() {
+ exeinto /usr/libexec
+ doexe browserpass-native
+
+ insinto /usr/lib/mozilla/native-messaging-hosts
+ newins browser-files/firefox-host.json com.github.browserpass.native.json
+
+ insinto /usr/lib64/mozilla/native-messaging-hosts
+ newins browser-files/firefox-host.json com.github.browserpass.native.json
+
+ insinto /etc/chromium/native-messaging-hosts
+ newins browser-files/chromium-host.json com.github.browserpass.native.json
+
+ insinto /etc/opt/chrome/native-messaging-hosts
+ newins browser-files/chromium-host.json com.github.browserpass.native.json
+
+ insinto /etc/opt/vivaldi/native-messaging-hosts
+ newins browser-files/chromium-host.json com.github.browserpass.native.json
+}
diff --git a/www-plugins/browserpass/metadata.xml b/www-plugins/browserpass/metadata.xml
index 1c6906f8795a..0b73582b85e0 100644
--- a/www-plugins/browserpass/metadata.xml
+++ b/www-plugins/browserpass/metadata.xml
@@ -5,4 +5,7 @@
<email>mattst88@gentoo.org</email>
<name>Matt Turner</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">browserpass/browserpass-native</remote-id>
+ </upstream>
</pkgmetadata>