summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPedro Arizmendi <dwosky@pm.me>2022-11-07 15:39:32 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-11-22 15:26:03 +0200
commitff06f996918b56f8f887578d2fbe0b6ae15088b8 (patch)
treece51a0c861f93ce75a138fce202cb30b98acd05b /www-misc
parentdev-lang/eisl: drop old 2.60 (diff)
downloadgentoo-ff06f996918b56f8f887578d2fbe0b6ae15088b8.tar.gz
gentoo-ff06f996918b56f8f887578d2fbe0b6ae15088b8.tar.bz2
gentoo-ff06f996918b56f8f887578d2fbe0b6ae15088b8.zip
www-misc/monitorix: Added packages and dependencies needed.
Added possible packages and dependencies needed for some configuration options. Closes: https://bugs.gentoo.org/844190 Signed-off-by: Pedro Arizmendi <dwosky@pm.me> Closes: https://github.com/gentoo/gentoo/pull/28166 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/monitorix/monitorix-3.14.0-r1.ebuild (renamed from www-misc/monitorix/monitorix-3.14.0.ebuild)26
1 files changed, 26 insertions, 0 deletions
diff --git a/www-misc/monitorix/monitorix-3.14.0.ebuild b/www-misc/monitorix/monitorix-3.14.0-r1.ebuild
index 7c5126a6c23a..4eebff098c97 100644
--- a/www-misc/monitorix/monitorix-3.14.0.ebuild
+++ b/www-misc/monitorix/monitorix-3.14.0-r1.ebuild
@@ -79,11 +79,37 @@ src_install() {
}
pkg_postinst() {
+ optfeature_header "Optional package dependencies for certain graphs:"
optfeature "disk drive temperatures and health" app-admin/hddtemp
optfeature "email reports/statics" mail-mta/postfix mail-mta/sendmail
optfeature "lm-sensors and GPU temperatures" sys-apps/lm-sensors
+ optfeature "ZFS statistics" sys-fs/zfs
+ optfeature "Tinyproxy statistics" "net-proxy/tinyproxy dev-perl/XML-LibXML"
+ optfeature "Libvirt statistics" app-emulation/libvirt
+ optfeature "System services demand" mail-filter/MailScanner mail-filter/amavisd-new
+ optfeature "Mail statistics" mail-filter/MailScanner mail-filter/amavisd-new
+ optfeature "FTP statistics" net-ftp/proftpd net-ftp/vsftpd net-ftp/pure-ftpd
+ optfeature "Apache statistics" www-servers/apache
+ optfeature "Nginx statistics" www-servers/nginx
+ optfeature "Lighttpd statistics" www-servers/lighttpd
+ optfeature "MySQL statistics" dev-db/mysql
+ optfeature "PostgreSQL statistics" dev-db/postgresql
+ optfeature "MongoDB statistics" dev-db/mongodb
+ optfeature "Varnish cache statistics" www-servers/varnish
+ optfeature "Squid Proxy Web Cache" net-proxy/squid
+ optfeature "NFS client/server statistics" net-fs/nfs-utils
+ optfeature "BIND statistics" "net-dns/bind dev-perl/XML-LibXML"
+ optfeature "Unbound statistics" net-dns/unbound
+ optfeature "NTP statistics" net-misc/ntp
+ optfeature "Chrony statistics" net-misc/chrony
+ optfeature "Fail2ban statistics" net-analyzer/fail2ban
+ optfeature "Icecast Streaming Media Server" net-misc/icecast
+ optfeature "Memcached statistics" net-misc/memcached
+ optfeature "Redis statistics" dev-db/redis
optfeature "APC UPS statistics" sys-power/apcupsd
optfeature "Network UPS Tools statistics" sys-power/nut
+ optfeature "Monitoring the Internet traffic of your LAN" "net-firewall/iptables dev-perl/Net-IP"
+
elog
elog "If you wish to use your own web server:"
elog " Web data can be found at: ${EROOT}/var/lib/${PN}/www/"