summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2024-07-28 11:33:50 -0700
committerJohn Helmert III <ajak@gentoo.org>2024-07-28 11:42:39 -0700
commitc10f53a20d94080d544166ad6ec25c666dee6a46 (patch)
treeaac1c84eb37e22136755a0a2479dc534735e560a /www-misc
parentnet-analyzer/boreas: set missing RDEPEND (diff)
downloadgentoo-c10f53a20d94080d544166ad6ec25c666dee6a46.tar.gz
gentoo-c10f53a20d94080d544166ad6ec25c666dee6a46.tar.bz2
gentoo-c10f53a20d94080d544166ad6ec25c666dee6a46.zip
www-misc/buku: drop 4.8
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/buku/Manifest1
-rw-r--r--www-misc/buku/buku-4.8.ebuild91
2 files changed, 0 insertions, 92 deletions
diff --git a/www-misc/buku/Manifest b/www-misc/buku/Manifest
index 0d0153569be1..3783191f5ade 100644
--- a/www-misc/buku/Manifest
+++ b/www-misc/buku/Manifest
@@ -1,2 +1 @@
-DIST buku-4.8.tar.gz 591883 BLAKE2B 459ff04a414d3f320a76e8d7792a977f40b030597b846cff34abc862f062956dcfe477d01606744b13e8afe1c6d48f73848816488094f4941b4723a5cd4fedb6 SHA512 a87311adbd72ed614e870c24ecf890633672a6dab12d18f40017177049b2aaebbc66776740f893248b99f2f79d85b6d7b9e57c1fd1bbf6c95963ca57649dc2bf
DIST buku-4.9.tar.gz 615794 BLAKE2B 79e0b7980d1df2b063be5b115c6d55fce63b9e9a58bae5c1ae4d81d77b644c90df2698e20a1743daf5468f4b08ab7b2125af073906385693419249b989686f3f SHA512 3804ea759c3b0172ab07b266123b27683f4785f1fb10859b4fd5b41e267b93e6ad0901b2456a27e434aef216f2063c5881d2755ec45789b3f2d42fe608b32eb2
diff --git a/www-misc/buku/buku-4.8.ebuild b/www-misc/buku/buku-4.8.ebuild
deleted file mode 100644
index a54c84ebd83a..000000000000
--- a/www-misc/buku/buku-4.8.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9,10,11} )
-PYTHON_REQ_USE="sqlite"
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Powerful command-line bookmark manager"
-HOMEPAGE="https://github.com/jarun/buku"
-SRC_URI="https://github.com/jarun/${PN}/archive/v$(ver_cut 1-2).tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/beautifulsoup4-4.6.0[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- >=dev-python/html5lib-1.0.1[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? (
- dev-python/attrs[${PYTHON_USEDEP}]
- >=dev-python/click-7.0[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- >=dev-python/py-1.5.0[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-4.2[${PYTHON_USEDEP}]
- >=dev-python/vcrpy-4.0.2[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- # Remove support for bukuserver - complex depgraph which isn't all
- # sufficiently packaged in Gentoo
- sed -ie '/console_scripts/s/,.*/]/' setup.py || die
- sed -ie 's/.*bukuserver.*//' tests/test_views.py || die
- sed -ie 's/.*flask.*//' tests/test_views.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /usr/share/zsh/site-functions
- doins auto-completion/zsh/_*
-
- newbashcomp auto-completion/bash/buku-completion.bash "${PN}"
-
- doman buku.1
-}
-
-python_test() {
- local skipped_tests=(
- # Disable tests related to bukuserver
- tests/test_setup.py::test_bukuserver_requirement
- tests/test_views.py::test_bmv_create_form
- tests/test_views.py::test_bookmark_model_view
- tests/test_views.py::test_load_firefox_database
- tests/test_views.py::test_tag_model_view_get_list
- tests/test_views.py::test_tag_model_view_get_list_empty_db
-
- # Broken with network-sandbox
- tests/test_buku.py::test_network_handler_with_url
- tests/test_bukuDb.py::TestBukuDb::test_tnyfy_url
- tests/test_bukuDb.py::test_add_rec_exec_arg
- tests/test_bukuDb.py::test_load_firefox
- tests/test_bukuDb.py::test_print_db
- tests/test_bukuDb.py::test_print_rec
- tests/test_bukuDb.py::test_refreshdb
-
- # Hard to debug sandbox issue - these pass when run outside portage
- # There also appears to be some state issue between these, because
- # skipping one can result in a later one failing.
- tests/test_bukuDb.py::test_delete_rec_index_and_delay_commit[1-True-False]
- tests/test_bukuDb.py::test_delete_rec_index_and_delay_commit[1-False-True]
- tests/test_bukuDb.py::test_delete_rec_index_and_delay_commit[1-False-False]
- tests/test_bukuDb.py::test_delete_rec_index_and_delay_commit[1-True-True]
- )
-
- # tests/test_server.py is bukuserver tests, ignore it
- pytest -p no:verbose-parametrize -v --ignore tests/test_server.py ${skipped_tests[@]/#/--deselect } || die "Tests failed with ${EPYTHON}"
-}