summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-10-08 23:06:26 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-10-08 23:13:55 +0200
commit97644d196d7bd5dba9ab1526df934648b281750d (patch)
tree9ca34d4a744dc847829ceb9f9137452c2d048df3 /www-client
parentapp-text/pelican: non-maintainer bump to 4.1.2 (diff)
downloadgentoo-97644d196d7bd5dba9ab1526df934648b281750d.tar.gz
gentoo-97644d196d7bd5dba9ab1526df934648b281750d.tar.bz2
gentoo-97644d196d7bd5dba9ab1526df934648b281750d.zip
www-client/firefox: force at least MAKEOPTS=-j2
Bug: https://bugs.gentoo.org/687028 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/firefox-60.9.0.ebuild9
-rw-r--r--www-client/firefox/firefox-68.1.0.ebuild8
-rw-r--r--www-client/firefox/firefox-69.0.2.ebuild8
3 files changed, 22 insertions, 3 deletions
diff --git a/www-client/firefox/firefox-60.9.0.ebuild b/www-client/firefox/firefox-60.9.0.ebuild
index dbac97b227d2..92a177f882da 100644
--- a/www-client/firefox/firefox-60.9.0.ebuild
+++ b/www-client/firefox/firefox-60.9.0.ebuild
@@ -37,7 +37,8 @@ MOZCONFIG_OPTIONAL_WIFI=1
LLVM_MAX_SLOT=9
inherit check-reqs flag-o-matic toolchain-funcs eutils gnome2-utils llvm \
- mozconfig-v6.60 pax-utils xdg-utils autotools mozlinguas-v2
+ mozconfig-v6.60 pax-utils xdg-utils autotools mozlinguas-v2 \
+ multiprocessing
DESCRIPTION="Firefox Web Browser"
HOMEPAGE="https://www.mozilla.com/firefox"
@@ -185,6 +186,12 @@ src_prepare() {
# Allow user to apply any additional patches without modifing ebuild
eapply_user
+ local n_jobs=$(makeopts_jobs)
+ if [[ ${n_jobs} == 1 ]]; then
+ einfo "Building with MAKEOPTS=-j1 is known to fail (bug #687028); Forcing MAKEOPTS=-j2 ..."
+ export MAKEOPTS=-j2
+ fi
+
# Autotools configure is now called old-configure.in
# This works because there is still a configure.in that happens to be for the
# shell wrapper configure script
diff --git a/www-client/firefox/firefox-68.1.0.ebuild b/www-client/firefox/firefox-68.1.0.ebuild
index e392249aee6a..ac1e779e823d 100644
--- a/www-client/firefox/firefox-68.1.0.ebuild
+++ b/www-client/firefox/firefox-68.1.0.ebuild
@@ -42,7 +42,7 @@ LLVM_MAX_SLOT=9
inherit check-reqs eapi7-ver flag-o-matic toolchain-funcs eutils \
gnome2-utils llvm mozcoreconf-v6 pax-utils xdg-utils \
- autotools mozlinguas-v2 virtualx
+ autotools mozlinguas-v2 virtualx multiprocessing
DESCRIPTION="Firefox Web Browser"
HOMEPAGE="https://www.mozilla.com/firefox"
@@ -266,6 +266,12 @@ src_prepare() {
# Allow user to apply any additional patches without modifing ebuild
eapply_user
+ local n_jobs=$(makeopts_jobs)
+ if [[ ${n_jobs} == 1 ]]; then
+ einfo "Building with MAKEOPTS=-j1 is known to fail (bug #687028); Forcing MAKEOPTS=-j2 ..."
+ export MAKEOPTS=-j2
+ fi
+
# Enable gnomebreakpad
if use debug ; then
sed -i -e "s:GNOME_DISABLE_CRASH_DIALOG=1:GNOME_DISABLE_CRASH_DIALOG=0:g" \
diff --git a/www-client/firefox/firefox-69.0.2.ebuild b/www-client/firefox/firefox-69.0.2.ebuild
index b39b1fb4f0b3..4821919cb2eb 100644
--- a/www-client/firefox/firefox-69.0.2.ebuild
+++ b/www-client/firefox/firefox-69.0.2.ebuild
@@ -42,7 +42,7 @@ LLVM_MAX_SLOT=9
inherit check-reqs eapi7-ver flag-o-matic toolchain-funcs eutils \
gnome2-utils llvm mozcoreconf-v6 pax-utils xdg-utils \
- autotools mozlinguas-v2 virtualx
+ autotools mozlinguas-v2 virtualx multiprocessing
DESCRIPTION="Firefox Web Browser"
HOMEPAGE="https://www.mozilla.com/firefox"
@@ -270,6 +270,12 @@ src_prepare() {
# Allow user to apply any additional patches without modifing ebuild
eapply_user
+ local n_jobs=$(makeopts_jobs)
+ if [[ ${n_jobs} == 1 ]]; then
+ einfo "Building with MAKEOPTS=-j1 is known to fail (bug #687028); Forcing MAKEOPTS=-j2 ..."
+ export MAKEOPTS=-j2
+ fi
+
# Enable gnomebreakpad
if use debug ; then
sed -i -e "s:GNOME_DISABLE_CRASH_DIALOG=1:GNOME_DISABLE_CRASH_DIALOG=0:g" \