summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-16 02:11:43 +0100
committerSam James <sam@gentoo.org>2023-06-16 02:11:43 +0100
commit88caec6a38285facc6c7682acd456452cc799333 (patch)
treed0cb4d02226b94c3b472bc8d0fe4cf3bc524b5e6 /sys-libs/zlib-ng
parentsys-process/procs: install completions (diff)
downloadgentoo-88caec6a38285facc6c7682acd456452cc799333.tar.gz
gentoo-88caec6a38285facc6c7682acd456452cc799333.tar.bz2
gentoo-88caec6a38285facc6c7682acd456452cc799333.zip
sys-libs/zlib-ng: add 2.1.2
No VNNI or VPCLMULQDQ yet, see linked bug. Bug: https://bugs.gentoo.org/908556 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/zlib-ng')
-rw-r--r--sys-libs/zlib-ng/Manifest1
-rw-r--r--sys-libs/zlib-ng/files/zlib-ng-2.1.2-cmake.patch35
-rw-r--r--sys-libs/zlib-ng/zlib-ng-2.1.2.ebuild92
3 files changed, 128 insertions, 0 deletions
diff --git a/sys-libs/zlib-ng/Manifest b/sys-libs/zlib-ng/Manifest
index cdd93f9171bb..6a7c819fb8e0 100644
--- a/sys-libs/zlib-ng/Manifest
+++ b/sys-libs/zlib-ng/Manifest
@@ -1 +1,2 @@
DIST zlib-ng-2.0.7.tar.gz 853381 BLAKE2B 89672bd35ee54df72ff995c1b4ed188538011be4cd077e464f21a088b0b70b3f95b4259dc546a65e8d4900dc5bd5bb98041875e361000898b34518f7e008b99b SHA512 1c19a62bb00727ac49049c299fb70060da95b5fafa448144ae4133372ec8c3da15cef6c1303485290f269b23c580696554ca0383dba3e1f9609f65c332981988
+DIST zlib-ng-2.1.2.tar.gz 2404176 BLAKE2B bc0b65520562827b10216110e2020a3341ee0dd853874c19ddb6f9df776fc74a542c1239f77dc3ec2ccb3f92e75f1de7ef104edfecfe37312149b1bc29ae7403 SHA512 2b3073df4eb13d8318f8fa2b7674e4729642488f65dad49d3080ccd830f29e9e3f32a673b42634443ddf9e9ef85cfff4f2f3e182506f950b9ee0a208a92c0465
diff --git a/sys-libs/zlib-ng/files/zlib-ng-2.1.2-cmake.patch b/sys-libs/zlib-ng/files/zlib-ng-2.1.2-cmake.patch
new file mode 100644
index 000000000000..8deb07a60515
--- /dev/null
+++ b/sys-libs/zlib-ng/files/zlib-ng-2.1.2-cmake.patch
@@ -0,0 +1,35 @@
+https://github.com/zlib-ng/zlib-ng/issues/1515
+https://github.com/zlib-ng/zlib-ng/pull/1519
+https://github.com/zlib-ng/zlib-ng/commit/39136c20716a94188c1d041b9656315371d35a47
+
+From 39136c20716a94188c1d041b9656315371d35a47 Mon Sep 17 00:00:00 2001
+From: "Mika T. Lindqvist" <postmaster@raasu.org>
+Date: Sun, 11 Jun 2023 18:38:12 +0300
+Subject: [PATCH] Try to find system copy of googletest before trying to
+ download it. * Don't use system copy if memory sanitizer is enabled
+
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -111,8 +111,6 @@ if(WITH_BENCHMARKS)
+ endif()
+
+ if(WITH_GTEST)
+- include(FetchContent)
+-
+ # Google test requires at least C++11
+ set(CMAKE_CXX_STANDARD 11)
+
+@@ -125,9 +123,13 @@ if(WITH_GTEST)
+ # Must set include and compile options before fetching googletest
+ include_directories($ENV{LLVM_BUILD_DIR}/include $ENV{LLVM_BUILD_DIR}/include/c++/v1)
+ add_compile_options(-stdlib=libc++ -g)
++ elseif(NOT TARGET GTest::GTest)
++ find_package(GTest)
+ endif()
+
+ if(NOT TARGET GTest::GTest)
++ include(FetchContent)
++
+ # Prevent overriding the parent project's compiler/linker settings for Windows
+ set(gtest_force_shared_crt ON CACHE BOOL
+ "Use shared (DLL) run-time lib even when Google Test is built as static lib." FORCE)
diff --git a/sys-libs/zlib-ng/zlib-ng-2.1.2.ebuild b/sys-libs/zlib-ng/zlib-ng-2.1.2.ebuild
new file mode 100644
index 000000000000..f32b71569755
--- /dev/null
+++ b/sys-libs/zlib-ng/zlib-ng-2.1.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Worth keeping an eye on 'develop' branch upstream for possible backports,
+# as they copied this practice from sys-libs/zlib upstream.
+
+inherit cmake
+
+DESCRIPTION="Fork of the zlib data compression library"
+HOMEPAGE="https://github.com/zlib-ng/zlib-ng"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+CPU_USE=(
+ x86_{avx2,avx512f,sse2,ssse3,sse4_2,pclmul}
+ arm_{crc32,neon}
+ ppc_{altivec,vsx2,vsx3}
+)
+IUSE="compat ${CPU_USE[@]/#/cpu_flags_} test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="compat? ( !sys-libs/zlib )"
+
+PATCHES=(
+ "${FILESDIR}"/zlib-ng-2.1.2-cmake.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DZLIB_COMPAT=$(usex compat)
+ -DZLIB_ENABLE_TESTS=$(usex test)
+
+ # Unaligned access is controversial and undefined behaviour
+ # Let's keep it off for now
+ # https://github.com/gentoo/gentoo/pull/17167
+ -DWITH_UNALIGNED=OFF
+ )
+
+ # The intrinsics options are all defined conditionally, so we need
+ # to enable them on/off per-arch here for now.
+ if use amd64 || use x86 ; then
+ mycmakeargs+=(
+ -DWITH_AVX2=$(usex cpu_flags_x86_avx2)
+ -DWITH_AVX512=$(usex cpu_flags_x86_avx512f)
+ -DWITH_AVX512VNNI=OFF # TODO, see bug #908556
+ -DWITH_SSE2=$(usex cpu_flags_x86_sse2)
+ -DWITH_SSSE3=$(usex cpu_flags_x86_ssse3)
+ -DWITH_SSE42=$(usex cpu_flags_x86_sse4_2)
+ -DWITH_PCLMULQDQ=$(usex cpu_flags_x86_pclmul)
+ -DWITH_VPCLMULQDQ=OFF # TODO, see bug #908556
+ )
+ fi
+
+ if use arm || use arm64 ; then
+ mycmakeargs+=(
+ -DWITH_ACLE=$(usex cpu_flags_arm_crc32)
+ -DWITH_NEON=$(usex cpu_flags_arm_neon)
+ )
+ fi
+
+ if use ppc || use ppc64 ; then
+ # The POWER8 support is VSX which was introduced
+ # VSX2 was introduced with POWER8, so use that as a proxy for it
+ mycmakeargs+=(
+ -DWITH_ALTIVEC=$(usex cpu_flags_ppc_altivec)
+ -DWITH_POWER8=$(usex cpu_flags_ppc_vsx2)
+ -DWITH_POWER9=$(usex cpu_flags_ppc_vsx3)
+ )
+ fi
+
+ # TODO: There's no s390x USE_EXPAND yet
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ if use compat ; then
+ ewarn "zlib-ng is experimental and replacing the system zlib is dangerous"
+ ewarn "Please be careful!"
+ ewarn
+ ewarn "The following link explains the guarantees (and what is NOT guaranteed):"
+ ewarn "https://github.com/zlib-ng/zlib-ng/blob/2.0.x/PORTING.md"
+ fi
+}