summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-02-23 15:23:47 +0800
committerJason Zaman <perfinion@gentoo.org>2017-02-23 19:14:23 +0800
commitea01f1ae5c4cdf80bb0b748825661114afa67388 (patch)
treec168ab3d6660b9927e00799bfca56ebe8b1948b7 /sys-libs/libsemanage
parentsys-libs/libselinux: update live ebuild (diff)
downloadgentoo-ea01f1ae5c4cdf80bb0b748825661114afa67388.tar.gz
gentoo-ea01f1ae5c4cdf80bb0b748825661114afa67388.tar.bz2
gentoo-ea01f1ae5c4cdf80bb0b748825661114afa67388.zip
sys-libs/libsemanage: update live ebuild
python libs and include dir are now properly detected so dont need to pass in need to pass the path to libsepol.a Package-Manager: portage-2.3.3
Diffstat (limited to 'sys-libs/libsemanage')
-rw-r--r--sys-libs/libsemanage/files/libsemanage-2.7-build-paths.patch4
-rw-r--r--sys-libs/libsemanage/libsemanage-9999.ebuild12
2 files changed, 9 insertions, 7 deletions
diff --git a/sys-libs/libsemanage/files/libsemanage-2.7-build-paths.patch b/sys-libs/libsemanage/files/libsemanage-2.7-build-paths.patch
index 0069c96ebdd4..4c2ad0d9462a 100644
--- a/sys-libs/libsemanage/files/libsemanage-2.7-build-paths.patch
+++ b/sys-libs/libsemanage/files/libsemanage-2.7-build-paths.patch
@@ -30,8 +30,8 @@ index ef25902..7aad334 100644
$(RANLIB) $@
$(LIBSO): $(LOBJS)
-- $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -lsepol -laudit -lselinux -lbz2 -lustr -L$(LIBDIR) -Wl,-soname,$(LIBSO),--version-script=libsemanage.map,-z,defs
-+ $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -lsepol -laudit -lselinux -lbz2 -lustr -Wl,-soname,$(LIBSO),--version-script=libsemanage.map,-z,defs
+- $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -lsepol -laudit -lselinux -lbz2 -L$(LIBDIR) -Wl,-soname,$(LIBSO),--version-script=libsemanage.map,-z,defs
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -lsepol -laudit -lselinux -lbz2 -Wl,-soname,$(LIBSO),--version-script=libsemanage.map,-z,defs
ln -sf $@ $(TARGET)
$(LIBPC): $(LIBPC).in ../VERSION
diff --git a/sys-libs/libsemanage/libsemanage-9999.ebuild b/sys-libs/libsemanage/libsemanage-9999.ebuild
index 5fdf0a04c988..53094b8c6e86 100644
--- a/sys-libs/libsemanage/libsemanage-9999.ebuild
+++ b/sys-libs/libsemanage/libsemanage-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -88,8 +88,7 @@ multilib_src_compile() {
if multilib_is_native_abi && use python; then
building_py() {
- python_export PYTHON_INCLUDEDIR PYTHON_LIBPATH
- emake CC="$(tc-getCC)" PYINC="-I${PYTHON_INCLUDEDIR}" PYTHONLBIDIR="${PYTHON_LIBPATH}" PYPREFIX="${EPYTHON##*/}" "$@"
+ emake "$@"
}
python_foreach_impl building_py swigify
python_foreach_impl building_py pywrap
@@ -104,8 +103,11 @@ multilib_src_install() {
if multilib_is_native_abi && use python; then
installation_py() {
- emake DESTDIR="${ED}" LIBDIR="${ED}/usr/$(get_libdir)" \
- SHLIBDIR="${ED}/usr/$(get_libdir)" install-pywrap
+ emake DESTDIR="${ED}" \
+ LIBDIR="${ED}/usr/$(get_libdir)" \
+ SHLIBDIR="${ED}/usr/$(get_libdir)" \
+ LIBSEPOLA="${EPREFIX%/}/usr/$(get_libdir)/libsepol.a" \
+ install-pywrap
python_optimize # bug 531638
}
python_foreach_impl installation_py