summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2022-06-16 02:37:48 +0900
committerAlice Ferrazzi <alicef@gentoo.org>2022-06-16 02:37:48 +0900
commit84708de9d9421f516ed308f6e1401a8f5a9eb108 (patch)
tree520d78e2ede4386929b1484b94904b17ca0f6954 /sys-kernel/kpatch
parentsys-kernel/kpatch: add 0.9.6 (diff)
downloadgentoo-84708de9d9421f516ed308f6e1401a8f5a9eb108.tar.gz
gentoo-84708de9d9421f516ed308f6e1401a8f5a9eb108.tar.bz2
gentoo-84708de9d9421f516ed308f6e1401a8f5a9eb108.zip
sys-kernel/kpatch: drop 0.6.3-r1, 0.7.1-r1
Signed-off-by: Alice Ferrazzi <alicef@gentoo.org>
Diffstat (limited to 'sys-kernel/kpatch')
-rw-r--r--sys-kernel/kpatch/Manifest2
-rw-r--r--sys-kernel/kpatch/kpatch-0.6.3-r1.ebuild85
-rw-r--r--sys-kernel/kpatch/kpatch-0.7.1-r1.ebuild98
3 files changed, 0 insertions, 185 deletions
diff --git a/sys-kernel/kpatch/Manifest b/sys-kernel/kpatch/Manifest
index 7f0a7421083b..ba8ec801896f 100644
--- a/sys-kernel/kpatch/Manifest
+++ b/sys-kernel/kpatch/Manifest
@@ -1,4 +1,2 @@
-DIST kpatch-0.6.3.tar.gz 153100 BLAKE2B e95d1880ffc9ff6038bba98902d0f1e97c9f7f8d0f90eedc281c4bf0570217668cf7b701d038d6f06e9885ebdbb4407cc554d5175cf17eb8fd5051381f75deb3 SHA512 0d266dd837ad651d7f46047cf2c8de527d08274a885a154c53354f4b3c5679d91c766d7d42294ffe71cc548e5ee865c7555f24001882b806f2fb48825f9b0c06
-DIST kpatch-0.7.1.tar.gz 181732 BLAKE2B da3ff8a6bbd31c3bdc353a3d2b75c6947b915fb309a6f19c57b31a6cbad1d82b9e1611bc2c412c5d049511e217a01719eb9a017d1fbbe7c7bbf2e5b02a381f40 SHA512 c1b149e9532dc16ee4f7578aadf3eda73b53c889a055229490a7afd1fca8e6df755c98c938353f937b81679fe8d08e065c473a6c31e588b1eb67f2de56bfddea
DIST kpatch-0.9.4.tar.gz 257885 BLAKE2B 3c84dd120b0b512e6a55d342b5950ce5d3a81c8c1e956f167bdb25c0c89dde5d4c2bd91fad687ab9eec4d6f965c21ff647f330f1fbcbfe560ca1f3cd37c6ac54 SHA512 647509fb9772b7564c0533ea043a15a66e29d413e045258036e78890c1d9cb072622bf458dda9bd4a87fe0855522c9b6ec3761f9bb4ab7e08157a179abfbaa62
DIST kpatch-0.9.6.tar.gz 260687 BLAKE2B 5c535af463f54d7be00fe987716dcb84ed17df69e4ccf5c0a6b4bde32704756c1c217ec43d9f338ce478ff6e0403e5c10f15055c56fbfa786b592b7d67427c6f SHA512 898c5704098c473187f2eab9bccd5fb3cfc31f4211492d658abcd0b7cac6d03f11a27df19a56ad17c20163803084ddf54a27defcf12b4975a8a8eb5dbad73f21
diff --git a/sys-kernel/kpatch/kpatch-0.6.3-r1.ebuild b/sys-kernel/kpatch/kpatch-0.6.3-r1.ebuild
deleted file mode 100644
index 175fecf308b0..000000000000
--- a/sys-kernel/kpatch/kpatch-0.6.3-r1.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit flag-o-matic linux-mod
-
-if [[ "${PV}" == "9999" ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/dynup/${PN}.git"
-else
- SRC_URI="https://github.com/dynup/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="Dynamic kernel patching for Linux"
-HOMEPAGE="https://github.com/dynup/kpatch"
-
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE="+kpatch-build +kpatch kmod doc contrib test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-crypt/pesign
- dev-libs/openssl:0=
- sys-libs/zlib
- sys-apps/pciutils
-"
-
-DEPEND="
- ${RDEPEND}
- dev-libs/elfutils
- sys-devel/bison
- test? ( dev-util/shellcheck-bin )
-"
-
-pkg_setup() {
- if use kmod; then
- if kernel_is gt 3 9 0; then
- if ! linux_config_exists; then
- eerror "Unable to check the currently running kernel for kpatch support"
- eerror "Please be sure a .config file is available in the kernel src dir"
- eerror "and ensure the kernel has been built."
- else
- # Fail to build if these kernel options are not enabled (see kpatch/kmod/core/Makefile)
- CONFIG_CHECK="FUNCTION_TRACER HAVE_FENTRY MODULES SYSFS KALLSYMS_ALL"
- ERROR_FUNCTION_TRACER="CONFIG_FUNCTION_TRACER must be enabled in the kernel's config file"
- ERROR_HAVE_FENTRY="CONFIG_HAVE_FENTRY must be enabled in the kernel's config file"
- ERROR_MODULES="CONFIG_MODULES must be enabled in the kernel's config file"
- ERROR_SYSFS="CONFIG_SYSFS must be enabled in the kernel's config file"
- ERROR_KALLSYMS_ALL="CONFIG_KALLSYMS_ALL must be enabled in the kernel's config file"
- fi
- else
- eerror
- eerror "kpatch is not available for Linux kernels below 4.0.0"
- eerror
- die "Upgrade the kernel sources before installing kpatch."
- fi
- check_extra_config
- fi
-
-}
-
-src_prepare() {
- replace-flags '-O?' '-O1'
- default
-}
-
-src_compile() {
- use kpatch-build && emake -C kpatch-build
- use kpatch && emake -C kpatch
- use kmod && set_arch_to_kernel && emake -C kmod
- use doc && emake -C doc
- use contrib && emake -C contrib
- use test && emake check
-}
-
-src_install() {
- use kpatch-build && emake DESTDIR="${D}" PREFIX="/usr" install -C kpatch-build
- use kpatch && emake DESTDIR="${D}" PREFIX="/usr" install -C kpatch
- use kmod && set_arch_to_kernel && emake DESTDIR="${D}" PREFIX="/usr" install -C kmod
- use contrib && emake DESTDIR="${D}" PREFIX="/usr" install -C contrib
- use doc && einstalldocs
-}
diff --git a/sys-kernel/kpatch/kpatch-0.7.1-r1.ebuild b/sys-kernel/kpatch/kpatch-0.7.1-r1.ebuild
deleted file mode 100644
index 2a2b069afca4..000000000000
--- a/sys-kernel/kpatch/kpatch-0.7.1-r1.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic linux-mod
-
-if [[ "${PV}" == "9999" ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/dynup/${PN}.git"
-else
- SRC_URI="https://github.com/dynup/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="Dynamic kernel patching for Linux"
-HOMEPAGE="https://github.com/dynup/kpatch"
-
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE="contrib +kpatch +kpatch-build kmod test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-crypt/pesign
- sys-libs/zlib
- sys-apps/pciutils
-"
-
-DEPEND="
- ${RDEPEND}
- dev-libs/elfutils
- sys-devel/bison
- test? ( dev-util/shellcheck-bin )
-"
-
-PATCHES=( "${FILESDIR}"/${P}-disable-dwarf-compression.patch )
-
-pkg_setup() {
- if use kmod; then
- if kernel_is gt 3 9 0; then
- if ! linux_config_exists; then
- eerror "Unable to check the currently running kernel for kpatch support"
- eerror "Please be sure a .config file is available in the kernel src dir"
- eerror "and ensure the kernel has been built."
- else
- # Fail to build if these kernel options are not enabled (see kpatch/kmod/core/Makefile)
- CONFIG_CHECK="FUNCTION_TRACER HAVE_FENTRY MODULES SYSFS KALLSYMS_ALL"
- ERROR_FUNCTION_TRACER="CONFIG_FUNCTION_TRACER must be enabled in the kernel's config file"
- ERROR_HAVE_FENTRY="CONFIG_HAVE_FENTRY must be enabled in the kernel's config file"
- ERROR_MODULES="CONFIG_MODULES must be enabled in the kernel's config file"
- ERROR_SYSFS="CONFIG_SYSFS must be enabled in the kernel's config file"
- ERROR_KALLSYMS_ALL="CONFIG_KALLSYMS_ALL must be enabled in the kernel's config file"
- fi
- else
- eerror
- eerror "kpatch is not available for Linux kernels below 4.0.0"
- eerror
- die "Upgrade the kernel sources before installing kpatch."
- fi
- check_extra_config
- fi
-
-}
-
-src_prepare() {
- replace-flags '-O?' '-O1'
- default
-}
-
-src_compile() {
- use kpatch-build && emake -C kpatch-build
- use kpatch && emake -C kpatch
- use kmod && set_arch_to_kernel && emake -C kmod
- use contrib && emake -C contrib
- use test && emake check
-}
-
-src_install() {
- if use kpatch-build; then
- emake DESTDIR="${D}" PREFIX="/usr" install -C kpatch-build
- insinto /usr/share/${PN}/patch
- doins kmod/patch/kpatch{.lds.S,-macros.h,-patch.h,-patch-hook.c}
- doins kmod/patch/{livepatch-patch-hook.c,Makefile,patch-hook.c}
- doins kmod/core/kpatch.h
- doman man/kpatch-build.1
- fi
-
- if use kpatch; then
- emake DESTDIR="${D}" PREFIX="/usr" install -C kpatch
- doman man/kpatch.1
- fi
-
- use kmod && set_arch_to_kernel && emake DESTDIR="${D}" PREFIX="/usr" install -C kmod
- use contrib && emake DESTDIR="${D}" PREFIX="/usr" install -C contrib
-
- dodoc README.md doc/patch-author-guide.md
-}