summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2022-09-04 17:42:38 -0400
committerMike Pagano <mpagano@gentoo.org>2022-09-04 17:42:38 -0400
commitb8083bab86f3a2aa64d9436187ad9755849652c1 (patch)
treec4efe6c5fab7bce69c688128be4a51e2700883ac /sys-kernel/git-sources
parentnet-wireless/gr-ieee802154: minor cleanup (diff)
downloadgentoo-b8083bab86f3a2aa64d9436187ad9755849652c1.tar.gz
gentoo-b8083bab86f3a2aa64d9436187ad9755849652c1.tar.bz2
gentoo-b8083bab86f3a2aa64d9436187ad9755849652c1.zip
sys-kernel/git-sources: add 6.0_rc4
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.0_rc4.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index ca56a611823e..4e7336accdc5 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -2,3 +2,4 @@ DIST linux-5.19.tar.xz 131581464 BLAKE2B 4db03a6830a3b3bbf0837e1912182a443d9a4aa
DIST patch-6.0-rc1.patch 107038239 BLAKE2B bea392cf4596fe326b58c08c20918bfe34d9bfb4ee8fca35b5930c35b44b721771ddd8d82fcb1c39f87b9fd3f072ca4e50417009346f0dcd97b930bcaa09c3fd SHA512 12113138533109c9939c8d1eae8982a4abaccc4c591c8d8f6a76e61a26bb04df94bd9074c2ce70126f712f7db031c6c2c7fdee3ff038e6926cb4aa5b7353e038
DIST patch-6.0-rc2.patch 107549416 BLAKE2B a4fefa99fab946258b1fc4c2cd3e8cd92de4047e53f6695ceaebc67d62d11df267dbc34d8f5e3ed1517dc98fb4cd4d8c8d0ce5cefe9b211b3ce63a6efe60f5c0 SHA512 cc950717e1ccc7d3e4b7222db2f368e3a7377bcf7c4c1999b6e921ebfb5c71547747c2dd2465ce4c1880fe966108b1b0474d76d6ea014bfe70493245c644d631
DIST patch-6.0-rc3.patch 107861796 BLAKE2B 201851c3bb54d6af7a481b0b88067d738e0bb8c71b4aa422914d20c70a09724a35e0a770dad95143c7718496c30087d912328d8780b3ffa6fe8579526742a547 SHA512 f27886b6ccafc2b7dda42f997c960ff2cacdeaf653dbdbc7148cf8286599461c7c716dc0f57b7ead0c609791fa70ba94ee4a7a41e047910bf753ffe921cbdbd8
+DIST patch-6.0-rc4.patch 108161851 BLAKE2B 095c03da992f3b2ea26aaea3a10fa4efded546bb409e7580f689cd312dce77378397525776b9b138c158dbf59cd3061db99f48919afb003f3766965050b381ce SHA512 1386f9ac2fdfc5fbf07e524ed573be4f0df00fd2c0add97289e3d98ce36441339f81bfd3106dabf79898de50b363eff2f7cc88d03746f578b299fa13a0000438
diff --git a/sys-kernel/git-sources/git-sources-6.0_rc4.ebuild b/sys-kernel/git-sources/git-sources-6.0_rc4.ebuild
new file mode 100644
index 000000000000..6789923d7615
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.0_rc4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.19"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}