summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2025-02-17 14:07:02 -0500
committerMike Pagano <mpagano@gentoo.org>2025-02-17 14:07:02 -0500
commit768a410b25ea337780a343b60459def6baf9eaf9 (patch)
tree86362b1b4e4a3641b2c35fca31dbe9f607e76db1 /sys-kernel/gentoo-sources
parentkde-plasma/kwin: backport fix for LTO (diff)
downloadgentoo-768a410b25ea337780a343b60459def6baf9eaf9.tar.gz
gentoo-768a410b25ea337780a343b60459def6baf9eaf9.tar.bz2
gentoo-768a410b25ea337780a343b60459def6baf9eaf9.zip
sys-kernel/portpeek: add 3.2.6, version bump
Don't break on USE_EXPAND Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/gentoo-sources')
-rw-r--r--sys-kernel/gentoo-sources/portpeek-3.2.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/portpeek-3.2.6.ebuild b/sys-kernel/gentoo-sources/portpeek-3.2.6.ebuild
new file mode 100644
index 000000000000..1ca2dd9b0ff4
--- /dev/null
+++ b/sys-kernel/gentoo-sources/portpeek-3.2.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9,10,11,12,13} )
+
+inherit python-r1
+
+DESCRIPTION="A helper program for maintaining the package.keyword and package.unmask files"
+HOMEPAGE="https://github.com/mpagano/portpeek"
+SRC_URI="https://github.com/mpagano/portpeek/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~sparc ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=app-portage/gentoolkit-0.6.7
+ || (
+ >=sys-apps/portage-3.0.65-r1[${PYTHON_USEDEP}]
+ )"
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}
+ doman *.[0-9]
+}